Well this is a terrible work around, but I thought I might share it with people. Mainly where I need to get PDF's from, is from a website which I need a secure login (Uni student I log into the VLE - virtual learning environment). As far as I know this causes a problem for the TP and I havn't come across another work around apart from using this, which is a little obvious, but I thought I might share.

Install linux on to your TP using the Ubuntu Chroot method. Use chromium (found this ran a little faster than firefox) and download any PDF's you want, save this where ever you like within the Ubuntu file structure in the partition you have made. So you could view them with Ubuntu if you want however it's not particularly nice. What I have found is that using Internalz file manager you can then access that partition you have made copy the PDF to some where within the webos file structure and then open it, using Internalz etc. I have found this worked for me, I haven't tested it thoroughly, but it worked with the one PDF I tested.

I hope this helps, because this bug with the PDF's has driven me absolutely MAD, and has driven me to the edge of having to return my TP because this is vital function that any tablet I own must do.

Kind Regards