Results 1 to 6 of 6
  1.    #1  
    Not sure what happened, but my TouchPad's screen won't turn on. It was working just fine less than an hour ago. The home button just keeps on blinking as if there's a notification, yet how ever way I press the power button or any button for that matter, nothing happens.

    Any ideas? Greatly appreciate the help

    Thank you

    Edit: Chatted with HP/Palm webOS support and followed these steps

    The last one, step 6. If the device still does not power on, press the power button and Center at the same time for approximately 15 seconds or until the HP logo appears. - Worked like a charm.
    Last edited by laurice; 08/09/2011 at 05:25 AM. Reason: Resolved
  2. #2  
    Hold home and power for a good 10 seconds or so. Alternatively, hold power while tapping home a bunch. You should eventually get it to reboot.
  3.    #3  
    ^ Thanks so much, yup that worked
  4. #4  
    No problem. Out of curiosity, did this happen on 3.0 or 3.0.2? I've had the problem a number of times before the update, but none after updating so far.
  5.    #5  
    The opposite actually. 3.0.2. Got the device on July 15th. Didn't have that problem before the update. My boyfriend on the other hand, had the issue a couple of times on 3.0. So I guess it's not version specific.
  6. #6  
    My touchpad was completely dead and unresponsive in the morning. This was after using it immediately before going to bed reading a kindle book then placing it on the touchstone. In the morning it didn't even appear to be taking charge, no lights, no heat from charging, nothing. Also none of the extensive list of strategies to hard reboot or reset it worked. The step I had to take was to leave it to lose all charge for a couple of weeks. I then placed it on a touchstone and the home light began to blink, then it started taking charge. The lesson learnt was to close all apps before leaving it to charge.

Tags for this Thread

Posting Permissions