Results 1 to 7 of 7
  1. FoneFreak's Avatar
    6 Posts
    Global Posts
    45 Global Posts
    I purchased my Touchpad last Thursday from Staples and they overnighted it to me for Friday. After reading the poor reviews I was a little nervous, but after a week with it I knew it was a keeper. Yes, there are some bugs here and there but it's 2 updates away from being substantially better and I'm an early adopter, so I expect bugs in the beginning.
    I was an original Sprint Pre owner and got mine on launch day and went through 7 Pre's before I couldn't take the cheap hardware build and switched to the Pixi as I still loved the OS and Android wasn't doing it for me at that point.
    Now I'm on Verizon and anxiously awaiting the Pre 3, but I have come across a major hardware failure that has me remembering the old Pre days unfortunately.

    I got home last night to a completely dead Touchpad I left it in standby mode on my Touchstone charging and when I went to use it later in the night it it was dead. Off and no matter what I have tried it won't turn on. I tried charging it with the plug-in charger and still nothing.

    Does anyone know of a master reset to try? Has anyone else had one that did the same thing? I'm about to bring it to my local Staples to swap out as I know they have it in stock after calling their customer service to find out what I should do.
  2. #2  
    Here is HP's suggestion:

    Step 3: Trigger a restart

    Press and hold Power. While still holding down Power, press and hold Center until the HP logo appears (about 15 seconds).

    Palm Support : 5Ts: Five ways to get your webOS tablet working again
  3. #3  
    hold the power and home button for 15 sec then let got the power button.. it should reboot.. ( like reseting the ipod).
    worked for me.
  4. #4  
    also try plugging in the usb to a pc...
    I haven't had any problems like this thus far but I do remember reading that someone had a similar problem and hooking it up to a computer worked for them... good luck
  5. #5  
    Just FYI... The few times when I've had to use the 'power & home buttons' to restart my TP, the TP had to be UNPLUGGED. For whatever reason, it would not turn on unless I took it of the charger. Hope that helps.
  6. FoneFreak's Avatar
    6 Posts
    Global Posts
    45 Global Posts
    Thanks for the response. It's funny as I didn't know that was the official way to reset it, but I tried doing that process earlier today from using Ipods and Ipads and it didn't do anything either. I really wonder what happened as I never powered it down to begin with. Very odd, but I guess a warranty replacement is in my future this afternoon.
  7. #7  
    Hope you get this fixed, I had a similar issue but, thankfully, the reset did resolve the problem. Yes, there are things that need to be improved but, like you, I know the TP will be brilliant. Good luck with getting a replacement - please let us know how good (or otherwise) the return and reissue works!

Posting Permissions