Results 1 to 4 of 4
  1. oliverh72's Avatar
    5 Posts
    Global Posts
    7 Global Posts
    Hi all,

    So here's my issue. I bought an unlocked AT&T Pre 3 from a guy in the states on Ebay. He said it was new, but I think he'd used it a few times at least. I open it up and put in my SIM. It recognizes my network (Telus) and doesn't ask for an unlock code. But, there's no 3G in the top right, just 4 bars.

    I try to log in to activate the phone, but it doesn't work - it basically has no connection. I can use the phone though.

    So I searched the forums. Went into developer mode using the dialpad. Restarted. No problem, Installed Preware and Impostah and used WiFi to login to my account. That all worked fine, but I've still got no mobile data.

    My manual APN doesn't work and under Device Info (can't remember the exact name of the app), it says that my network is AT&T though in the top left, it says Telus. So I did more reading and some people said that only a reset would fix it. So I did that. Now I'm back at the sign in page with no 3G in the top right again.

    So before I run through this all over again, does anyone have any tips? Please be somewhat descriptive as I haven't had a pre since my Pre2 in early 2011. I don't know all the lingo and methods of things but I'll try. I tried to call my voicemail while in DevMode and that worked just fine, so clearly the phone is unlocked. It just has no mobile network whatsoever. It's not much good to me as a wifi-only toy.

    Thoughts? Am I missing something obvious?

    Thanks in advance,

  2. #2  
    Where are you based in Canada? I might be able to look up the exact details for you based on that
  3. #3  
    click on phone App
    Top left drop down menu
    Prefs & accounts
    scroll down to where it says Network.
    make sure Data Roaming is Enabled
    Data Usage On

    I hope this helps.
  4. oliverh72's Avatar
    5 Posts
    Global Posts
    7 Global Posts
    Thanks for the replies.

    So I got this to work, somehow. Who knows why it wasn't before, but I reset the device and then added Telus into the APN settings again. This time, it accepted the APN and I got 3G within a few seconds.

    After that, everything has worked flawlessly.

    Thanks for your help.


Similar Threads

  1. Activation of unlocked Verizon Pre 2
    By fahzz in forum North American Carriers (CDMA)
    Replies: 14
    Last Post: 09/19/2011, 11:57 AM
  2. Replies: 41
    Last Post: 05/15/2011, 02:28 AM
  3. Activation Bypass for Unlocked Pre 2 not working with 2.1
    By GMTesta in forum webOS Development
    Replies: 5
    Last Post: 03/19/2011, 06:43 AM
  4. Palm Pre Plus activation on Rogers Wireless / Canada
    By sabesh in forum Palm Pre and Pre Plus
    Replies: 13
    Last Post: 09/30/2010, 03:57 PM
  5. Need Help: Activation of Unlocked Verizon Pre Plus?
    By zak123 in forum Palm Pre and Pre Plus
    Replies: 1
    Last Post: 05/11/2010, 11:03 AM

Tags for this Thread

Posting Permissions