Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By boovish
  1. mc25mc's Avatar
    61 Posts
    Global Posts
    63 Global Posts
    Help please!!!!! I've been enjoying my AT&T Pre3 since last fall with very little problems. I have preware and a few patches. Haven't loaded anything since NDrive about 2 months ago. Put it in my pocket around 8AM this AM and when got to work, phone was turned off. I tried holding power button in, nothing. Pulled the battery a few times, nothing. I've let it charge (wall mount) all day and still nothing. No plug in symbol, USB, anything, just a black screen. Tried connecting to CPU and the CPU doesnt even recognize it.

    I've said all along, if no new webOS devices come out, I'n gonna go back to a dumb phone and just keep my touchpad with me everywhere - I hope I don't have to live up to that statement,

    It seems like the phone just isn't getting any power at all. Any suggestions??

  2. mc25mc's Avatar
    61 Posts
    Global Posts
    63 Global Posts
    just noticed the little litmus paper by where the battery attaches is red. i believe this is what they use to tell if it has gotten wet. it is red! it has not ever gotten wet. we've had some pretty bad humidity lately, but it has never been in water???
  3. #3  
    try plugging it in without the battery. If not its dead and you should hold a proper funeral for it
    Rookie4sho likes this.
  4. #4  
    May sound silly, but make sure there is not something blocking the proximity sensor near the top. Even some screen protectors have caused the screen to stay off as it thinks it is next to something.
  5. #5  
    it's quite easy to replace it by another nd logon to same account. only pictures and recordings will be missing

Posting Permissions