Results 1 to 4 of 4
  1.    #1  
    I cannot buy apps on my Pre 3. It constantly says "Purchase failed". Freebies install just fine and with the same account, same access country and same credit card I can buy apps on my Touchpad. So I don't see why it doesn't work on my Pre 3.

    OS: 2.2.0
    Access country: DE

    I tried on both Wifi and 3G, several times, several apps and with several phone restarts. Also, Impostah says "true" when looking up if I can get paid apps.
    Still, on my Touchpad I can buy anything I want (I in fact bought several apps) with the same account, same credit card and same access country.

    Anyone here who knows that the problem might be?
  2. #2  
    Try an Erase Apps and Data from Device Info, and be sure to make a backup of everything first.
  3.    #3  
    Already tried that, but still it says Purchase failed on my Pre 3 while on my TP works fine
  4.    #4  
    Okay, I rebooted and now it does work. But it's a bit flakey. Sometimes it works, sometimes it doesn't.

Posting Permissions