Results 1 to 3 of 3
  1.    #1  

    i just purchased a cingulair treo 650 3 days ago from singulair, very excited about this. i have never owned a palm pilot deviceand love that this has camera, mp3 player, phone and the palm device organization stuff...

    i charged the battery for 24 hours, it seems simple enough according to the manual to power up the phone pressing and holding the red phone icon key, from there it is all a blur...

    i try to use the stylus to click things on directly on the screen but nothing activates. i also tried to initiate a phone call but it wouldnt seem to call when the green icon phone button is pushed. i am pretty sure nothing is wrong with the device, the guy in the store helped me make an initial call and even got me on the web for a minute, i was blown away by the web browsing features...

    basically, i want to be able to pretty rapidly make phone calls, create a contact list, browse web, learn how to do initial palm pilot type stuff. is there anything i am doing wrong here? the manual seems simple enough, i know i am turning on the phone AND the palm piolt, maybe i am not activating something right, any ideas or beginners advice, much appreciated, i run a reggae festival here in california and this device in theory should make my directing this show a breeze with its ability to remotely access web and e-mail in the field as well as make calls, take some pictures etc...

    my show is pretty big show and i got to learn to use this thing properly fast. prior to this, all i have is cheap go-phone from AT&T and a home computer whereby i do my internet work and such,

    any help or advice or guidance is much appreciated!

    sincere, jahguide
  2. #2  
    To solve the touchscreen problem, I would try to calibrate the touchscreen. Go to System->Pref.-->Touchscreen-->then click on the targets. This should hopefully solve the touching the treo with your stylus problem.
  3. #3  
    Maybe your signal is messed up. Sometimes when Im in that house I cant get any calls out.

Posting Permissions