Results 1 to 9 of 9
  1.    #1  
    Hi, I was wondering how to get my Treo to work as a modem for my PC. I've installed PDAnet, but it never works. Is there another way to get the Treo to act as a phone line for my PC's dial-up?

    <a href="">TerribleMovies.Com</a>
  2. #2  
    What is the problem you're having with PDANet? And what is your carrier?
    I have problems with PDANet 3.0 and Cingular with the default settings, but I've found a workaround.
    In all honesty, once you get PDANet working, it really is the easiest way to use the Treo as a Modem.

    There is a "tethered" mode for the treo.
    On a GSM Treo, on the keypad dial #*83843733 (##83843733 for Sprint/Verizon CDMA) and then dial. The screen will show "tethered" and the phone is now in tethered mode.
    When in tethered mode, the treo acts like an external modem on the serial cable. Not, you'll have to find serial cable or cradle to use it in this mode as there is no way to get a virtual COM port on the PC for the USB cable.
    How to get it to work at this point, I don't know. You have to use the AT command set (modem commands) and think you dial *99***1# to get it to use the GPRS data for your modem (as opposed to dialing in to an ISP.)

    SO it's not terribly simple and if I ever get a serial cable and figure it out, I'll certainly post how I did it since no one else has.

    Meanwhile I hightly suggest you give in an use PDA Net. There should be a way to make it work. Put it this way, if you can't get PDAnet to work, I don't know how you'll get the tethered mode to work.
  3.    #3  
    Hey, thhanks a lot for the info. My problem though is that PDAnet starts to connect fine, but then when it starts to verify the username and password, I get an error message:
    "Dialup failed, error=734 (state=6)!"

    So I'm a bit lost at this point...
    <a href="">TerribleMovies.Com</a>
  4. #4  
    See my post at the bottom of page 3 of this thread:
    I describe this exact same error. I choked on it for days. PDA Net 2.5 worked great, but I couldn't get PDA Net 3.0 to work.
    The problem:
    PDANet is supposed to automatically configure the user name and password for the access point when using it's "defualt connection." Somehow this was broken for cingular in 3.0.

    The workaround:
    Essentially create a custom connection with the right setting.
    1) Right clickon the PDANet icon in the task bar at the bottom right corner of the screen. Chose "Settings..."
    2) Select "Selected Dial-Up Network Entry Below (Advanced.)
    3) Click "Create new customized entry." It will create an entry called "PdaNet Modem (Customized)"
    4) Click on "(More...)" to open the Windows network connections window.
    5) Right click on "PdaNet Modem (Customized)" and select 'Properties'
    6) Select the 'Options' tab at the top.
    7) Under 'options' check the box "Prompt for name and password, certificate, etc."
    8) Click "OK" to exit.
    9) Go back to the PdaNet Settins window, make sure "PdaNet Modem (Customized)" is highlighted, and click the "OK" button to close the window.
    10) Now start PdaNet on the treo. Select "Cingular Express" as your connection
    11) On the windows desktop you'll get a login window asking for User Name and Password. Use:
    WAP@CINGULARGPRS.COM as the user name
    CINGULAR1 as the password.
    Check "Save this user name and password." and select "Anyone who uses this compuiter" then click "DIAL"
    12) If all is well, you should connect to the internet through your treo. You should be able to start web browsing.
    13) Now Disconnect (click disconnect on the treo)
    14) Go back to the windows Network Connections window. Right click on 'pdanet modem (customized)', select properties, clickon the options tab, and uncheck "Prompt for name and passwrd... etc."
    The purpose of step 14 is so that you can connect with PDAnet without it poping up the user name and password window every time. Now that the user name and password are stored it'll just do it automatically.

    That's it. Make sure to leave the "phone number" as *99***1# dont' change it. This is how it uses GPRS for your data rather than attempting to use CSD (Circuit switched data, aka dial up which uses your minutes and is slow)

    Let me know if this works.

    -Taylor Hively
  5. #5  
    I EMailed PdaNet and got a response that they believe the problem was related to the download link on their web page.
    They said to try re-downloading PdaNet and try again.
    Indeed I did download PdaNet 3.0 again, re-installed it (on both windows and the Treo) and voila, the problem is fixed. You can use the default connection and don't need to use my workaround.

    So try re-downloading pdanet. It should fix the issue.

  6.    #6  
    Hey! I downloaded the new version and it fixed the problem. Thank you so much though for posting all the steps anyway, I really appreciate it!!
    <a href="">TerribleMovies.Com</a>
  7. #7  
    Good info.
  8. #8  
    Hmmnn. That is very interesting. On my GSM Treo600 (Rogers network), I get some interesting results.

    1. Connect Treo to laptop via serial hotsync cable (not USB).
    2. Start terminal emulator on laptop, set com port to 115200 8N1.
    3. Enter #*83843733 sequence and tap Dial, Treo goes into Tethered Mode with a single Stop button onscreen.
    4. On laptop in terminal program, enter AT and receive an OK response. Enter ATDT*99***1# and receive the response "CONNECT".

    Hmmnn. Now what do I do to use the connection??? Must need to use a dial up networking connection to manage a PPP connection, instead of the terminal program. Will do some experimenting...
  9.    #9  
    That seems pretty interesting. Another question I have is whether I use this PDAnet as a dialup modem? I've tried, but everytime it starts to dial, I get disconnected.... Any advice?
    <a href="">TerribleMovies.Com</a>

Posting Permissions