Results 1 to 11 of 11
  1.    #1  
    Good one:

    Got the dreaded no-flip dead radio. Tried the Jog dial - battery drainer - dead radio fix. No go. Also, battery will no longer hold its charge. It charges ok but completely drains in about an hour. This happened directly after the radio died and before I applied the dead-radio fix.

    It's almost like the radio is clocking overtime and thus, draining the battery ?

    Got another Treo so I'm ok but is this one destined for my Treo parts bin?
  2. #2  
    That's sounds like what happened to mine...I had done a hard reset, and after that there was no handspring flip guy, and Treo wasn't connecting to a network...tried resetting a few more times with no luck and gave up for the night. The next day, i look at the treo, and the battery is in the red, after being fully charged the night before and even though i had wireless off. Took Treo to a T-Mobile store to check if my SIM was bad...but it wasn't the SIM... Called Handspring that night, agreed to the $20 support fee, the second i told the tech i wasn't getting a flip, he sent me to a webpage with the radio reset utility and also said that it was a covered issue, so I didn't owe them the 20 bucks...downloaded the radio reset utility, installed it, ran took a long long time to drain the battery (6-7 hours). Once the battery drained completely, and i recharged completely, flip guy showed up and I was back in business.

    So what does that mean for you? That most likely your battery is fine, the quick draining effect is a result of the noflip and not a seperate issue. As for why the radio reset didn't work for you...I'm not sure...the page i was sent mentioned that the radio reset I was downloading was different from that available to the general public. I wish I could remember the link (I'm trying), but I believe someone else has posted it somewhere...

    Did you get the radio reset you ran from ?

    I would attempt to drain the battery a few more times...perhaps give handspring a call and see if there is a different version of the radio reset utility (though I honestly don't know what difference there could possibly be between utilities that drain the battery down...), because i definitely remember my download page saying it was not for the general public and to not make the URL available to others, though that may no longer be the case.
  3. #3  
    Have you tried unplugging the battery inside? Someone like you should not be afraid to open the case up
  4.    #4  
    Tried the battery disconnect fix. Now when I try and turn on the radio, Treo180 completely hangs. The hang times out after a few minutes.

    Clogoodie: Thanks for the HS radio-reset link. I will give that a go.

    Appleman: You are indeed correct. As I do not like the fliplid, I have installed my 270 guts in the 180HFL case. HFL looks even cooler in colour
    ps. Appleman, can you send me a private (off discussion group) email to ?
  5.    #5  
    Progress, albeit minimal

    Tried the dead-radio fix from HS. It took about an hour to drain the battery.

    Fully charged Treo and still no Flip (tried two different SIMS). The good news is Treo no longer hangs.

    I will try the HS fix again... fingers X'd
  6. #6  
    I wish I could explain why it worked for me, and why it doesn't seem to be working for everyone else...

    Is the battery still draining rapidly or did that get fixed? Perhaps the second time is the charm for flipman...
  7.    #7  
    Tried the fix again last night and back to square 1. Treo hangs and battery drains in about an hour.

    I think it's cactus
  8.    #8  
    Just noticed 'liujf' had the same problem I'm describing.

    I'm gonna try the GPRS update again and see if it works for me.

    liujf - Thanks for the post
  9.    #9  
    Had to trick GPRS Updater... because I couldn't get a network I couldn't complete the install of the Updater. Used 270 to establish a network, read my Service provider info from the SIM and then replaced 270 with broken 180.

    Worked a treat. Dead radio is no more...
  10. #10  
    Glad to hear it...

    Has anyone figured out what causes the problem?
  11.    #11  
    Originally posted by clogoodie
    Glad to hear it...

    Has anyone figured out what causes the problem?
    Wish I knew. Maybe one for the X-Files.

    ps. Thanks for your help

Posting Permissions