I have a serious problem. My Treo 270 was working fine till I installed 2 games, namely Blocks from http://www.electronhut.com/games/ and smallWare Solitaire Free 3.5.2, both found at download.cnet.com. After performing an HotSync to install these, after a while I tried dialing and the treo failed to dial!

Suspecting that these two softwares may have caused the issue, I tried the following:

1. I deleted these 2 apps. from the delete option in treo.

2. When that didnt work, I performed a soft reset but to no avail.

3. Then I deleted these 2 from the backup folder of the desktop.

4. I then performed a hard reset.

5. On turning on the wireless mode, after it did a Network Search, I got no service in the bottom left corner of the screen. I tried dialing and it gave me the error 'Network Error The network could not complete your call. To try again, wait a few moments, then tap Redial'. Pressing redial just repeated this again and again. Although, the signal strength wasing shown full.

6. After this, I hotsynced and restored my files barring the games.

7. On turning on the wireless mode again , I got the code 404-100 that I usually did when the phone was working. But on selecting a number to dial I got the same Redial error message that I quoted in 5. The signal strength was again full.

Now I am unable to dial out. Also, if I try dialing my own cellphone from another phone, I get the message that it is swtiched off. I have tried different sim cards also.

Please tell me what to do? I am extremely worried. All other apps. seem to be working normal. Its only with the wireless that I have the problem.