After waiting for aeons until my contract was activated, I could now take my Treo along with me. It is only a 180 at the moment, but I have the dealer's promise that he will exchange it for a 270 as soon as it is in store.

I tried installing the software on my company laptop (Win 95), but it does not support the USB port. (OK, Handspring's website told me before, but I wanted to give it a try, since all other USB devices I tried, mouses and digital camera, worked like a breeze. Seems to be a quite artificial problem.)

Than, I tried installing on my girlfriend's laptop. It runs OS X normally, but has the classic environment which normally supports all OS 9 apps. But somehow in this constallation, the Handspring software cannot access the USB port. Palm desktop from works though (OS X native version), and the other stuff like the Firmware Update has to wait until I get home to my XP PC.

But please, Handspring, support OS X soon, and do not impose homemade problems onto 95 users that have patched their system to use USB without any problem!

As soon as I have other experiences to talk about, I will continue in this thread.