I decided to try the Updater last night - sometime close to 1AM. I hoped for the best, based on some of the experiences I read about here and on treomb.com. The updater installed without a problem and the restore went through as well. Once the reset after the restore was complete, though, that's when things started going wrong. I tried to hotsync again to re-setup my wireless internet connection (throught Configure your Treo), and started getting various errors (sorry I don't remember what they were). Decided to do another hard reset and restore to see if it was consistent, and unfortunately it was - confirmed after two more hard resets. So I started to investigate on my Treo, as it seemed logical that something bad got restored to it post-hard reset. While going through the Preferences, I noticed that under Connections it was completely empty. So I performed yet another hard reset and examined the Connections immediately after the reset. All the default Connections were listed (Wireless Modem, Direct USB/Serial, IR, and Standard Modem). This told me that the restore was overwriting the Connections preferences with bad (blank, really) information. So I performed yet another hard reset, but this time before restoring, I moved the following files so they wouldn't be restored:


I included the last file because I felt that if the restore nuked the Connections database, it would likely do the same to the Network preferences database. I restored after moving those files and everything worked again. Hotsyncs succeeded, and I was able to reconfigure my wireless internet settings. So everything was fixed - at about 3AM...zzz. I do have some questions as a result of all this:

1) While ConnectionDB.pdb and NetworkDB.pdb were present, ConnectionMgrDP.pdb never got recreated. Is this file important? What creates it? I still have a recent, known good version of that file that I can restore if it is required.

2) Does running Configure your Treo multiple times create multiple Service entries in the Network preferences? When I was troubleshooting the problems, I ran Configure your Treo 3-4 times, and each time a new "My Wireless Window" entry was created. Even after I solved the problem, I ran it again and had two entries (one already present from the old NetworkDB.pdb (most likely) and another that was just created). Is this normal?

Thanks for reading through this long-winded post. And thanks in advance to anyone who can answer my questions.