Results 1 to 7 of 7
  1.    #1  
    First off please don't tell me to do a search because I have (spent two hours on it last night) and none of that helped. Second off if you guys don't know what to do don't worry I'll just use webosquickinstall on the school computers (xp).
    Long story short I have webosquickinstall and webosdoctor sitting in the same folder.
    I run javaw webosquickinstall.jar from command and it pops up "Could not find the main class: webosquickinstall.jar. Program will exit."
    I run java webosquickinstall.jar from command and I get this error:
    "Exception in thread "main" java.lang.NoClassDefFoundError: webosquickinstall/jar

    Caused by: java.lang.ClassNotFoundException: webosquickinstall.jar
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    Could not find the main class: webosquickinstall.jar. Program will exit."

    Same error. I do have some java programming experience and do know what the error means, but I also know the same program works on xp just fine. Why can xp find the main class and windows 7 can't? No idea.

    My system:
    Windows 7 64-bit
    Java 1.6.0_20 640bit
    WebOSquickinstall v3.14
    WebOSDoctor for v1.4.5 for pixi

    I also can't seem to associate opening of jar files with java for some reason. I try, go to Open With, Choose Default programs, Browse, find java or javaw, click it, and it doesnt get added to the list of default programs. This is minor though as webosquickinstall doesn't work anyway.
  2. #2  
    try this:

    java -jar webosquickinstall.jar
  3. #3  
    why do you want to run it from command just click the dang thing works for me windows 7 x64
    Sprint Palm Pre/Verizon Pre Plus On Sprint/Sprint Pixi Hybrid with WIFI
  4. #4  
    Yup, that works for me too. Never had to run from the command line. But if you do, you need the -jar after java. I think that is your problem.
  5. #5  
    I don't think this is a complicated issue. I would try uninstalling and reinstalling Java. I would also re-download Webosquickinstall(no need to do this with Doctor).

    If it doesn't work after that try compatibility mode switch.
  6.    #6  
    Got it to work thanks. For some reason my file associations are all screwed up when it comes to java. Always have been. Which is why I couldn't just double click it.
    Running it with Javaw -jar webosquickinstall.jar works
    So now I just need to associate .jar with javaw with the -jar parameter.
    Thanks again!

    Edit: both java and javaw work. As some may know, there is no difference in execution between the two; java displays error output while javaw does not.
    Last edited by mobone; 09/02/2010 at 11:27 PM.
  7.    #7  
    I got my file associations all figured out and am now able to open WebOSqi with java.exe by clicking, but I can't figure out how to tell java.exe its a jar file.
    Any ideas on how to pass the -jar command to java.exe? I tried adding -jar to the end of the shortcut

Posting Permissions