Page 5 of 27 FirstFirst 1234567891015 ... LastLast
Results 81 to 100 of 523
Like Tree12Likes
  1.    #81  
    Quote Originally Posted by Nightburn View Post
    Jason. Again, thank you for your continued support of the WebOS community.

    Excellent application. I do have a suggestion though. Please hear me out:

    I've been developing a theme and today I had a botched installed using WOSQI 2.96 on WebOS 1.4. I believe the XML didn't properly copy to the cryptofs. All my replacement images did properly install and WOSQI did create BACKUP files for each image replaced. However, neither Preware or WOSQI gave options to remove the theme.

    So, I set out to revert the theme back to default and because you recently posted this repair utility on the front page of precentral I decided to give it a try...

    The repair utility found all the BACKUP images but never prompted me to "restore" them. Is this because the repair utility assumes if there is a backup there must be a way to uninstall? In my case this wasn't true. I propose adding the option of being prompted to restore backup files.

    Of course it's possible I've completely missed something obvious and it's already doing this?

    I ended up manually fixing the files through WinSCP. Thoughts?
    interesting idea. In the meantime you could have enabled "Override Compatibility" and it would have removed the theme
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  2. #82  
    Quote Originally Posted by Jason Robitaille View Post
    It should have restored it. And given what you've said about the ipk, I'm willing to guess the files ARE still there, but for some reason it's not showing up in the launcher.

    Did you have Override Compatibility enabled? With it disabled, there's no way it would alter any installed packages
    This app is pretty awesome - thx so much for working on it. I do have a question though, and I want to make sure I'm doing this right.

    I'm trying to restore the PDF Viewer that I deleted by accident. I ran the repair utility the first time with the override off. It flagged two items, and neither appeared to be related to the PDF viewer, so I ignored them. The phone rebooted and the PDF viewer was not back.

    I then ran it a second time with the override on after reading this thread. It found a number of items and I told it to repair all. After that the phone rebooted. Again, the PDF viewer was not back.

    So I set the phone to run a third time, now that all the patches had been removed. This time the application found no issues. I manually rebooted the phone just to be safe. Again the PDF viewer was not back.

    I tried to add the application (thinking the file name was but the the repair utility says that it cannot find it in the WebOS Doctor. I also tried looking just for pdf and pdfviewer. No luck.

    Anyone know the name of the app to load it manually from the tools --> restore specific file option or why running the WebOS Repair Utility wouldnt notice it was missing and install it?
  3. #83  
    Quote Originally Posted by Jason Robitaille View Post
    interesting idea. In the meantime you could have enabled "Override Compatibility" and it would have removed the theme
    Yea, however, everything would have reverted back to default. Specifically my applied patches =/

    edit: or does it actually prompt for everything when in "override compatibility" mode ?
    Last edited by Nightburn; 03/17/2010 at 07:14 PM.
  4. Tomeygun's Avatar
    67 Posts
    Global Posts
    87 Global Posts
    little side note here:

    1) I too noticed no progress, only to move the side bar up and down and BAM, we were off and running...

    2) There are monay files that it simple says "file was missing or not found, would u like to repair", or whatever. I am suprised I was missing so many files, like 5-6 so far.

    Many thanks Jason, seems like there were many glitches on my phone I was not aware of and hopefully this fixes the lag I had been experiencing.
  5. #85  
    Couple of UI bugs, found in 2.0, not checked in 2.01:

    ~ If you select 'Override Compatibility' from the menu, it pops up a Yes/No box. If you select No, it turns it on anyway. Dangerous if you don't double check.

    ~ Verbose Reporting overwrites the previous log, without giving you the option to rename the old copy.
    Thought of the day :
    No sense being pessimistic, it probably wouldn't work anyway
  6. rattical's Avatar
    66 Posts
    Global Posts
    70 Global Posts
    Thanks Jason you are a true credit to the community...

    Hope everyone else can spare a few bones to send your way to show our gratitude!!
  7. #87  
    Ok i can not run this at all the version before this ran fine it keeps giving me a error number 22 while tryint to load this file any ideas just did a full arease and it left patches so somethings borked is there anything i need to know running windows
    others like 3.02 webosqi works fine. Please help i am getting beyond frustraited.
  8. CESantos's Avatar
    34 Posts
    Global Posts
    35 Global Posts
    Wow! How can that be?

    I'm a new Pre owner as of this past Monday (3/15/10). Everything seemed fine.

    Tuesday I upgraded to 1.4 and loaded some Apps and patches.

    Wednesday I couldn't use Sprint TV. I kept getting an error. This newbie figured maybe the site was down.

    Thursday, same thing. Hmmmm.. Then I realized I could not play (test) any of my ringtones. What's going on????

    Today I ran the magic WebOS Repair Utility 2.01.

    Presto!! Some 72 ( I could have miscounted) files were restored. I wonder what could have caused that? I now have Sprint TV and ringtone testing. I don't know what else could have been missing. The Apps and patches still seem to be there.

    What a job! You're an Ace!!
  9. #89  
    Lifesaver once again, much obliged Jason.
  10. #90  
    The latest repair utility (2.01) is not working for me. Will not start up.

    EDIT: Nevermind - after reloading everything it is now working, although it made me reload WebOS Doctor.
    Last edited by sir_mycroft; 03/20/2010 at 02:24 PM. Reason: Fixed
    VisorPhone Clone
    (Please do not thank me - I find it scary)
  11. #91  
    Thanks for all you do to keep our Pres up and running great.
  12. #92  
    Thanks for keeping up the hard work! We Pre-lovers appreciate it!
  13. #93  
    Restored my pdfviewer app with this today, no problems! =)

    Thanks Jason!
  14. #94  
    Great app and Great work. This may be the wrong place to ask, but I wonder if there could be an app made to backup the entire palm pre. The reason I ask, is that God forbid Palm went out of business, how would we have access to our currently purchased apps? It would be awesome to make our own WebOS Image that includes our apps.
  15. #95  
    can it help to restore phone v1.4 software on my gsm pre??
  16. #96  
    Jason, I am having some really weird behavior with webOS Repair Utility. When I try to start it (by double clicking) is just never opens. So I ran it from the command line and this is the result:

    C:\Documents and Settings\Administrator\Desktop\Pre>java -jar WebOSRepairUtility
    Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: com/palm/
    at ca.canucksoftware.repairutility.NovacomConnection.<init>(NovacomConne
    at ca.canucksoftware.repairutility.MainView.<init>(
    at ca.canucksoftware.repairutility.RepairUtility.startup(RepairUtility.j
    at org.jdesktop.application.Application$
    at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at Source)
    Caused by: java.lang.ClassNotFoundException: com.palm.novacom.Novacom
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 12 more

    It appears to be a problem with novacom. I have stop and restarted the service, rebooted the computer, and did the (re)installation of novacom through WOSQI.

    I have java 1.6.0_18 installed, dev mode is enabled.

    I am also seeing strange behavior in WOSQI (latest version), when I click on File --> Options, nothing happens, it never opens the Options window. In order to do the reinstall of novacom, I actually had to go back to version 2.5.

    Any ideas on what might be going on?
  17. #97  
    Quote Originally Posted by Mikey47 View Post
    Jason, I am having some really weird behavior with webOS Repair Utility. When I try to start it (by double clicking) is just never opens. So I ran it from the command line and this is the result:

    ..snip a whole bunch of stuff
    OK, this is really strange, but I think I have resolved the issue, of course, just shortly after posting the question.

    Apparently I had a failed webOSDoctor.jar download in the directory in which I was trying to run WOSRU and WOSQI. The webOSDoctor.jar file was only 3MB (yeah, right). So, when I deleted that file it took one of my other doctor files and renamed it to webOSDoctor.jar and it opened up.

    So apparently even though the java exception thrown seemed to be complaining about novacom, that was a red herring....
  18. #98  
    Sorry for posting three times in a row on this thread, but I just have to ask.

    Now that I got the utility running, I ran it and it replaced about 5 files it said were modified and replaced 3 that it said were missing.

    Just for grins, as soon as it completed I ran it again. I expected that it would go through and find nothing modified and nothing missing, but guess what it didn't... Why?

    All of the files it said were modified, appeared not to be modified, here is an example of the output:

    Scanning /usr/palm/applications/
    Found md5sum: caa1a31542514c6a3bb738fb8222e31e
    Expected md5sum: caa1a31542514c6a3bb738fb8222e31e
    Modified file found: /usr/palm/applications/

    Correct me if I am wrong, but those md5sum's are exactly the same, why would the utility say it was modified if the md5sum's were the same?

    In fact it also reported that it found several missing files too, that it apparently did not find during its first pass.

    Why would I see different results in two passes run immediately following one another?

    EDIT: Just ran it a third time and got completely different results. What gives? It reported that three files were missing. Before I clicked the restore button, I opened Terminus and looked for the files and they were already there -- why would it report the files as missing if they are already there?
    Last edited by Mikey47; 03/24/2010 at 09:06 AM.
  19. ricomann's Avatar
    18 Posts
    Global Posts
    23 Global Posts
    mine is in process as we speak.
    first ten minutes was no problemo, but now getting error 2 and 5

    error 2 : can't remember whta this one said...

    error 5: Command: put file:///usr/palm/frameworks/mojo/submissions/330/formats/gr.jsjsjs
    Reply: File open failed


    error 5: command: put file:///etc.udev/mount.blacklist
    Reply: File open failed
    etc... there were 10 or so of these.

    what gives? it has caught several screwed up ones....
  20. #100  
    Just ran it and found md5sum diff for mount.blacklist and version... The weird thing is that the "View Diff" button was greyed out... So I was unable to view the difference.

    Also, I have some issue uninstalling the "browser multi-mod" tweak (clicked by mistake on the checkbox in the WOSQI Tweaks which installed it) When I try to uninstall it I get an error (see attached image).

    WebOS Repair utility found no error related to this (default settings). I have some other patches that I don't want to remove... How can I restore the Browser app and remove this patch? (without being asked for every other patches)?

    Attached Images Attached Images
Page 5 of 27 FirstFirst 1234567891015 ... LastLast

Posting Permissions