Page 24 of 27 FirstFirst ... 14192021222324252627 LastLast
Results 461 to 480 of 523
Like Tree12Likes
  1. #461  
    i canot able download it til this tym. ...wat da heck the problem. .. pls help folks
  2. ludvball's Avatar
    57 Posts
    Global Posts
    73 Global Posts
    Quote Originally Posted by Growler48 View Post
    Does this work for Touchpads?
    I was wondering the same.
  3. #463  
    I can't get this to work.

    Doesn't seem to matter what I do, I'll either get an error in opening a "zip" file (yes, the file is a .jar, not a .zip), or it tells me that the versions don't match whenever I try to select the webos doctor.

    When the program tries to download the webos doctor, it doesn't have unlocked as a carrier, and none of the options list the pre2. I tried anyway, and got to a screen where it asked for the webos doctor. Selecting the one that the repair utility downloads tells me that it's not the right version. I selected the one that I downloaded from palm, which I know is the correct one (I downloaded it through my palm profile), and it won't open the "zip" file. I tried changing the name to WebOSDoctor.jar and removing all the other doctor files, and then the repair utility won't start up at all. I do get java processes over and over again when I double click on it, but it won't actually open it.

    I'm on windows 7x64, and using Palm Pre 2 with 2.1.0.

    Any ideas?
  4. #464  
    well jason does this or will this ever work on the pre3 or touchpad ?!
    Here is a direct link to webOS Doc for all carriers
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  5. #465  
    Well as the repair utility seems not to be working on 2.1++ versions of webOS, i did a repair "by hand". This is much handwork to be made, so be sure only doing this if everything else except doctoring fails AND you don't want to doctor right now.

    To not have to change to much files by hand, be sure to uninstall all Patches/Themes/ before
    a) First all manually by Preware or/and by Webosquickinstall - sometimes one achives more than the other
    b) then by Emergency Patch Recovery (EPR):

    c)- (sometimes there are old dangling patches here you could try to rebuild the IPKG datenbase to uncover those after that you should remove those by going to step a) again

    Sometimes this fixes e.g. patchinstall problems at this stage and you can stop.

    The whole process:
    1. Therefore i got the right doctor for my device from here:
    Webos Doctor Versions - WebOS Internals

    This one is needed if files are altered in the device and needs to be overwritten by original ones.
    I extracted the jar -> extracted \resources\webOS.tar -> extracted \resources\webOS\nova-cust-image-castle.rootfs.tar.gz

    2. Now it's up to checking the files on the device if they were altered. This is done by comparing the original md5sums of the files with the md5sums of files now.

    You need a terminal application installed on your device (i use SDL Terminal for webos 2.1 - not working for 2.2/3 atm i think) , or terminal access otherwise via ssh or xterm (search in forum for possibilities)

    There is a /md5sums.gz in the root of the device filesystem, this needs to be extracted or you extract the already locally on your PC available \nova-cust-image-castle.rootfs\md5sums.gz and exctract this and transfer the md5sums as md5sumsdoc to your devices root directory (via internalz copy or webosqi transfer).

    now there should be a
    in your devices root directory

    Now open your perferred terminal and enter
    cd /
    md5sum -c md5sumsdoc | grep -v "OK$" > /tmp/md5BAD
    (on sdlTerminal | (Pipe) is at SYM+X and > is at SYM+N - see your terminals help if needed)

    The md5sum checks the local files against the sums in the md5sumsdoc file and there can be outputs like : "Can't open file..." or
    "Warning xx of 16056 cumputed checksums did NOT match"
    The can't open files could be such als first which is ok
    The Warning shows you how many files you probably have to alter before having a clean device.

    3. The md5sum wrote a text file to /tmp/md5BAD which can be opend by Internalz and contains things like that (example is part of a patched calendar by Ubercalendar ) :
    ./usr/palm/frameworks/calendar/submission/29/concatenated.jsjsjs: $FAILED$
    ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$sources$.$json$: $FAILED$
    ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$javascripts$/$jumpto$.$js$: $FAILED$
    ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$javascripts$/$confirm$-$deleteevent$.$js$: $FAILED$
    ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$javascripts$/$recurrence$-$warning$.$js$: $FAILED$
    ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$stylesheets$/$week$.$css$: $FAILED$
    ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$stylesheets$/$datetime$.$css$: $FAILED$ ./$usr$/$palm$/$applications$/$com$.$palm$.$app$.$calendar$/$stylesheets$/$calendar$.$css$
    This is the point where you know which files to look for. If you advance to these files often there is a similar named file like calendar.css.webosinternals.orig which is the original file renamed by a patch which could not be referted, even if you took the patch-uninstall steps above. This is a good cause now you can simply rename the calendar.css to calendar.css_ and rename calendar.css.webosinternals.orig to calendar.css and you are done with this file (without having to transfer it from the unpacked doctor).
    I cases where no such webosinternals.orig file exists you have to get it from the extracted doctor.

    I was a little afraid overwriting files like:
    ./etc/palm/luna.conf: FAILED 
    ./etc/.rootfs_RW: FAILED 
    ./var/lib/update/ FAILED 
    ./var/lib/update/ FAILED 
    ./var/palm/event.d/datatransferassistant: FAILED
    So i kept these and for my repair it was enough to get things going again.

    4. At the end you can md5sum again and see if most of your files are stock again.

    Perhaps this posting helps a little bit, even if this is not the cool automagical way of repair utillity.

    thx to for the original command. I did not have to cut that md5sums on my pre2 2.1 device.
    petit13 and Jive Turkey like this.
  6. #466  
    Quote Originally Posted by kiukiukiu View Post
    Hope to see the utility with webos 2.1 support......I don't want to doctor my phone.
    Anyone who can update this project? I think there is tremendous value here for those of us on 2.1 +
  7. #467  
    Well, I finally had to swap my worn pre for a refurb. I put if off as long as possible since I knew I would probably lose some setting/apps in the process. It' been a long few days of preparing, backing up what I could, and restoring on the new phone. Well there are 8 apps that have been lost. I was able to restore preware and my loaded homebrews. Using installz restored my text messages. Then hastily installed the save google maps, forgot about step2 and installed the HP maps (which is really bing maps). So now I've spent another few hours of working to get google maps back.

    On a side note: There should be a law against companies being able to mess with my s/w and device without my permission. If it wasn't for the patch I wouldn't have even known that HP and microsoft were yet again going to exert their control over what I can do with my device.

    So the device is a little unstable now (every once in a while it locks up then starts working again in couple of minutes). It has only self-rebooted once after locking up. I've rebooted it a few times but I would like to run webos repair tool on it.

    The link page keeps timing out. I know there is a comment the it requires 10 posts first. Not wanting to clog up the site, just to get the file I have been reading all over the posts without a path to get the file. So here's my first post.

    I have to thank precentral and all the wonderful work everyone has done. The support from Palm and sprint are really lacking for changing phones and keeping everything intact. I just find that to be a poor design and poor specs on the part of the service provider. Thank you so much for this site.
  8. #468  
    In the past I've doctored the pre trying to get back functionality only to lose more after doctoring. At least now we have webos repair. Thanks for the work on that. I'm really looking forward to getting access to it.
  9. #469  
    all the links before are no longer valid.

    BTW, I tried having webos repair download webos doctor and it downloads version Fortunately, it also recognized that the device is 1.4.5 so I manually downloaded the correct version into the same directories and am currently in the repair process.

    Any other location for the older versions?
  10. #470  
    Oops missed this:
    NOTE: Since March 18th 2010, the Palm servers are no longer hosting old WebOSDoctor versions via the links below. The current versions are still available.

    Does anyone still the old doctors?
  11. #471  
    Quote Originally Posted by batra View Post
    Oops missed this:
    NOTE: Since March 18th 2010, the Palm servers are no longer hosting old WebOSDoctor versions via the links below. The current versions are still available.

    Does anyone still the old doctors?
    Go to & you will find links to all versions - in the preware section I think.
  12. #472  
    Thanks for the message. In the sprint area all the versions before are bad links. As the notice indicates palm is no longer hosting them.
  13. #473  
    many thanks, hope i never need it much like car insurance!
  14. #474  
    OK, I've ran webos repair tool. I actually went through each message just for the curiosity of what it was changing. It fixed the areas I expected would be an issue. The pre is back to working without hanging up (insert happy dance here), without have to go through the painful doctoring. This refurb is definitely not as tight as the original but either way I am going to preserve it as long as possible.
  15. #475  
    What a nice thing its pretty cool!!! So....many thanks comrade for your great job for the webOS users!!!
    El Sendero del Samurai: Lealtad, Paz Interna, Paciencia y Meditar a los pies de Buda

    Samsung Galaxy S4 + Root / HP TouchPad 4G + CM10 / iPod Touch 5 + Jailbreak 6.1.3
  16. #476  
    Thank you for the tool. I need to restore my google maps apps, after I installed the very bad HP maps apps.
  17. #477  
    Quote Originally Posted by tkl2612 View Post
    Thank you for the tool. I need to restore my google maps apps, after I installed the very bad HP maps apps.
    I think that Google maps webos will stop working soon. Google may be killing the api's necessary for the functioning of this program. Read this somewhere.
  18. #478  
    Quote Originally Posted by swieder View Post
    That would be great news. I have the correct doctor file in the same director as the Repair Utility. I have always gotten error messages when I try to run the utility.

    I just tried it again. RU asks for the Doctor file which I select (WebOSdoctor.jar). Then I get Error 22: WebOS.tar.gz (The system cannot find the file specified) The its says Selected WebOSDoctor does not correspond to the connected device.

    I have never seen any ATT Pre+ users report success when using the Repair Utility. I would love to be able to run it!

    EDIT: See attached screen shot. RU does not recognize the device type.
    I have same issue with my ATT Pixi + running 1.4.5

    Same erro even when i run as Administrator in my PC

    Thanks for the help
  19. #479  
    HP Pre2 Unlocked (PG9U0...)
    webOS Doctor webosdoctorp103ueuna-wr.jar (Downloaded using link at WebOS Doctor Versions - WebOS Internals and directly by analysing the jnlp received when entering the Serial No into

    When attempting scan get:
    Loading WebOSDoctor...
    WebOSDoctor found at C:\HP\webOS\webOSDoctor.jar
    Loading connected device's build info:
    Device: <unknown>
    Version: 2.1.0
    Loading webOSDoctor to check ROM build info
    webOSDoctor for: <unknown>
    webOSDoctor of: <unknown>
    Build/Version mismatch

    Cannot get a suitable webOSDoctor from the pull down list in the repair util either.

    Any ideas?

  20. #480  
    Quote Originally Posted by nzpling View Post
    HP Pre2 Unlocked (PG9U0...)
    Cannot get a suitable webOSDoctor from the pull down list in the repair util either.
    Any ideas?

    Version number of this tool does NOT say it works with 2.1 doctors

Posting Permissions