Page 1 of 2 12 LastLast
Results 1 to 20 of 25
  1.    #1  
    Quote Originally Posted by dblessmd View Post
    Quick question.... Try'n to install the WebOS Quick Install for my Pixi... But im using Mac OS 10.4.11, now this means that i cant upgrade to the Java 1.6, so when i try to install the WebOS Quick Install it does nothing.... is there any away around this? PLEASE HELP
    Ok... so im not giving up on this....
    I found SoyLatte... Thank Goodness.. But i cant seen to find the right $PATH to it through the terminal... I did watch watch the video Installing the JDK 1.6 on Mac OS X The Video But he's running OS 10.5.... Does that make any difference, or am i just type'n it wrong, Any one... Any ideas.. I would really like to get this up in running, phone seems really naked with out all the tweaks...

  2.    #2  
    Ok Now I have the Java i need for this to work... Thanks to this --> How to force reinstall Java on Mac OS X « Kunal Dua.. My Java is now SE 6 on my Mac G5 PPC with OS X 10.4.11...

    Now that i got the WebOS Quick Install.. installed, i never get the option for "Novacom".. i tried going to... file/options and attempt Novacom, but nothing happenes... Helpppppppppp~!
  3.    #3  
    I know that im just talking to my self in here... "haha seems to help" but im so close "i think" to have'n this working on my Pixi...

    All i need is Novacom. Because for some reason it will not download after the WebOS Quick Install.... I have read so many threads and so many posts that my HEAD hurts.. "No really it does" Is there a way to just download it separately, and see if i can get it to work that way....
    Anyone... please....
  4. #4  
    Quote Originally Posted by dblessmd View Post
    I know that im just talking to my self in here... "haha seems to help" but im so close "i think" to have'n this working on my Pixi...

    All i need is Novacom. Because for some reason it will not download after the WebOS Quick Install.... I have read so many threads and so many posts that my HEAD hurts.. "No really it does" Is there a way to just download it separately, and see if i can get it to work that way....
    Anyone... please....
    Word of caution - don't get your hopes up regarding my response. I am a Windows OS expert and know very little about MAC OS. I thought from reading other messages that Novacom required MAC 10.5 or greater.

    With regard to downloading Novacom separately - that is problematic, since it is proprietary to Palm. Hence Jason's use of the utility for the required connection between the Pre and a PC or MAC is accomplished by downloading WebOS Doctor which DOES include the files necessary to install Novacom on a PC or MAC.

    Since you are in terminal already on your MAC, I am assuming you may have some level of Linux/UNIX expertise. Therefore, you may possibly be able to extract the required files yourself from the webosdoctor.jar file. On Windows, I would use WinZIP. I am not certain what you would use on MAC/Linux/UNIX to do the required extraction.

    One other possibility (shotgun approach) is to sign up for developer access on Palm's site and install the Palm Pre SDK (Software Developer Kit). It DOES include Novacom.
  5.    #5  
    MortiseMaker your awesome, thank you for your response and your honesty... Much appreciated.. Thought i was invisible =D...

    As for the "shotgun approach" i tried.... It needs OSX 10.5, as well as everything else.... Through all the posts i've read, i see some folks got this to work with OSX 10.4, I dont know... I'm lost for words.. I just don't know what they did different... or what im doing different..

    See i switched back to 10.4 from 10.5... So now im try'n to get 10.5 installed on my external firewire drive via 'Superduper'... that way i can startup on either 10.4 or 10.5.... Never done this before... So this is a new experience. This is freakn crazy..... all of this just so i can get preware on my Pixi.... got'a love it.. =D
  6. aric's Avatar
    104 Posts
    Global Posts
    107 Global Posts
    i still run 10.4.11 on a netbook and can run everything using soylatte. i wrote some help a while ago here:

    i think that this will help getting novaterm installed.
  7.    #7  
    Quote Originally Posted by aric View Post
    i still run 10.4.11 on a netbook and can run everything using soylatte. i wrote some help a while ago here:

    i think that this will help getting novaterm installed.
    I tried that SoyLatte... I could not get the correct $PATH for the bin in soylatte folder... And to tell you the truth im not a real pro with 'Terminal', i mean i can tinker a little, i just could not figure it out...

    Awwww.. Now that im reading this, im now in OSX 10.5... I bit the bullet and just installed it on my external.... just waiting for the updates so i can have Java 6.... waiting waiting waiting... then start this whole process again, with Preware this time "hopefully"

    Thank you for your response,
  8.    #8  
    Crap.. after all that... im right back where i started.. My mac is only 32 bit.... So now its back to try'n to get Java SE 6 for my 32 bit mach... Java 6 is only for 64 bit....

  9.    #9  
    Welp...... went down to my mother-n-laws house, installed it on her windows mach... now im up and running... Yahooooo.... gesh~! took like 20 mins.... AWESOME
  10. #10  
    did you ever get java 6 working on 10.4?
  11. #11  
    I'm running 10.5.8 and I can't get it to work either. I launch the WebOS Quick Installer, it asks if I want to download WebOS doctor (I've already downloaded it and it's in the same folder but it doesn't seem to recognize that), I say yes, and the application quits and does absolutely nothing.

    Cheers, Joe
  12. #12  
    I'm having the same problem as shewhorn. I have downloaded WebOS doctor and when i open up quickinstall.jar I get a message saying webos doctor needs to be reinstalled. Can someone please help!!I'm running mac OS X 10.5.8
  13. #13  
    just want to revive this thread... i am running osx10.4.11 and quickinstall does nothing when clicked. webdoctor is in the same directory..


    just a follow up, is there a way to get preware without the use of quickinstall?
    Last edited by johnj2803; 02/20/2010 at 02:14 PM.
  14. #14  
    java 6 won't run on the old power pc macs, only the new intel macs. it's a hardware issue. sorry friends. get creative and go to either someone's new pc or to your local mac store and set it up on a display mac while the employees are distracted. lol, oh even better, a best buy, no one's ever watching over the mac's there. lol, i'm playing of course, don't try that
  15. #15  
    Finally got Java 1.6 running on a friend's Mac with OS X 10.4.11, but then got this when trying to run WOSQI:

    java -jar Desktop/WebOSQuickInstall.jar 
    Exception in thread "main" java.lang.UnsatisfiedLinkError: /Applications/Utilities/Java/soylatte16-1.0.3/jre/lib/i386/xawt/libmawt.dylib: dlopen(/Applications/Utilities/Java/soylatte16-1.0.3/jre/lib/i386/xawt/libmawt.dylib, 1): Library not loaded: /usr/X11R6/lib/libXext.6.dylib
      Referenced from: /Applications/Utilities/Java/soylatte16-1.0.3/jre/lib/i386/xawt/libmawt.dylib
      Reason: image not found
            at java.lang.ClassLoader$NativeLibrary.load(Native Method)
            at java.lang.ClassLoader.loadLibrary0(
            at java.lang.ClassLoader.loadLibrary(
            at java.lang.Runtime.load0(
            at java.lang.System.load(
            at java.lang.ClassLoader$NativeLibrary.load(Native Method)
            at java.lang.ClassLoader.loadLibrary0(
            at java.lang.ClassLoader.loadLibrary(
            at java.lang.Runtime.loadLibrary0(
            at java.lang.System.loadLibrary(
            at Method)
            at sun.awt.NativeLibLoader.loadLibraries(
            at sun.awt.DebugHelper.<clinit>(
            at java.awt.EventQueue.<clinit>(
            at javax.swing.SwingUtilities.invokeLater(
            at org.jdesktop.application.Application.launch(
            at ca.canucksoftware.WebOSQuickInstallApp.main(
    Hope this will help resolve the issue. Thanks.
  16. #16  
    how do u put this code into my mac to make this work?
  17. #17  
    These are instructions that I pieced together from several websites with regards to getting webOS Quick Install working on my Mac OS X 10.4.11. From here you can begin to download homebrew apps such as Preware for your Palm Pre (Plus) phone. I am not a programmer, I know very little about macs, and therefore, I cannot vouch for the safety or appropriateness of these methods. Please use at your own risk.

    # 1. Put phone into developer mode
    Simply press “upupdowndownleftrightleftrightbastart.” Then, press the icon for “Developer Mode,” and switch the icon to “on.” Let the phone restart itself.

    # 2. Getting Java 6.0 (the saga)
    This was probably the trickiest part, and also the part that could most damage your computer. It worked great for me and others that wrote in, but please proceed with caution and at your own risk.
    Download Java v6.0 from: meiert <dot> com/en/blog/20051029/java-and-lynx-for-mac/. The file link should be called “Java 1.6 Developer Preview (DMG, 52,216 KB). Again, this was accurate as of 06/03/10 and this particular download may only be good for OS X 10.4.11 and below. There is a disclaimer for v10.5 and above; not sure about this.
    Then, copy the methods provided on this site: www <dot> kunaldua <dot> com/blog/2006/06/how-to-force-reinstall-java-on-mac-os-x/. Which basically tell you to: (1) Run the new Java 6.0 program to see if it will install itself (likely not). (2) “In Finder, go to folder /System/Library/Frameworks/JavaVM.framework/Resources and move the files “version.plist” and “Info-macos.plist” to a safe place like the Desktop”. Likely this will require a copy/paste and then a delete of the two files in thier native folder. (3) Run the installer again, and hopefully it will work this time, otherwise…??? (4) Go into Applications > Utilities > Java > Java SE 6 > Java Preferences. Under the ‘General’ tab change the “Use version: “ to Java SE 6 and move the Java SE 6 logo under “Java Application Runtime Settings” to the top. (5) Check to see if it worked by going into Terminal (Applications > Utilities > Terminal) and typing in: java –version. It should say something about Version 1.6.0. If it doesn’t work, be sure to move those 2 files back to their native folders, and perhaps try the soylatte route. It worked for me and I still kept those 2 files just in case.

    This method worked really well for me. It avoided having to go through soylatte and using terminal to change my Java settings. (BTW, there are several posts/videos on the soylatte method of getting Java 6.0 on your computer. This way worked for me (i.e., Java v6.0 was successfully installed onto my computer), but webOS Quick Install still did not work properly. But this way may work for you).

    # 3. Download webOS Quick Install
    Download the file at forums <dot> precentral <dot> net/canuck-software/228310-webos-quick-install-v3-12-a <dot> html. You should probably download it to a new folder called “Palm” or something.

    # 4. Download (separately) webOS Doctor
    Go to: www <dot > webos-internals <dot> org/wiki/Webos_Doctor_Versions and download the appropriate version. Download this to the same folder as webOS Quick Install.

    # 5. Get Novacom (the backdoor method)
    Hopefully at this point you can get “Quick Install” to open on your computer. But, you probably can’t get it to recognize your Palm Pre (Plus). You can try clicking under File > Options > Attempt Novacom (re)installation…, but it probably won’t work.
    So, (1) Copy the webOS Doctor .jar file and paste a new copy into the same folder. (2) Change the .jar extension to .zip. (3) Unzip the new .zip file. (4) Go into the new folder; probably labeled something like “webOSDoctor copy.” (5) Go into the resources folder and double-click on Novacominstaller.pkg.tar.gz. (6) Once that is done unzipping double-click on Novacominstaller.pkg and install the Novacom program. (I forget where I found this method, but thanks to whomever posted this method of getting Novacom installed!)

    # 6. Plug in your phone and let the magic unfold
    At this point you should be good to go; as in, webOS Quick Install should recognize your phone. You can probably watch one of a million YouTube videos on how to get Preware or other nifty homebrew apps on your phone. But basically, you connect your phone to your computer via USB cable. Click on “Just charging” on you Palm Pre. Click on the down arrow third from the top on the right side of the quickInstall screen. And away you go…
  18. #18  
    Sorry to bellyache here, but this is insane. One of the secondary reasons I bought a Pre over an iPhone was so I could install the 3rd-party software I want. This sounds like I could risk bricking both the Pre and my old PowerMac G4 (running 10.4.11, the most recent version it can run).
    Last edited by UltraJoe; 06/08/2010 at 09:59 AM. Reason: Add title & icon
  19. #19  
    It seems like I need Java 6 to do just about anything, so I tried the meiert site above. FYI, the link has changed to meiert <dot> com/en/blog/20071029/java-and-lynx-for-mac/
  20. Nettwerk's Avatar
    78 Posts
    Global Posts
    97 Global Posts
    First one for all. WebOS Doctor, QuickInstall not/will not recognize device.
    The reason is PPC macs not supported. For this you need intel mac and Java 6. Thats is. If some one can develop novacomd for PPC Macs, then will work.
Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions