Page 5 of 184 FirstFirst 123456789101555105 ... LastLast
Results 81 to 100 of 3676
Like Tree10Likes
  1. #81  
    Quote Originally Posted by Davejm74 View Post
    Jason, in not trying to transfer files while tethering, im just simply trying to use tethering.

    I don' think you can install [rooting required] apps....unfortunaly.
  2. #82  
    Quote Originally Posted by xyther4523 View Post
    I have downloaded and installed everything, switched my phone to dev mode, but im getting the Error: no device found or whatever error. I am on Vista 32bit.

    I installed the java, and SDK in other words, and ran the webosquickinstall, but after i connect my Pre (in dev mode, novacom drivers installed and works just fine connecting to my computer) then try to install a .ipk thru WebOS Quick Install, thats when the error comes up. I have followed everything perfectly (from what ive read or seen) and im not sure where this error is coming my computer detects my Pre but the program doesnt.
    I had the same problem and I fix it reading some more threds on this web page.
    you probably need to do the same thing as I try this.
    Click START
    - Run
    Type “Services.msc” and hit enter

    At this point a large list of programs will appear. Scroll through until you find the following:

    Palm Novacom
    right click it and make sure you select the start option.
    Then try to load the ipk file on the quick web os software again and install it,
    I solved my problem doing this, fyi when you finish installing the apps make sure you do the same thing but this time select stop then you can safely disconect your phone from your computer.
    Hope this help for you. I work for me.
  3. OlSarge's Avatar
    4 Posts
    Global Posts
    20 Global Posts
    Mk Im a newb so pardon the question but when I download the file its a .jar so how are you guys installing it on the pc ???
  4. #84  
    Sweet app thanks for the hard work
    My device history. Casio A-10/Cassiopeia E-100/PPC6600/PPC6700/700wx/Moto Q/PPC6700/Mogul/Touch/Mogul/700wx/800w/Touch Pro/Touch Diamond/Palm Pre/Touch Pro
  5. #85  
    It was the Novacom Drivers, I re-installed and run WEBOSDOCTOR after it started up it installed novacom drivers and it worked instantly. GREAT APP!!
  6. #86  
    Many thanks to the development of this. Very easy to install and use! Apps install to the phone in seconds with any issues that I can see. Thanks again!
  7. smd4usc's Avatar
    21 Posts
    Global Posts
    43 Global Posts
    Last edited by smd4usc; 07/26/2009 at 11:35 AM.
  8. #88  
    Ubutnu, SDK is installed and my device is in developer mode. I keep getting "Error: no device found" error.

    Here is the output from dmesg for my device:

    [193304.552639] usb 1-5: new high speed USB device using ehci_hcd and address 13
    [193304.690205] usb 1-5: configuration #1 chosen from 1 choice
    [193304.692300] scsi11 : SCSI emulation for USB Mass Storage devices
    [193304.692494] usb-storage: device found at 13
    [193304.692496] usb-storage: waiting for device to settle before scanning
    [193309.690206] usb-storage: device scan complete
    [193309.690933] scsi 11:0:0:0: Direct-Access Palm Pre 0316 PQ: 0 ANSI: 2
    [193309.699299] sd 11:0:0:0: [sdg] Attached SCSI removable disk
    [193309.699393] sd 11:0:0:0: Attached scsi generic sg7 type 0

    Installing on the emulator works fine.
  9. #89  

    I took a look at the techiques you are using in your excellent WebOS Quick Install tool, and have a number of suggestion (listed below). It's a pity that you didn't release this as open source, or use an open development process, as then I could have just sent you a patch file to implement these suggestions directly ...

    1) I notice you run

    /usr/bin/luna-send palm://com.palm.appinstaller/installNoVerify {"target":"<filename>"}
    to install ipkg files after you have used the novacom putFile method to upload the ipkg file to the device.

    Did you know that you could simply run

    ipkg -o /var install <filename>
    instead, and it would automatically handle any dependencies that the application might have on other applications from the Palm App Catalog, or other homebrew ipkg repositories?

    2) I notice you run

    rm -r /var/usr/palm/applications/<appid>
    to delete an application.

    Did you know that you could simply run

    ipkg -o /var remove <appid>
    instead, and it would automatically handle the case where one application depends on another application, and removing the second application would cause the first application to stop working? At the moment, your tool blindly deletes the second application, and the first application would cease to function without warning the user about the dependency between the two applications.

    3) I notice you run

    /bin/ls -l /var/usr/palm/applications | egrep '^d'
    to get the list of installed applications.

    Did you know that you could simply run

    ipkg -o /var list_installed
    instead, and it would not only give you the name of each application, but it would also return a description of the application and the currently installed version number and allow you to display that information in the Device Management pane of your tool?

    Doing it this way would also save you the trouble of creating that little script, uploading it to /media/ram on the device, running it, and then deleting it afterwards ...

    You could even take this further, and use the "ipkg -o /var list" command to list all the applications in the and future PreCentral ipkg repositories, and allow the users of your tool to simply tick the applications to install after having read the description associated with each one.

    4) If you used the built-in Palm ipkg commands as listed above, your WebOS Quick Install tool would also be able to install homebrew apps (such as Terminal, Flashlight, and MyTether) which require root access to install files outside of the /var directory. You could use the novacom runProgram method to run the ipkg command, and then use the novacom runProgram method again to execute the postinst script that would be included with the ipkg files for such packages.

    5) If you made these improvements, then no-one would ever need to log into a Pre as root ever again to install a homebrew application of any type - all the things that needed to be done as root could be embedded into the postinst file in the relevant ipkg, and your application could be the means of installing such ipkg files without needing to log into the Pre as root.

    6) Taking this concept further, all of the community-created modifications to the built-in Palm applications could be packaged up as ipkg files with postinst scripts, and your application could be used to install and remove those patches too (using inter-package dependencies to handle multiple patches applying to the same files).

    Feel free to take these suggestions and incorporate them into your WebOS Quick Install tool. I'll continue to try and convince you to open source the tool so the rest of the development community can help make the tool do so much more than it does today ...

    -- Rod
    Last edited by rwhitby; 07/26/2009 at 09:04 AM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ if you find our work useful.
    All donations go back into development.
  10. #90  
    I was having huge problems trying to install it on my vista pc when I noticed another post saying to disable firewall.I tried that and it installed at once.

  11. #91  
    I want to thank you and say that I have been very uneasy about entering the HomeBrew worl but your awesome program has really let me experience it. THANK YOU.

    Also this keeps my wife from being mad that only I have the Mynotification App
  12. #92  
    Great work with the program I love it! I did find a small bug. Basically after dragging and dropping 5+ files it would be "out of focus". I uploaded the pic of what im talking about. Im runing xp mediacenter sp2.
  13. #93  
    Freaking awesome!!! Now I am scared...this is fun. This was easy to understand, i am enjoying this more than I thought I would. Fabulous job!!
    TeckieGirl Official website
  14. #94  
    Got it to work! Woo Hoo!! For those getting errors like I did when you tried to download the file, click on "email attachment" instead of the .jar itself. I downloaded the file through the email, and it worked instantly. For some reason clicking on the .jar will download a "download" file attachment. When you get it through email, it is the .jar
  15. rtlsnke's Avatar
    21 Posts
    Global Posts
    25 Global Posts
    Until this morning except for Palm webOS updates, my Pre had been out of the box stock. Of course I have been an avid reader of this forum since June when I bought the Pre. I downloaded the SDK when it was officially released and played with it ("hello world") but not much else. After yesterdays release of the two installers I decided I would dip my toe into the homebrew arena. This is the first app I installed. Your instructions fantastic! First app I installed was the devmode app. Then Brian's fileCoaster. As I said in a previous post this app and your instructions have turned this into the precentral homebrew app warehouse. Fantastic Job!
  16. Nesta's Avatar
    134 Posts
    Global Posts
    139 Global Posts
    Thanks for the work on this. I have one problem whichI have to assume is user error. i can't get the ability to hide/make visible the DevMode application in the launcher work? I select the option from the menu reset my Pre but still I don't see anything.

    I already had the DevMode Launcher app installed. Is this installing somethng different or is installing the app I alredy had? I'm probably missing something very basic. Thx for your help.
  17. danstah's Avatar
    136 Posts
    Global Posts
    141 Global Posts
    Nicely done. App works great
  18. #98  
    I just have to say that this program is wonderful. I have Windows 7 and was having issues with the Novacom Driver install. I now have Homebrew apps on my Pre !!!!!!! =)
  19. merrix's Avatar
    99 Posts
    Global Posts
    104 Global Posts
    Quote Originally Posted by fred72matt View Post
    It was the Novacom Drivers, I re-installed and run WEBOSDOCTOR after it started up it installed novacom drivers and it worked instantly. GREAT APP!!
    How do you run WEBOSDOCOTOR, I downloaded it and unzip and I don't see which files to run to fix the Novacom problem.

  20.    #100  
    Hi guys, guys woke up after a night out with friends, gimme a hour or 2 to catch up and I'll be able to help you guys out.

Posting Permissions