Results 1 to 8 of 8
  1.    #1  
    Hi there, thanks for the hard work on this great app. :-)

    One issue though, my ftp server (iis 7 hosted by godaddy) doesn't seem to play well with the ftp function. From what I see I connect ok, but the screen is blank. Other ftp sites are just fine and my ftp site is fine with other clients, so I'm puzzled.

    Any idea's? Oh, version says 0.0.7.


  2. #2  
    Most probably output from curl command (that gets parsed in JavaScript) is different that expected.
    Post output from (or send via PM):
    curl -# --ftp-method nocwd -u <username>:<password> ftp://<server><directory>
    Ideally run this command in novaterm or wTerm (ie directly on device).
  3.    #3  
    From wTerm the curl command worked fine, output was two lines of ########### 100% then the file listing from my FTP site, perfect.

    Since this seemed to work, I tried again with commander, no luck. Fails on my stock touchpad too...

    I'll send you the ftp info in a PM so you can try for yourself if that's OK.
  4. #4  
    In the meantime you can replace src/ftp.jsjsjs $with$ $attached$ $file$ ($you$ $can$ $use$ $Commander$ $itself$ $to$ $copy$ $file$ $over$, $don$'$t$ $forget$ $to$ $restart$ $device$)

    And create some directories on test account if dirs does not work with attached file.
    Attached Files Attached Files
  5.    #5  
    Thanks, your getting very close. It now lists the files attributes are NAN or otherwise misinterpreted. For example subdirectories are not recognized as a dir, etc.

    I put some sample stuff in your test account so you can see first hand.

    thanks again!
  6. #6  
    > RETR testdir2
    < 550 Access is denied.

    Please check permissions for testdir and testdir2
  7.    #7  
    permissions are fine, re-tested access with several other ftp clients and have no issues (can cd, ls, create new dir and file, upload, download, etc).

    Turns out however that RETR doesn't seem to be a valid command on IIS ftp server, use a command line to ftp to the test account and try it, return is invalid command. Help command also does not list it....
    Last edited by MacksEPadd; 06/22/2012 at 04:46 AM.
  8. #8  
    was able to download baro-bear.png using Commander inside testdir ... so there is small chance that it will work...
    Last edited by artxxork; 06/22/2012 at 05:36 AM.

Tags for this Thread

Posting Permissions