Page 9 of 26 FirstFirst ... 456789101112131419 ... LastLast
Results 161 to 180 of 509
Like Tree99Likes
  1. #161  
    I dont believe there is one for any platform. The main difference upon inspecting my old sim and the new sim is that when i access the sim card using sim tools there is the ability to utilize the space on the sim for additional sim contacts or additional messages stored on the sim, my old sim did not have that.
  2. #162  
    Guess, what! It is working now.
    But I had to install CM10, and while I got "Default Message" at the bottom,
    1. Turned off Wifi
    2. Created manually the Internet APN for my carrier.
    3. Profit! I was connected to Internet finally!

    I am going to try doing it on CM9. I will try and restore it from its nandroid backup.

    I do no feel comfortable with CM10 yet. Specially about that battery charging thing thaty may brick the Touchpad.
  3. #163  
    cool! someone did suggest that in one of the posts before it got deleted. good job.
  4. #164  
    Ok, now I can confirm that it works also on CM9. I just reinstalled cm-9-MBM_Beta-20121204-4g_beta1-tenderloin
    As soon as I passed the initial config, after getting an initial "Unfortunately, the process has stopped." error and a setup wizard stopped error, I went to Data Usage ->more... and created manually the APN entry for my carrier.
    After that, I turned off wifi and Internet connected fine through the mobile data network.

    -----Update 12/30/2012
    It didn't survive a reboot!
    despite saving it, the manual APN does not seem to survive the reboot.
    Last edited by pepebuho; 12/30/2012 at 08:19 AM. Reason: add info
  5. #165  
    Cool, knowing the problem really helps to find a solution, or at least a workaround.

    Regarding the has stopped problem, it seems it is because CM9 can't read the sim and can't apply the APN to connect to Internet. Worse, it seems like CM9 cannot save the new APN info to use after a reboot.

    My solution needs two programs: Titanium Backup Pro (the paid version) and a utility called "APN Backup & Restore" Both are in the google play store.

    From a newly updated CM9, create a working APN. Believe me, once the process sets in, one will not be able to have enough time to input all the data for the APN. I tried. I wasn't fast enough.

    Start Titatnium Backup and convert the APN Backup app into a system App. CMN (ICS) does not allow common apps to modify APN data. That's why APN backup has to run in root mode.

    Run APN backup and backup the APN.
    After reboot, the error should start popping around.
    Go to APN Backup and restore the APN.
    The error should go away and you should be connected to Internet.

    I wish there were a system mode to do that, but if you set airplane mode, you lose access to the mobile data menus.
  6. #166  
    ok, not quite success.
    Still having problems
    I need something that would allow me to backup the whole data mobile wireless info and restore it on demand.
    That would be the regional network and the APN.

    Right now each time the error comes up it does not give me enough time to find the network and register to it.

    As it is, it is just luck if I can set up everything on time before the error crops up
  7. #167  
    Quote Originally Posted by pepebuho View Post
    ok, not quite success.
    Still having problems ...

    As it is, it is just luck if I can set up everything on time before the error crops up

    It would be helpful if you could send me some logs. Also, please send the APN settings that work for your mobile carrier. I may be able to learn something that will help figure out what is going wrong with the older SIMs.

    You can create a log dump by running Terminal Emulator, typing 'su' to get to get a superuser prompt, then typing ''. This script will create a zip file with all the logs in /sdcard/logs. You should perform the log dump as soon as you can following a reboot so it captures the initial log entries. You may get errors if fsckdos is still running, but just type again.

    Send me the logs attached to a PM and I will see if I can come up with a fix...

    Happy New Year,
  8. #168  
    Hi NewbyJE
    Couldn't find how to attach the log to a PM, therefore I will post it here.
    There are two files:
    The last extension really is .gz, but I had to change it to zip for the forum software to accept it, otherwise it kept rejecting it.
    Likewise the APN is an xml file called apns-20121231134057.txt. The extension should be xml but I had to change it to txt for the forum software to accept it.

    That is the APN that works when I am registered at my carrier, Movistar. Under WebOS it works flawlessly.

    I hope this helps to solve this issue, if you need anymore data just let me know.

    Attached Files Attached Files
  9. #169  
    BTW, my SIM is a Data only SIM, it does not have a voice data plan activated, just FWIW.
    Maybe it has something to do, maybe not.

  10. #170  
    Just for kicks I tried the SIM on my HP PRE and voila, everything worked perfectly. This SIM has voice and data, and it is an earlier than my current Touchpad SIM. I have had my Pre 3 since Sep 2011
    I am attaching the logs. Again, change the .zip for .gz. because otherwise the forum software would not accept the file.

    Attached Files Attached Files
  11. #171  

    Thanks. I took a quick look at the first set. This is a Legacy SIM and it is tripping up the code. Having the logs will help me try to figure out if there is a way to make such SIMs work. Will let you know if I come up with anything.

    Looking at the second set, it also seems to be a Legacy SIM. However, it did connect using first EDGE, then UMTS (3G). Did not connect using HSDPA or H+.

    I do not think it matters if it is a data only SIM. The MBM code just seems to have trouble with Legacy SIMs. While I will try to fix the code, it is probably better to get a new USIM from Movistar.

    I did create a version of the APN configuration file with Movistar Panama entries. Should work with either SIM, see if it makes any difference. It is attached with a 'txt' extension. Change it to 'apns-conf.xml' and save it as /system/etc/apns-conf.xml. Permissions should be rw-r--r--.

    Attached Files Attached Files
    Last edited by NewbyJE; 01/01/2013 at 02:33 AM.
  12. #172  
    Happy New Year John, your amazing work does not even rest on holidays. Kudos to you.
  13. #173  
    Hi John.
    Replaced the apns-conf.xml file with the one you provided, changed the permission and rebooted.
    There is no change in the situation. The problem is stil there.

    I just attached the logs

    Thanks for all the help!
    Attached Files Attached Files
    Last edited by pepebuho; 01/01/2013 at 11:47 PM.
  14. #174  
    Hi John, I think this log might be a lot more useful.
    I reinstalled everything from anew.
    1. Wiped user data to factory reset
    2. wiped partition
    3. wiped dalvik cache
    4. reinstalled cm-9-MBM_Beta-20121204-4g_beta1-tenderloin/gapps
    5. rebooted

    After entering all the initial info, I noticed that the tablet kind of registered to the phone network but did not have Internet Access. Going to Settings....APN names I noticed there was no APN, therefore entered and saved one manually (for some reason this APN does not get permanently saved).

    Right after I entered the APN, I got internet connectivity, (turned wifi off to check).

    Then I went to the terminal emulator and generated the attached logs.

    I hope there is something a lot more useful in here.

    Attached Files Attached Files
  15. #175  
    Does someone have a link to I'm having a hard time finding it.
  16. #176  
  17. #177  
    Can someone please provide me with a link or info of the sim card (prepaid) that I will need and works with the 4g touch pad. I only want to do the prepaid or pay as we go sim cards .

    Please help


  18. #178  
    Quote Originally Posted by pepebuho View Post
    Thanks . Worked great!
  19. #179  
    Maybe this document may help you out...!121
  20. #180  
    Lurking and Googling I came to this file on the /data/data/ subdirectory:

    /data/data/ # cat
    <?xml version='1.0' encoding='utf-8' standalone='yes' ?>
    <string name="network_selection_name_key">movistar</string>
    <string name="network_selection_key">714020</string>

    As you can see, it already has the network and its MCC/MNC (or whatever it is called).
    I wonder:
    1. Is it possible to write directly into this place ? It is a -rw-rw---- file, so I figure it should be writable unless the file system is mounted ro. Actually, checking out the mount command, it says that it is rw, nosuid, nodev, noatime, barrier=1,data =ordered,noauto_da_alloc. I guess it means it is writable.
    2. If I can backup and restore that file after a reboot, When stops, and restarts, will it pickup that file and connect to the network or will it erase it and try to connect and then write a new one? What is the behavior of supposed to be?

    I wonder and I'd rather find out a little more from those ahead of me before really bricking the 4G


    No dice.
    I am in the middle of has stopped
    I just SSHd to that file and it is there with the correct info. Why doesn't CM9 pick up that info and just log into the network?
    Last edited by pepebuho; 01/05/2013 at 10:50 AM. Reason: update
Page 9 of 26 FirstFirst ... 456789101112131419 ... LastLast

Posting Permissions