Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By dkirker
  1.    #1  
    I want to know if there's a way to kill or reset an application or system process using some terminal type app.

    Specifically: when my BT starts acting weird, the headset loses connection and makes its "disconnected" audio tone. But the phone's BT indicator is still full white circle indicating it thinks it's connected. Then i must fight with it to shut off, opening and closing the BT app until it finally releases. Only then will it reconnect correctly.

    Can i force quit or reset the BT using WTerm or other?

    Are there ANY handy shortcut commands that can be input directly to device using a terminal app on device?

    Thanks!
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  2. #2  
    Quote Originally Posted by TJs11thPre View Post
    I want to know if there's a way to kill or reset an application or system process using some terminal type app.

    Specifically: when my BT starts acting weird, the headset loses connection and makes its "disconnected" audio tone. But the phone's BT indicator is still full white circle indicating it thinks it's connected. Then i must fight with it to shut off, opening and closing the BT app until it finally releases. Only then will it reconnect correctly.

    Can i force quit or reset the BT using WTerm or other?

    Are there ANY handy shortcut commands that can be input directly to device using a terminal app on device?

    Thanks!
    yup

    In wterm:

    su

    (then enter the root password you set)

    stop bluetooth
    start bluetooth

    or, in one line

    stop bluetooth && start bluetooth
    Did you know:

    webOS ran on a Treo 800 during initial development.
    TJs11thPre likes this.
  3.    #3  
    Quote Originally Posted by dkirker View Post
    yup

    In wterm:

    su

    (then enter the root password you set)

    stop bluetooth
    start bluetooth

    or, in one line

    stop bluetooth && start bluetooth

    having difficulty testing this.
    -- open Wterm. It says: wterm@webosdevice:~$
    -- I put in "su", then i'm asked for password.

    Q1. Is this a pre-existing password, or one I'm creating now?
    Q2. Will this password persist, or does it reset each time i enter SU?

    -- I put in "pass" and it says: root@webosdevice:/var/home/root#
    -- i put in "stop bluetooth" and it says: sh: stop: not found

    then it says root@webos-device:/var/home/root#

    suggestions?
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  4. briest's Avatar
    Posts
    133 Posts
    Global Posts
    134 Global Posts
    #4  
    Quote Originally Posted by TJs11thPre View Post
    Q1. Is this a pre-existing password, or one I'm creating now?
    Q2. Will this password persist, or does it reset each time i enter SU?

    -- I put in "pass" and it says: root@webosdevice:/var/home/root#
    So, your password is obviously "pass" and you are logged in to root shell. For what I remember, our devices don't have root password by default, some apps (wterm, dropbear) insist on creating one.

    Quote Originally Posted by TJs11thPre View Post
    -- i put in "stop bluetooth" and it says: sh: stop: not found

    then it says root@webos-device:/var/home/root#

    suggestions?
    Try full path: use /sbin/stop and /sbin/start instead.
    T5, Clié NZ90, Treo 650, Centro, Pre, Pre+, Pre 2, Pre 2, Nexus7@LuneOS
  5.    #5  
    Well, that did stop Bluetooth.

    But then it wouldn't start again, either with the command typed as you suggested, or in either the system menu or on the Bluetooth app itself. Just would not respond to the on switch. Said running in the term window but no icon up top.

    This is what i was hoping to overcome, having to reboot to unfreeze Bluetooth.
    Any other options?
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!

Similar Threads

  1. Vi commands
    By ericizzy1 in forum Palm Pre and Pre Plus
    Replies: 4
    Last Post: 08/22/2009, 01:50 PM
  2. ## Commands
    By shopharim in forum North American Carriers (CDMA)
    Replies: 2
    Last Post: 05/23/2007, 09:38 PM
  3. Voice commands and the 650
    By Felipe in forum Palm OS Devices & Apps
    Replies: 1
    Last Post: 01/27/2005, 01:41 PM
  4. AT Commands
    By sjanaway in forum Palm OS Devices & Apps
    Replies: 2
    Last Post: 07/05/2002, 02:39 AM
  5. AT Commands
    By sjanaway in forum Palm OS Devices & Apps
    Replies: 0
    Last Post: 07/03/2002, 06:11 AM

Posting Permissions