Results 1 to 13 of 13
Like Tree1Likes
  • 1 Post By 60RH
  1.    #1  
    Recently when I plug in my Pre3 to my laptop and enter USB mode, Windows 7 asks me "Do you want to scan and fix HP Pre3?" I know I need to scan and check for filesystem errors, but I'm afraid windows might "fix" (corrupt) something in /media/cryptofs, since it is located in the USB partition. I found a few posts indicating this was safe, but they are pretty old, so I'm not sure they are still valid. I would think running something from an ssh terminal window would be safest, but I haven't turned up good info in my searches (I found two different variations of fsck commands). So, what's the safest way to fix it?
    Last edited by Grabber5.0; 01/22/2014 at 08:49 PM.
  2. #2  
    This happened to me on my TouchPad after using Tailor the other day. It's my "spare" TouchPad that I dual boot Android on so I let Windows do it. No problems that I saw. If you backup /media/cryptofs it shouldn't hurt to run it. I think there are harddrive apps out there that will scan the drive and tell you what needs "fixed". Often Windows seems to think file structures need "fixing" when they're not "normal" formats that Windows plays nice with.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  3. #3  
    Quote Originally Posted by Grabber5.0 View Post
    Recently when I plug in my Pre3 to my laptop and enter USB mode, Windows 7 asks me "Do you want to scan and fix HP Pre3?" I know I need to scan and check for filesystem errors, but I'm afraid windows might "fix" (corrupt) something in /media/cryptofs, since it is located in the USB partition. I found a few posts indicating this was safe, but they are pretty old, so I'm not sure they are still valid. I would think running something from an ssh terminal window would be safest, but I haven't turned up good info in my searches (I found two different variations of fsck commands). So, what's the safest way to fix it?
    A mil $ question. I was trying to fix my camera on my FrankenPre2 since the camera app will throw an error in the cleanup method. After repairing and recreating the dos partition before doctoring I still don't have a working cameraJust hooked up my pre to ubuntu machine and running sudo dosfsck -w -r -l -a -v -t /dev/sda ...
    where sda is the name that my usb partition has been mounted.
    Not sure if this command is available on the pre and can be run from ssh.
    Anyway wish me luck. I know that win7 checkdisk didn't harm or at least didn't make my camera issue worst or my pre for that matter.
    Rnp likes this.
  4. #4  
    Results, please...????


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  5. #5  
    Quote Originally Posted by Rnp View Post
    Results, please...????


    Best Regards...
    Same as running it on win7
    Although ubuntu reported : Reclaiming unconnected clusters. Unable to create unique name
    with sudo dosfsck -w -r -l -a -v -t /dev/sda
    had to run sudo dosfsck -r /dev/sda only and then it told me that the boot sector and the backup one have different sizes I chose to copy over the backup one.
    So far nothing new my camera is still no go.
  6. #6  
    I confess that I'm trying to find courage to make a Secure Full Erase & doctorize after...


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  7. #7  
    Quote Originally Posted by Rnp View Post
    I confess that I'm trying to find courage to make a Secure Full Erase & doctorize after...


    Best Regards...
    Did that too as last resort but nothing changed on my non working camera situation...
    If you don't have a good reason to do it just don't
  8.    #8  
    I just want to do a read-only scan to see what windows thinks is wrong. I have had to do one in so long I can't remember how to make sure it's done without making any changes.
  9. #9  
    We're still talking about using a Windows machine, right? Just uncheck Automatically fix file system errors. Check your hard disk for errors
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  10.    #10  
    I was just afraid if I clicked yes that it would just start and not give me a chance to change the options. I didn't think about initiating it myself from the drive properties. Probably the safest route.
  11.    #11  
    Ugh windows is so lame. I said no, initiated a check on my own and said not to automatically fix errors. It said it found none. So I ejected and reconnected, and it STILL popped up and asked me if I wanted it to scan and fix errors! Maybe it didn't mark it as clean since I unchecked the box.. Since it found nothing I am letting it scan and fix this time. I still left the 2nd box unchecked as I don't want to scan for bad sectors right now. We'll see...

    Okay finally that shut it up!
    Last edited by Grabber5.0; 01/23/2014 at 01:26 PM.
  12. #12  
    Thank you for the question and the result.

    I always get this message (also win7 32 bit) and always click it away, which is annoying.
    Maybe I try the same path: check it once with everything off and if it found nothing, again with scan and fix.

    Regards,
    UW
    Handspring Visor -> Palm Centro -> HP Pre 3 / HP TP 4G -> amazon fire phone 64GB
  13. #13  
    I typically run f-s-c-k when I see complaints in the boot messages (Warthog kernel here). Boot to installer ramdisk, and issue
    Code:
    dosfsck -awv /dev/mapper/media
    (I might have the dev name wrong, but it's one of the files in that directory.)

    Not sure if it helps with Windows, though. The last time I used Windows' check it didn't seem to mess anything up.

Similar Threads

  1. Replies: 144
    Last Post: 06/19/2016, 08:31 AM
  2. Help, Resized Partition and Now I can't Fix it
    By smcbeaven in forum TouchPad Patches
    Replies: 3
    Last Post: 01/15/2012, 07:46 PM
  3. Classic bug: Filesystem not closed when entering USB drive mode
    By PreOwned in forum webOS Apps & Games
    Replies: 4
    Last Post: 01/29/2010, 08:36 AM
  4. Replies: 0
    Last Post: 10/22/2009, 09:07 AM

Posting Permissions