Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By tagscuderia
  1.    #1  
    Solved! N.B, workaround/unofficial

    -- I have previously Doctored my Pre3 after the 23rd July and had no problem restoring the App Catalog and then installing the update so I know the routine --

    Hello all, I carried out a full erase and Doctor of my Pre3 (UK model, unlocked) last night and have come unstuck with the App Catalog Update... update, have tried everything that I can think of but cannot get it to install.
    So once the phone fired up, I signed into my Palm Profile and started setting up: apps were loaded but not installed, when I tried downloading them I got a message along the lines of my WebOS profile wasn't active? Scratching my head I reset the phone (again), no error message but everything resulted in "install failed."
    I can restore the App Catalog and use it but it's then called the "App Catalogg." I've reset it and Doctored numerous times, tried 3G and WIFI but I'm not getting anywhere.

    I've also erased my HP/Palm backup so in theory I'm starting from scratch but... Any and all help greatly appreciated, I've been troubleshooting for hours but can't suss it out. Thanks.

    P.S, just checked the certificate and it's valid from 23/07/2009 to 23/07/2013, I have the date set to 01/07/2013.
    Last edited by tagscuderia; 09/19/2013 at 07:29 AM. Reason: Readability
  2. #2  
    You're doing a lot of stuff that I've never tried, so I'm not going to be of much help. I hope that when you deleted your HP backup, you didn't actually delete your account! But that thought leads me to wonder whether you needed to do a "first activation" after the doctor?

    In any case, if you get this fixed, you may want to back up your security certificates per this procedure (http://forums.webosnation.com/hp-pre...ml#post3399736) so that you can manually restore them after your next monthly doctor, if need be.

    Tungsten E, Treo 650, Pre+ (3), Preł (2), TouchPad (2), & my trusty Treo BT headset (in use!)
    Posts: Save/Restore Backup Process & Batch File | Activated! (Verizon Preł Activation) | "Not Enough Space To Download" Fix
  3.    #3  
    Quote Originally Posted by bethel95 View Post
    You're doing a lot of stuff that I've never tried, so I'm not going to be of much help. I hope that when you deleted your HP backup, you didn't actually delete your account! But that thought leads me to wonder whether you needed to do a "first activation" after the doctor?

    In any case, if you get this fixed, you may want to back up your security certificates per this procedure (http://forums.webosnation.com/hp-pre...ml#post3399736) so that you can manually restore them after your next monthly doctor, if need be.
    Yeah turned off backup, profile is intact.
    I've just tried creating a new profile but that suffers from the same issue. I'm wondering if there's an issue with HP's servers; looking at another thread, it seems that others are having the exact same issue! Obviously something has changed, struggling to figure out what though.

    Backing up security certs sounds like a very sensible thing to do, if I can get my Pre3 working again I'll be sure to do it. In the mean time, any suggestions? Thanks.
    Last edited by tagscuderia; 09/15/2013 at 11:34 AM.
  4. #4  
    I been having the same problem also this weekend and have just about exhausted all of my obvious ideas. I'm using the same doctoring approach that was working just fine Thursday (doctor, set date to July 1, 2013, load App Catalog Update, restore all apps with caution sign, update...) I'm strongly wondering - did something happen to the HP servers?
  5. #5  
    The same thing has happened to my Pre Plus doctored up to 2.1.

    I have tried everything listed in the posts above and my "update" is also spelled" App Catlogg Update."
    Maybe their will be a fixed pushed to their servers later?
  6.    #6  
    From another thread I found a workaround, thanks sideshowbob84.
    Quote Originally Posted by sideshowbob84 View Post
    I used the steps described here: [How To] Retain App IPKs from App Catalog to get an .ipk file of the app catalog update. I installed the ipk with QuickInstall and restarted my phone.
    I can attest to it working, don't even have to tweak the date. Works flawlessly so far as I can tell.
    Whilst I'm happy to have everything fully functional, I'm still bemused as to what the issue was/is. HP's forums have the same issue listed but no one's taking it seriously it appears. It was a bodged job to start with (cert update) and really they should issue updated Doctors but... I guess we're on our own. Thanks Jason for QuickInstall, invaluable tool going forwards!
    bethel95 likes this.
  7. #7  
    Quote Originally Posted by tagscuderia View Post
    From another thread I found a workaround, thanks sideshowbob84.

    I can attest to it working, don't even have to tweak the date. Works flawlessly so far as I can tell.
    Whilst I'm happy to have everything fully functional, I'm still bemused as to what the issue was/is. HP's forums have the same issue listed but no one's taking it seriously it appears. It was a bodged job to start with (cert update) and really they should issue updated Doctors but... I guess we're on our own. Thanks Jason for QuickInstall, invaluable tool going forwards!
    If this works, then you were able to get the ipk from HP's server, so the server isn't the problem. This sounds like the App Installer service on your Preł was malfunctioning (since installing via WOSQI worked fine). I'm puzzled why a doctor wouldn't have fixed this--unless the doctor .jar was itself corrupted. That seems unlikely, but did you by any chance verify the .jar file you downloaded against the MD5 checksum listed on webOS Internal's doctor wiki page?

    Tungsten E, Treo 650, Pre+ (3), Preł (2), TouchPad (2), & my trusty Treo BT headset (in use!)
    Posts: Save/Restore Backup Process & Batch File | Activated! (Verizon Preł Activation) | "Not Enough Space To Download" Fix

Similar Threads

  1. App Catalog Certificate update failed
    By techlover10 in forum HP TouchPad
    Replies: 62
    Last Post: 12/20/2014, 10:34 AM
  2. Replies: 4
    Last Post: 09/15/2013, 01:05 PM
  3. App Catalog failed download
    By shanpalm61 in forum HP TouchPad
    Replies: 2
    Last Post: 12/19/2012, 07:14 PM
  4. App Catalog 'Purchase Failed'
    By jetsetter883 in forum Palm Pre and Pre Plus
    Replies: 5
    Last Post: 09/26/2010, 12:57 AM
  5. Installation Failed (App Catalog) anyone else see this?
    By mochzr in forum webOS Discussion Lounge
    Replies: 3
    Last Post: 01/28/2010, 12:20 PM

Posting Permissions