Results 1 to 9 of 9
  1. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #1  
    When I receive a message the contact's name doesn't show up in the Messaging app unless their number is stored in international format (i.e. +61 123 456 789 rather than local 0123 456 789).

    Incoming calls are looked up OK because they appear to come into the device in local format but SMS's seem to come into the device in international formal. My Treo obviously had the smarts to recognise them as the same number in both applications and thus displayed the contact name. I currently have a Veer but had the same problem with my Pre 2 so it appears to be a webOS thing.

    As a workaround I added an international version of a number to one contact and the next message that came it the name translation was done correctly; but I don't want to have to create duplicate numbers for each contact and don't really want to have every contact's number in international format.

    Is there a hack to get webOS Messaging to recognise it as the same number? Essentially it just needs to:

    if number starts with +61 then convert +61 to 0 and output to messaging client, else output original number to messaging client.

    Thanks!
    Greg
  2. #2  
    in the dialer app is a place to indicate dialing prefixes. Did you try any of that? The manual way would be to export from gmail to a spreadsheet and the use a formula to add characters to the front of each number, and upload it back to gmail.
  3. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #3  
    Thanks for your reply. I didn't know that was there but it appears to relate to a prefix that will automatically go in front of outgoing numbers I dial when I dial a certain number of digits. I don't want outgoing numbers to be changed so I don't think that's going to do what I want.

    I realise I can change all the numbers in my phone book into international format but that's going to create the same issue for incoming calls, because these currently come in in area-code format, not international. As a test I just created my landline number (which comes in as 08 8123 4567) in international format (+61 8 8123 4567) and the name didn't show up. Same result when I changed the number to the same without the area code (8123 4567). The name only appeared when I had exactly the same digits in the address book entry as what the phone receives.

    The only way this solution would work would be to store a local, area-coded and international version of each phone number in each contact, which seems ridiculous. Even to get the basic functionality of my three year old Treo I would have to create two versions of each and every number in my address book.

    The alternative, which I'm hoping is possible, is to perform some simple logic when the number comes in to check if there is a number in the address book that matches a different locale version of the same number.

    I presume after two years of webOS phones someone else must have discovered this issue and hopefully a solution?

    Greg
  4. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #4  
    Bump...
  5. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #5  
    Does no-one else in the world have this problem?
  6. #6  
    Quote Originally Posted by gregp View Post
    I don't want to have to create duplicate numbers for each contact and don't really want to have every contact's number in international format.
    The correct way to store and dial a number on a cell phone is +(ISD code) (STD code) (local number), ie. for a US number the displayed format should be +1 123-456-7890. This is the internationally accepted format for cellphone numbers and is actually the format specified as part of the GSM protocol. This is the only correct format, which will ensure that you can dial a contact's number on any GSM network in the world. This is also the correct format in which caller ID numbers are supposed to be displayed on a GSM network. Unfortunately, phone companies in the US refuse to follow this standard and thus calls from and to the US are at the root of these problems. This issue is handled by all cellphone manufacturers, simply by matching the last ten digits of the displayed caller ID. But, for reasons known only to Palm/HP, changes were made post webOS 1.4.5 in how webOS matches incoming numbers with stored contacts and thus ever since webOS 2.x.x, webOS phones no longer display the name of contacts who call from the US. That is because the US networks refuse to display the numbers correctly as per international norms and webOS, for strange reasons, now looks for only an exact match of the displayed number. Now when I receive a call from my friend in the US and whose number is 607-xxx-xxxx, my phone is unable to match his name and the incoming call. Instead of displaying his name as the caller, it states the call is from Malaysia, since '60' is the ISD code of Malaysia. Since it is foolish to expect the US phone companies to suddenly understand the technicalities of caller ids, and or even expect HP to fix anything with webOS, our only hope is that someone here makes a patch to allow matching of the last ten digits of an incoming call to the contacts. Until then, we are stuck with having to save numbers in two different formats for contacts in the US. One, 'correct' format for outgoing calls and the other 'incorrect' format to enable the phone to match incoming calls to stored contacts.

    ISD = International subscriber dialling = country code
    STD = Subscriber trunk dialling = area code
    Last edited by Sanjay; 09/22/2011 at 07:38 AM.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  7. rajivdx's Avatar
    Posts
    1 Posts
    Global Posts
    2 Global Posts
    #7  
    Found it! In Regional settings>Phone Numbers set it to your current country of residence (Eg: Australia) and it will match numbers correctly. By default this is set to US if you purchased your phone from the US.

    Cheers,

    Rajiv
  8. #8  
    Quote Originally Posted by rajivdx View Post
    Found it! In Regional settings>Phone Numbers set it to your current country of residence (Eg: Australia) and it will match numbers correctly. By default this is set to US if you purchased your phone from the US.

    Cheers,

    Rajiv
    I'm from Vietnam (+84 Region number), and in the list off Regional Settting don't have Vietnam (+84). How to add this Region Number to show the contact name at messaging ?

    Thanks
  9. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #9  
    Quote Originally Posted by rajivdx View Post
    Found it! In Regional settings>Phone Numbers set it to your current country of residence (Eg: Australia) and it will match numbers correctly. By default this is set to US if you purchased your phone from the US.

    Cheers,

    Rajiv
    thx for the suggestion but this did nothing for me. I already had it set to AU, and this also causes a non-match on contact names on calls. On US I get calls matched but still not messages. No idea what that setting does but it certainly doesn't fix this problem.

Posting Permissions