webOS Nation Forums >  webOS Discussion >  webOS Tips, Info & Resources > Stuck in headset mode: permanent, easy fix
Stuck in headset mode: permanent, easy fix
  Reply
Like Tree5Likes

 
Thread Tools Display Modes
Old 05/13/2011, 06:13 AM   #21 (permalink)
Member
 
leebae's Avatar
 
Posts: 200
I have been afraid to use my headphone jack, I will give this a shot. Thanks.
leebae is offline   Reply With Quote
Old 05/15/2011, 10:03 PM   #22 (permalink)
Member
 
Posts: 20
That is your name, cause graphite is black. I had my old pre plug into my aux. enroute to St. Louis from K.C.MO. As I got closer to town I started making calls, thats when I found out the speakerphone only worked. I was near a mall ,so I ask sprint. The rep. said I don't know I will google it. She came up with nothing. So when I got to my hotel, I used their computer for Pre central. I got the remedy and went to Auto Zone. Two dollars and change fixed my pre while out of town. As the A-Team says " I love it when a plan comes together"

Thanks much: The PRE CENTRAL FAMILY ROCKS!!!!!!!!!!!!!!!!!
rapaross is offline   Reply With Quote
Old 05/15/2011, 11:31 PM   #23 (permalink)
Member
 
Posts: 1,138
another success story. my pre got stuck in headset mode a few days ago. i tried the graphite trick tonight (from a pencil shaving), and it worked.

i pour some graphite powder in, dumped the excess, then turn the pre back on. after about 7 or 8 headphone insert and pull, the phone was no longer stuck in headset mode. the 7 or 8 insert and pull probably helped get the powder into the right places to fix the issue.

anyhow. thank you for this post!
__________________
--

Get your virtual onscreen keyboard themes & installation instructions here

Free 2GB of online storage, with automatic synching between multiple devices, on Dropbox
un_designer is offline   Reply With Quote
Old 05/16/2011, 01:59 AM   #24 (permalink)
Member
 
avnera's Avatar
 
Posts: 174
the problem started yesterday. first time i hear about such problem. luckily enough i saw this thread.
all I could think of was: "i can't believe i'm inserting pencil dust into the headset jack..."

but so far so good!
Thanks!
__________________
Avner.
@avnerarbel

WritePad HD - http://goo.gl/8RQmn
Coloring Book HD - http://goo.gl/XgezU
Animal Baby Piano - http://goo.gl/Y5UXg
Four in a row - http://goo.gl/tHF63
avnera is offline   Reply With Quote
Old 05/18/2011, 08:33 PM   #25 (permalink)
Member
 
blue duck butter's Avatar
 
Posts: 718
No problem! Pass the word on!
blue duck butter is offline   Reply With Quote
Old 05/18/2011, 09:48 PM   #26 (permalink)
Member
 
spikea4's Avatar
 
Posts: 455
Have Pre 2. Every time I listened to a pod cast with ear phones. When I would unplug the ear phones, all system sounds were silenced. I would have to do a full reboot to fix.

Wow, just used pencil shavings and it worked. Unreal! Thank you!

-- Sent from my Palm Pre using Forums
spikea4 is offline   Reply With Quote
Old 05/23/2011, 10:26 PM   #27 (permalink)
Member
 
Posts: 16
Worked like a charm, thanks OP.
Boregardo is offline   Reply With Quote
Old 06/06/2011, 11:37 PM   #28 (permalink)
ggs
Member
 
Posts: 7
I shaved down a pencil lead with a nail file, plugged/unplugged the headphones a dozen times, and now it's working again. Thanks!!!
ggs is offline   Reply With Quote
Old 06/28/2011, 04:21 PM   #29 (permalink)
Member
 
drk65's Avatar
 
Posts: 28
I'm not sure what kind of "Voodoo Black Magic" you conjured up to develop this fix, but it works! --- I actually used this process to repair my colleagues Pre-, whose been dealing with this issue for 6 months! As another poster said, I was sitting there with this guy's phone, saying to myself... "I can't believe I'm dumping pencil powder into this phone... and how is it going to fix anything... but hey... it's worth a shot... and it's not my phone!

Follow-Up Curiosity Question... How did you come up with the idea for this fix, and can you briefly explain HOW & WHY IT WORKS?!?!

Thanks again!!!
drk65 is offline   Reply With Quote
Old 06/29/2011, 07:12 AM   #30 (permalink)
Member
 
Posts: 386
My phone got stuck, and I just shaved some graphite from a pencil, BAM! Works!
pezman726 is offline   Reply With Quote
Old 06/29/2011, 10:47 AM   #31 (permalink)
Member
 
ryancell's Avatar
 
Posts: 515
chalk up one more fix. Hope it lasts! I used a pencil and a knife and just shaved off the lead and dumped some in there. After about 5-10 in/out of a headphone jack the screen lit up and works. I always test if its stuck by going into the phone app with the ringer on and tapping keys. If I dont hear the the beeps I know its stuck. So far so good. Thanks!
ryancell is offline   Reply With Quote
Old 08/03/2011, 12:32 AM   #32 (permalink)
webOS Enthusiast
 
Abyssul's Avatar
 
Posts: 2,119
This fix also works for faulty ringer switches. Just put some powder in the indent in the ringer switch then flip the switch, fill the other side, and then flip the switch a few times to mix the powder.

I had a Pre- that was literally freaking out, but once I put the powder in there and flipped the switch a little, it behaved like normal.

Also, this trick fixed my headphone jack on my Pre2 so far.
__________________


If I helped you or you have downloaded one of my files,
then least you could do is click the "Thanks" button.
Abyssul is offline   Reply With Quote
Old 08/21/2011, 10:24 PM   #33 (permalink)
Member
 
xberserker's Avatar
 
Posts: 134
Tried this and got it so it won't switch to headset mode after a call. But now I can't listen to music via my headphones. On the ghastly headset if I try to force it I get:

Return Value : false
error text: could not set current scenario. Failed.

permanent fix indeed, lol. Oh well. At least I can make calls now. Sigh ... this launch day Pre- is showing it's age.

Last edited by xberserker; 08/21/2011 at 10:49 PM.
xberserker is offline   Reply With Quote
Old 08/30/2011, 06:03 AM   #34 (permalink)
Member
 
Posts: 149
thanks, worked for me! very happy to have this fixed. we'll see if it's permanent though.

i used a pencil rather than a can of graphite, but otherwise followed the instructions in the first post.
gastr is offline   Reply With Quote
Old 09/12/2011, 09:39 PM   #35 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by Wayne173 View Post
I posted a fix about a week ago and found that (IMO) the cause of the headset issue is the little contacts in the headphone jack are outta wack. The contacts that touch the board are barely touching. When I took mine apart and popped the headphone jack out the two bottom contact were slightly lower than the top two. I just rasied all four to and even above 'normal' height. Popped it back in and no issues since. My phones music app use to pause when opening/closing the slider...gone. Calls going into headset mode...gone.
I just completed a Sprint to FrankenPre2 conversion and had this exact symptom, stuck in headset mode, speaker phone working fine. Your suggestion led me to reopen my phone and I discovered that I had accidentally let the battery removal tab get stuck under the bezel. So it was physically preventing the head phone jack prongs from making contact with the circuit board. It's an embarrassing mistake, but an easy one to make and relatively easy fix. So, in case you've just swapped comm boards on phones and your phone seems to be stuck in headphone mode, make sure that you didn't do the same thing I did. If so, just loosen the two top screws and pry the battery out. You should be able to pull the tab out from under the bezel.

Thanks for the tip!
Dan Pass is offline   Reply With Quote
Old 09/22/2011, 07:35 PM   #36 (permalink)
Member
 
tp2386's Avatar
 
Posts: 92
I can't believe this actually works. Thank you so much!
tp2386 is offline   Reply With Quote
Old 09/22/2011, 08:44 PM   #37 (permalink)
Member
 
Mr._Happy's Avatar
 
Posts: 101
I can't believe it either but I'm sure glad it does. I've been without music for a while.

I had been using my blue-tooth headset for music almost exclusively (wired headset had gotten scratchy and lost a channel if bumped, so I tended to use the blue-tooth more - better sound anyway), but one night the blue-tooth battery died, so I plugged in my stock Pre headset it and finished listening to my play-list.

The next day I discovered blue-tooth wouldn't work to listen to music, radio, or podcasts, although it would work for voice mail. Then I discovered the headset wouldn't work for answering a call and deduced, slowly but surely, that I had got stuck in headset mode.

I read up all kinds of fixes here and nothing worked, so I've just lived with it since the beginning of August. My Jawbone Icon worked like a champ to allow me to continue to use the phone as a phone, but the ringer volume was weird (I could barely hear it ring or notify me when mail or texts arrived - those sounds were quieter, independent of whatever sound setting, like they are when the headset is plugged in), and I was just bummed to be cut off from my MP3s and podcasts.

I didn't see this fix in my initial travels around here when I was specifically looking to fix it back in early August, but tonight as I was lurking around and checking reactions to the recent HP drama I happened to see this thread.

So I took a deep breath and scraped off some No. 2 pencil shavings and maneuvered them into the headset port.

Wow. Too easy.

The wired headset is still scratchy and still loses a channel if bumped, but it now comes in and out of headset/handset mode. I can once again use the handset to answer and listen to calls and I can also use a blue-tooth headset to listen to music, podcasts, etc.

So great. Thanks.
__________________
Trēo 650 -> Trēo 700P -> Trēo 755P -> Prē

Last edited by Mr._Happy; 09/22/2011 at 08:54 PM.
Mr._Happy is offline   Reply With Quote
Old 09/26/2011, 12:46 PM   #38 (permalink)
Member
 
El Valluco's Avatar
 
Posts: 136
Oh man, I can't WAIT to try this!! Big thanks!
El Valluco is offline   Reply With Quote
Old 12/10/2011, 01:49 AM   #39 (permalink)
Member
 
Posts: 1
I don't have a Pre, but an Htc Inspire. My second one after my other one crapped out on me. This one had the headset icon stuck since Day 2. I was so close to literally taking it apart. Luckily I found this thread. Thank you guys so much.

I had some silicone lubricant in my garage so I used that in place of graphite powder. Used a liberal amount and stuck a jack into it and voila! Works perfectly now.

I can finally stop sounding like that damned Verizon guy whenever someone calls me.
luvettes91 is offline   Reply With Quote
Old 12/13/2011, 06:13 AM   #40 (permalink)
Member
 
Posts: 2
holy sagging ballbag, that worked perfectly. I had some silicone spray in the basement that i use on hinges and what not. applied liberal coating to headset, inserted ONCE into pre 2 and BOOM! i can now hear the tones when i dial. I'm pretty nerdy and savy, so it embarasses me to say i didnt find this thread before. So...those 3 "faulty" pre plus' i returned back in the day were never really broken. So now i'm in the camp that never had a NEW Pre or Pre 2 break on me. The refurbs they gave for my "broken" pre's were total sh-t, but the new ones apparently were fine.

THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU
upayne@yahoo.com is offline   Reply With Quote
Reply

 

Tags
headset mode, no sound, stuck headset mode

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0