Results 1 to 18 of 18
Like Tree1Likes
  • 1 Post By stuarty
  1.    #1  
    I'm posting this as a quick success story and because there is conflicting information elsewhere online. All the other posts I have seen suggest that the Palm Pre cannot join Eduroam networks.

    I am able to join a university Eduroam wifi network easily on my Palm Pre Plus. In 'Wifi preferences' I chose 'join network', entered 'eduroam' (case sensitive) as the network name and chose 'Enterprise' as the option in the 'security' menu. I entered my username and password and joined the network. I did not need to install any certificates. Palm Knowledge Base article #47857 lists preinstalled certificates; my university uses an AddTrust external root certificate which seems to come preinstalled.

    This means joining Eduroam networks may be easier on a Webos device than practically any other. iOS, Windows mobile or Symbian systems seem to need to install a root certificate.

    My pre + is running 1.4.5 and GSM. I did have links in this post but have too few posts for links to be allowed.

    YMMV
    Last edited by stuarty; 01/20/2011 at 02:43 PM. Reason: Added more info, corrected spellings
    MAMISHO likes this.
  2. #2  
    Thanks for this post, it is good to know. I have had a problem signing into my company wifi network and this did the trick.
    Palm m130 > Verizon Trēo 650 > Verizon Trēo 755p > Verizon Palm Prē Plus > TouchPad > Verizon Palm Prē 2
    ~ The Future's Just Not What it Used To Be ~
  3. #3  
    I was directly asked my username first time I tried to connect.

    It's nice to see advantages of WebOs compared to other mobile OS.

  4.    #4  
    Just to say that this still seems to work easily with webos 2.1. I upgraded my prprpr&#$275$; + $and$ $re$-$entered$ $my$ $authentication$ $details$ $and$ $connected$ $straightaway$.
  5. #5  
    Well, I'm having no joy on Eduroam at Kingston University, London.

    Works fine on Android and iOS devices I have.

    Have tried installing certificates and manual config - no joy.

    I'm on a Pre- with 2.1, incidentally.
  6.    #6  
    I upgraded to a PrPrPr&#$275$; $2$ ($came$ $with$ $WebOS$ $2$.$1$ $installed$) $and$ $logging$ $into$ $Eduroam$ $still$ $works$ $easily$ $for$ $me$; $still$ $no$ $need$ $for$ $manual$ $config$, $just$ $follow$ $instructions$ $above$.

    When I have had problems connecting it seems as though they are to do with signal strength as much as anything. I do occasionally get the 'Unable to connect. Try again.' message but a repeated attempt (sometimes two or three) is then successful.
  7. #7  
    Quote Originally Posted by stuarty View Post
    I'm posting this as a quick success story and because there is conflicting information elsewhere online. All the other posts I have seen suggest that the Palm Pre cannot join Eduroam networks.

    ...................................................

    This means joining Eduroam networks may be easier on a Webos device than practically any other. iOS, Windows mobile or Symbian systems seem to need to install a root certificate.

    ......................................................

    YMMV
    I'm unable to join eduroam at another UK uni. I have tried both a TouchPad and a Pre3 with the addtrust certificate that our university uses installed, but no joy.

    WebOS internals has an advanced wifi page that recommends some command line stuff using a wpa_cli copied from Debian arm, but that isn't working for me either....

    Any other success stories out there, particularly UK eduroam?
  8. #8  
    Joining eduroam (in Germany) with my Pre3 worked completely smooth :-)
  9. #9  
    I didn't even need to use all of the above in order to access eduroam. The only problem was that my Uni uses a proxy and TP doesn't support it.
  10. #10  
    Quote Originally Posted by ginpre View Post
    Joining eduroam (in Germany) with my Pre3 worked completely smooth :-)
    I wonder what the quirk is with the setup here. There is no problem connecting with an Android handset........

    We have PEAP-MSCHAPv2, this seems to be causing issues for a lot of folk:

    forums.hpwebos.com/t5/HP-TouchPad-Software-Hardware/ISSUE-Wifi-and-Enterprise-Networks-No-PEAP-MSCHAPv2-amp-PEAP-GTC/td-p/353706/page/2
    Last edited by professordes; 09/05/2011 at 09:48 AM. Reason: more info
  11. #11  
    Seems to be an issue with eduroam in the UK.

    It worked fine with my Pre and my MacBook in Germany, at Coventry University however I only had issues... The IT staff seemed extremely incompetent at CovUni as well.

    The computers they had were new but slow as ****.
  12. #12  
    Yaay - got the WebOS internals stuff working to connect to PEAP-MSCHAPv2 (eduroam in UK) with a script "EDU" (sitting in /usr/local/sbin/ ) that looks like this:

    cp /usr/local/wpa_supplicant.conf /tmp/.wpa_supplicant.conf
    chmod a-w /tmp/.wpa_supplicant.conf
    /usr/local/sbin/wpa_cli -i eth0 -p /var/run/wpa_supplicant/ reconfigure
    

    and a wpa_supplicant.conf (sitting in /usr/local/) that looks like:

    ctrl_interface=DIR=/var/run/wpa_supplicant/
    network={
    ssid="eduroam"
    mode=0
    proto=WPA2
    key_mgmt=WPA-EAP IEEE8021X
    eap=PEAP
    identity="MYNAME"
    anonymous_identity="WOTEVER"
    password="WOTEVER"
    phase2="auth=MSCHAPV2"
    }
    

    The trick seemed to be to run EDU a couple of times in quick succession, the first returns an error - the second gives OK.

    I needed to manually run

    dhclient eth0

    and add a name server after this.

    All of this from

    http://www.webos-internals.org/wiki/Advanced_Wifi

    No doubt this could all be automated more slickly.
    Last edited by professordes; 09/05/2011 at 03:31 PM. Reason: credit where credit is due...
  13. #13  
    Quote Originally Posted by professordes View Post
    Yaay - got the WebOS internals stuff working to connect to PEAP-MSCHAPv2 (eduroam in UK) with a script "EDU" (sitting in /usr/local/sbin/ ) that looks like this:

    cp /usr/local/wpa_supplicant.conf /tmp/.wpa_supplicant.conf
    chmod a-w /tmp/.wpa_supplicant.conf
    /usr/local/sbin/wpa_cli -i eth0 -p /var/run/wpa_supplicant/ reconfigure
    

    and a wpa_supplicant.conf (sitting in /usr/local/) that looks like:

    ctrl_interface=DIR=/var/run/wpa_supplicant/
    network={
    ssid="eduroam"
    mode=0
    proto=WPA2
    key_mgmt=WPA-EAP IEEE8021X
    eap=PEAP
    identity="MYNAME"
    anonymous_identity="WOTEVER"
    password="WOTEVER"
    phase2="auth=MSCHAPV2"
    }
    

    The trick seemed to be to run EDU a couple of times in quick succession, the first returns an error - the second gives OK.

    I needed to manually run

    dhclient eth0

    and add a name server after this.

    No doubt this could all be automated more slickly.
    I may have spoken too soon, this repeatably connects up the underlying Linux layer when run via an xterm or novaterm over a usb cable, but I am struggling to get it to reliably work with the shiny webOS layer on top. I have got it to do this once from numerous attempts with novaterm and not at all with an xterm on a pre3. It may be a timing issue, which is highlighted as a potential problem at:

    Advanced Wifi - WebOS Internals

    I'll have a bash with a TouchPad when it next travels to my university.
    Last edited by professordes; 09/05/2011 at 03:15 PM. Reason: Fixing my dodgy spelling
  14. #14  
    Quote Originally Posted by professordes View Post
    I may have spoken too soon, this repeatably connects up
    .......................................

    I'll have a bash with a TouchPad when it next travels to my university.
    Same story with a TouchPad - the webOS layer shows a "connecting" icon, rather than connected and some apps such as the browser work, others (Engadget, Facebook...) don't.
  15. #15  
    I have a similar, but different problem with eduroam.

    I have had a Pre and now I have a Pixi Plus both with OS 1.4.5. I never had problems connecting to eduraom at the Universitat de Valencia in the first place (I didn't even have to manual connect, just tab eduroam, userid, password et voilą), but I have encountered the a different problem on both devices when I tried to RE-connect for the second time to this network - it just does not connect a second time. (i.e. the wifi symbol has the three dots on top and (sometimes) it says unable to connect.)

    I have tried it a couple times, turned wifi on and off again, tried again, tried in a different building, tried at the same spot where I have connected the first time (assuming that it has something to do with the router), but no success.

    With the Pre I didn't mind to much, because I didn't need the Wifi in the Uni. But now I would like to have Wifi...

    Has anyone experienced something similar?
    Any suggestions?
  16. #16  
    The 3.04 update appears to fixed this on my TouchPad

    The enterprise wifi settings have been tweaked. There are options to ignore certificate verification and to choose protocols. Choosing PEAP and ignoring certificates got me connected after a few attempts.
  17. #17  
    When I read the threads about connecting Eduroam... i get confused. Writing a script ??
    Is there (now 2013) not a more simple solution ?
  18. #18  
    I'm studying one semester abroad in Sweden at the moment... And as the iPhone guys said it was not easy to connect (they had to set it up manually) and I read this thread about the difficulties of connecting to eduroam, I have to say it was totally easy on my Pre3 I downloaded the certificate to my Pre3 and installed it with Internalz, connected and it works flawlessly since then

Posting Permissions