Results 1 to 19 of 19
  1.    #1  
    We've purchased a couple of re-furbed Bell Mobility Palm Pre phones, and - let this be a lesson to you all - they have all of their previous owner's personal info still in them :-(

    What we want to do is create a second Palm Profile for the new users before we erase the existing ones, but we can't figure out how to do that. Can anyone tell us?

    Thanks!
  2. #2  
    Do a full reset on the device, and use a different email and password to sign back in. You will see that option.
    Note: You can find the full reset option in "Device Menu"
    cheers.~
  3. #3  
    you create the new profile as part of activating the phone on your carrier. one of the first steps is to give it an email address, which is used to create the profile.
  4. cmahy's Avatar
    Posts
    300 Posts
    Global Posts
    310 Global Posts
    #4  
    This is an educated guess -- one part of the homebrew world I'm not 100% clear on.

    I believe what you want to do is Doctor your phone (WebOS Doctor). That will revert it back to factory-build state and should prompt you to either login to a current Palm Profile or create a new one.

    I haven't had to doctor my phone yet, so, my apologies on being a bit vague.

    If any PreCentral folks are reading this: I would be very interested if either a Tip or general article could be put together on the Palm Profile -- I know there are lots of people who aren't clear (myself included) on all the related details.

    Good luck!
  5. #5  
    the doctor actually comes from palm, and it is the correct first step. Then refer to my prefious post.
  6. #6  
    Wiping the usb drive I would say would be the better of all, hence, wiping the phone to a brand new state. A full reset would do a good job on that. Webos doctor doesn't delete/erase things on the usb drive.
  7.    #7  
    OK, i should have mentioned that we realize that we can wipe the device, and actually did that on one, then realized that doing so also wiped all the patches and apps currently installed.

    If that's the only way, it's what we'll do, but we thought if we simply created a new Palm Profile (and it's our understanding that WebOS supports that) and then deleting the previous owner's Profile, we wouldn't have to re-install everything. is that correct? And, if so, back to my original question: how do we create a second Palm Profile on the device?

    And yes, a primer on the whole topic of Palm Profiles would be very much appreciated!
  8.    #8  
    Quote Originally Posted by Cantaffordit View Post
    you create the new profile as part of activating the phone on your carrier. one of the first steps is to give it an email address, which is used to create the profile.
    yeah.... Bell Mobility happily activated all the phones with the previous owners' data - and Profile - still on them.
  9. #9  
    Quote Originally Posted by dpaus View Post
    OK, i should have mentioned that we realize that we can wipe the device, and actually did that on one, then realized that doing so also wiped all the patches and apps currently installed.

    If that's the only way, it's what we'll do, but we thought if we simply created a new Palm Profile (and it's our understanding that WebOS supports that) and then deleting the previous owner's Profile, we wouldn't have to re-install everything.

    And yes, a primer on the whole topic of Palm Profiles would be very much appreciated!
    before you wipe the phone, go in to preware and create a "saved package list" which you can copy to your PC. Once you wipe the phone and reinstall preware, you can copy that file back and tell preware to automatically reinstall the patches and such.

    generally works very well.
  10.    #10  
    Quote Originally Posted by Cantaffordit View Post
    before you wipe the phone, go in to preware and create a "saved package list" which you can copy to your PC
    Thanks for that! OK, I've created and saved the file, but now I have no clue how to find the file.... That's one of the biggest beefs I have with WebOS apps; they can do one amazing thing each, but unless the one thing they do is exactly what you want, you're SOL.
  11. #11  
    Quote Originally Posted by dpaus View Post
    Thanks for that! OK, I've created and saved the file, but now I have no clue how to find the file.... That's one of the biggest beefs I have with WebOS apps; they can do one amazing thing each, but unless the one thing they do is exactly what you want, you're SOL.
    it's in the preware thread somewhere. Check in the preware help link on your phone.

    I can't plug in my phone to find the name, but look on your usb area for a new folder, maybe called "developer" or "preware" and see if there is a file in it.

    I'll check back later to make sure you found it. Be sure you read up on the preware "getting started" threads, too.
  12.    #12  
    Quote Originally Posted by Cantaffordit View Post
    Check in the preware help link on your phone
    Useless - can't even read it on the Pre. Managed to find it on my desktop via Google, but it only has very basic info.


    Quote Originally Posted by Cantaffordit View Post
    I can't plug in my phone to find the name, but look on your usb area for a new folder, maybe called "developer" or "preware" and see if there is a file in it.
    No candidates visible on the USB partition - in fact, no files with todays date at all.


    Quote Originally Posted by Cantaffordit View Post
    it's in the preware thread somewhere. Be sure you read up on the preware "getting started" threads, too.
    I'll go looking. But to answer the immediate question, I haven't been able to find it yet...
  13. #13  
    Quote Originally Posted by dpaus View Post
    Useless - can't even read it on the Pre. Managed to find it on my desktop via Google, but it only has very basic info.




    No candidates visible on the USB partition - in fact, no files with todays date at all.




    I'll go looking. But to answer the immediate question, I haven't been able to find it yet...
    hi, try this link:
    http://forums.precentral.net/webos-p...kage-list.html

    if you back up the list using the save/restore app, you can use that. I'm still looking, but. steps from the thread:

    Here are the steps that Rod listed before. Notice step 3 it says Don't hit update.

    1) In Preware Saved Packages List, hit Update to make sure it has the current list of installed packages.
    2) In Save/Restore, save the application data for Preware, just in case.
    3) In Preware, go to the Saved Packages List, and re-install the packages. Don't hit update, or it will clear your list.
    4) If for some reason, the Saved Packages List is not there, you can restore it from Save/Restore.
    Last edited by Cantaffordit; 09/27/2010 at 05:19 PM.
  14. #14  
    ok, here is a clarification of what I just posted. Preware puts the "package list" in a hidden file. if you have Internalz installed you could find it that way. The steps above are assuming you just doctored your Pre, which doesn't erase the contents of the usb storage area - which includes that hidden file.

    METHOD #2) if you are moving to a new phone, you take the additional step of installing the Save/Restore app and backing up the preware data. That creates a file you can see on the usb storage, and you would copy that to your PC to replace on the phone.

    if you run the doctor, the first method will work for you. if you do a "secure erase" to delete the usb drive contents and start completely fresh, you will need to use method 2.

    Is that clear? sorry i haven't tried this in a while so the specifics are coming back to me a little bit slow...
  15. #15  
    btw, the actual file location is: /media/internal/.webosinternals.patches.packages

    if you want to use Internalz to find it. i just confirmed it's there on my Pre+


    I hope I haven't confused you.
  16.    #16  
    Quote Originally Posted by Cantaffordit View Post
    btw, the actual file location is: /media/internal/.webosinternals.patches.packages

    if you want to use Internalz to find it. i just confirmed it's there on my Pre+
    Yep, it's there on my Pre, too - except that the date on it is several days ago... ***....?


    Quote Originally Posted by Cantaffordit View Post
    I hope I haven't confused you.

    It's not you that's confusing me! :-)
  17. #17  
    use save/restore and you should be fine. You can always write down which patches are installed so you can manually install them, too.
  18.    #18  
    Well, I used WebOS Doctor, created a new profile, re-installed preware, restored the files, went to Packages, was careful not to hit update, and....... Nothing. But I'm not going to waste anymore time with it, either. Thanks for your help, all of you, but I'm putting this phone aside for now.
  19. #19  
    you werent supposed to hit update, you were supposed to hit "install all"...

    what you did was write a new installed list (which would be empty)

    copy those files back from your PC to the pre and try it again... it really does work!

Tags for this Thread

Posting Permissions