Page 8 of 12 FirstFirst ... 3456789101112 LastLast
Results 141 to 160 of 234
Like Tree1Likes
  1. #141  
    Quote Originally Posted by kbrabble View Post
    I have been noticing a few problems with the WiFi triggers added to this. It seems that in order for this to work correctly you must first be connected to a access point, then disconnected. If the phone is rebooted, and wifi has not been connected, then disconnected, the data will not turn on with any of the app triggers. Once WiFi has connected and disconnected the triggers work. Anyone else having this problem? Is this a bug with Mode Switcher, or a "feature"? It would be nice if there were a simple WifI on/off trigger, instead on just connected/disconnected....
    Sorry, I do not mean to step out of this discussion.

    I too have issues w the wifi triggers on occasion. Much like you describe. I guess this is still a work in progress.

    I am testing the Wifi Disconnected From ____ to see if it works better. I have found that if a public wifi network is available, it can affect the triggers even if you never connect to it. The phone seems to know it's there and open and the 'disconnected' trigger is falsified.

    Most days I do not have issues. I guess you need to find what works for you and fly with it.
  2. #142  
    Just a quick word on wifi triggers: there are some known issues with them. I believe sconix has plans on how to address them somehow.

    The thing to remember is that we are miles ahead of a stock phone withe al that sconix has brought us in ModeSwitcher and drahgon's mode design.
  3. #143  
    Quote Originally Posted by allonon View Post
    I have a wifi disconnected from trigger that is working when using data on demand.

    if triggers seem to get stuck for me (happens every now and then with too many things happening at once), I try to normalize where all the modes are off, go into mode switcher config, then exit mode switcher. This kind of jump starts default mode for me and seems to get everything back on track
    I use a similar approach. I buitl a mode that closes all modifer modes when I toggle the silent switch. I need to add a lauch of ModeSwitcher to it.
  4. dizzwave's Avatar
    Posts
    98 Posts
    Global Posts
    109 Global Posts
    #144  
    Quote Originally Posted by palmuse View Post
    Could you post some details or a link to the battery you ordered?
    Sure, I just searched Amazon for "palm pre battery" and picked the cheapest one. It was $7 shipped, so I ordered two (one for the wife too). It looks like that one's gone, but I see some that are around $7 + shipping...

    One of the ones I received is the older style "Cell origin: Japan" battery, and one is the newer "Cell origin: Korea". I'm giving the Japan one its initial charge right now (it was dead when it arrived). According to Dr Battery its health is 100%, but who knows. It's probably better than my old one though.
  5. #145  
    Quote Originally Posted by dizzwave View Post
    Sure, I just searched Amazon for "palm pre battery" and picked the cheapest one. It was $7 shipped, so I ordered two (one for the wife too). It looks like that one's gone, but I see some that are around $7 + shipping...

    One of the ones I received is the older style "Cell origin: Japan" battery, and one is the newer "Cell origin: Korea". I'm giving the Japan one its initial charge right now (it was dead when it arrived). According to Dr Battery its health is 100%, but who knows. It's probably better than my old one though.
    thx
  6.    #146  
    Quote Originally Posted by EVOandBACK View Post
    Tried this whole thing with mode switcher. Cool idea, but it didnt work for me. I suspect it may be because my battery issues are due to a weak signal in my office, so this does not help in that regard. Wish it did though. I would love some better battery life. It might be the #1 reason I want a new phone.
    This will ALWAYS increase your battery life no matter what. A weak signal will drain your battery fast but keeping data on 24/7 will increase your battery drain big time. If it didnt work for you then the error most likey rest with your setting it up incorrectly, using it incorrectly or some bug that isnt turning data off.

    I also suggest in your situation that you add your phone radio to Data on Demand so that phone only turns on when your data turns on. That will definitely solve your problem.
  7. #147  
    drahgon----great thread. Truly.
    I have my emails set to every 15 min for EAS, and every 30 for Google. In your suggested settings in the first post, I see you set the Email as items arrive.

    Is that the correct setting for my scenario? I want to retrieve email per my original settings.
    Also. My carrier name changed to white after this install. How do I get it back to blue?

    Thanks
    Last edited by NABRIL15; 09/23/2010 at 07:10 PM.
  8.    #148  
    Quote Originally Posted by NABRIL15 View Post
    drahgon----great thread. Truly.
    I have my emails set to every 15 min for EAS, and every 30 for Google. In your suggested settings in the first post, I see you set the Email as items arrive.

    Is that the correct setting for my scenario? I want to retrieve email per my original settings.
    Also. My carrier name changed to white after this install. How do I get it back to blue?

    Thanks
    It is impossible to get your email per your original settings because what this does is turn your data connection off when you are not using your phone or an app that needs data access. That mean if your phone is in your pocket for 2 hours not being used then you won't get email for 2 hours. Therefore setting your email to as arrives will give you your email as soon as possible which could be often if you are always opening data dependent apps or longer if you keep your phone on standby. There is a timer that turns the data on every two hours in case this happens so that at minimum you get email in 2 hours.
  9. kbrabble's Avatar
    Posts
    82 Posts
    Global Posts
    100 Global Posts
    #149  
    Quote Originally Posted by EVOandBACK View Post
    Tried this whole thing with mode switcher. Cool idea, but it didnt work for me. I suspect it may be because my battery issues are due to a weak signal in my office, so this does not help in that regard. Wish it did though. I would love some better battery life. It might be the #1 reason I want a new phone.
    You might try creating a "Work" mode that either turns roaming off, or set it to roaming only, depending on how you get the best signal. This way the phone is not constantly searching and switching from sprint to roam. I have the same problems at work, setting my phone to roam only greatly improves the situation.
  10. #150  
    thanks...dragon.

    how do I return the carrier color to the color it was before? Do you happen to know? I will check the thread for the patch.
  11.    #151  
    Quote Originally Posted by NABRIL15 View Post
    thanks...dragon.

    how do I return the carrier color to the color it was before? Do you happen to know? I will check the thread for the patch.
    No prob. My carrier text has always been white so I'm not sure. If there is a patch that changes it then some other patch you installed must be conflicting with it.
  12. #152  
    Quote Originally Posted by drahgon View Post
    It is impossible to get your email per your original settings because what this does is turn your data connection off when you are not using your phone or an app that needs data access. That mean if your phone is in your pocket for 2 hours not being used then you won't get email for 2 hours. Therefore setting your email to as arrives will give you your email as soon as possible which could be often if you are always opening data dependent apps or longer if you keep your phone on standby. There is a timer that turns the data on every two hours in case this happens so that at minimum you get email in 2 hours.
    drahgon--in my question I was refering to phone only mode, not data mode. In your settings on the first post, i see you add the trigger for group 5 (the one with the email check every 2 hours) to the Data On profile:
    Group 5
    32. Now click "Group >" button on the bottom right of the screen
    33. Click "Add Trigger" and click "Time Interval Trigger".
    34. Set Mode to "Repeating", Active to "5 minutes" and Every to "2 Hours"

    So I am confused. You added the email check every 2 hours as a trigger to the DataOn profile.

    Thanks
    Last edited by NABRIL15; 09/24/2010 at 11:40 AM.
  13. #153  
    Quote Originally Posted by palmuse View Post
    Below is a modification of drahgon's original data on demand mode. It adds the following:

    1) a check for Wifi being disconnected (meaning it is not connected to any network or hotspot) for all trigger groups - when Wifi IS connected to a network, the data radio stays off (you do not need both unless the Wifi is weak and drops out)

    2) a screenstate check to turn off data when the screen is off, the phone is not charging and the specific apps are not in the forground (basically when you are not using it) - when you "wake" the phone for 15 sec, data will turn on - turn off the screen for 15 sec, data turns off - also turns off data when the proximity sensor turns off the screen during a phone call (may keep the phone from getting as warm)

    NOTES:
    1) order of the triggers/groups not important (I have six groups here)

    2) you can set battery levels to your liking

    3) interval trigger can be set to your liking (drahgon had every 2 hours - I may push mine out as well)


    Activation Triggers (5)
    (Group 5 -*specific application triggers)
    ** * Application
    ** * * State: Foreground
    ** * * Application: {name}
    ** * * Delay: 60 Seconds*
    (repeat for all applications...)
    (add at any time...)
    ** * Wi-Fi Network*
    ** * * State: Disconnected
    ** * * Delay: No Delay
    (*added Wi-fi disconnected check)
    ------------------------------------------------


    EDIT: Not sure where the prefix * came from (should be spaces). The items with an ending * are where I changed mind from the original. I tried to explain the chnages as a footnote.
    palmuse---thanks for your settings. Dragohn had the application triggers at group 0. You moved them to 5, correct?
  14. dizzwave's Avatar
    Posts
    98 Posts
    Global Posts
    109 Global Posts
    #154  
    hi again, DOD (Data On Demand) lovers...
    After playing around with this for a few days, I've determined that it's a bit overkill for my situation. On work days, my Touchstone is almost always an arm's reach away, thus I rarely go below 80% batt during the week. So, with DOD I'm staying above 90, but don't get immediate emails. Hardly worth it.
    *However*... There are times when I'd love to use this. Weekends when I'm out on day trips, evenings I'm expecting to play a bunch of Angry Birds away from a charger, etc. So I figured out how to create DOD as a mode itself, that's different from the default mode. Know what I mean?
    the idea is that you have three modes:
    1) your default mode, which has data ON.
    2) your Data On Demand mode, which is essentially equivalent to Drahgon's default mode. You can set it to only be turned on manually (via launcher shortcut, mode menu, etc.), or have it turn on on weekends, or whatever.
    3) your Data On mode, which is basically the same as Drahgon's Data On mode. The difference (and the "trick") is that it doesn't get triggered unless Data On Demand mode is already on.

    so. Anybody interested? Here's how you do it: (typing this on my Pre, sorry about formatting!)
    Edit Default Mode
    --Settings:
    ---Notify: Disabled (I recommend this, unless you want banners every time you open a net app, even in default mode)
    ---Connections: Data:Enabled
    Everything else should stay the same, or as you like it.

    Now create a new custom mode called Data On Demand. Here are my settings:
    Mode Type: Normal
    Auto Start/Close: Only Manually (tho you can set this to Immediate, and add a trigger to turn it on on weekends or whatever...but I kind of like having full control of it.)
    Settings:
    --Connections:
    ---Phone: Enabled
    ---Data: Disabled
    Apps:
    --Behaviour:
    ---On Start: Do Nothing
    ---On Close: Close Started
    --click "Add MS", and in the new MS block, set the following:
    ----Process: After Mode Close
    ----Action: Close Mode
    ----Mode: Data On
    (the prev step ensures that when you exit DOD mode, the Data On modifier mode is closed as well.)

    ok, one more step. Go into your Data On mode, and click Apps, then "Add MS". In the new MS block, set:
    --Process: Before Mode Start
    --Action: Require Mode
    --Mode: Data On Demand
    The prev step makes sure that the Data On mode is only triggered when the DOD mode is already on. Nifty, huh!

    I think that's all. Anyone else who tries it, please report back. Or maybe I'm the only one this picky and crazy about configuring my Pre (tho I *highly* doubt that! Ha!).
    -dave
    Last edited by dizzwave; 09/25/2010 at 09:46 PM.
  15. #155  
    good stuff., but i dont fully get it. I have read the manual and posts, and still dont get this. Sorry.

    I want the data off all day, and when I launch data-dependent apps to turn data on, regardless of battery level, charger, whatever. Unfortunately it takes 15 secs to activate the data connection, no? I wish it could be instant.
    How do I do that?
    What type of mode: normal or modifier?
    settings: data on
    triggers: all the data-dependent apps

    That's it, right?

    Thank you
  16. dizzwave's Avatar
    Posts
    98 Posts
    Global Posts
    109 Global Posts
    #156  
    Hey Nabril, the 15 seconds thing is confusing. That delay time is not actually the time it waits to turn on data -- rather, it's the time you want Mode Switcher to wait between the time you close a data app, and when it turns off Data mode. (I actually jacked mine up to 60 seconds, cuz I don't like it switching out of data mode just because I am sending a text or checking my calendar.) However, just by the nature of the Pre, it does sometimes take a few seconds to turn on data. I've found that with some apps it's instant, and sometimes it takes 5-10 seconds.

    So, to do what you're talking about, basically setup the modes exactly as Drahgon outlined in the first post of this thread. Except, you can remove the battery- and charger-related triggers. (You'll just need the data-dependent apps trigger, like you said.)

    This stuff is really complex at first, but once you play around with it a bit and it clicks, it's pretty easy. Good luck!
    -dave
  17. #157  
    Quote Originally Posted by NABRIL15 View Post
    palmuse---thanks for your settings. Dragohn had the application triggers at group 0. You moved them to 5, correct?
    np.

    Right, may have switched the order a bit. The order of the group triggers does not matter.
  18. #158  
    dizzwave/whomever
    i think i have this working fairly well. What I notice is that whenever I have an app opened in my triggers (email, precentral, etc), it closes data while I still have the app open. All my app triggers are set for 60 seconds, and dizzwave's behavior described above makes sense. However, i see my data shutting off BEFORE i've closed the app.

    Issue with app? Or do I have another trigger that is closing the mode? (I've looked).



    Sprint Pre-
    UK Screenstate 500/1ghz
    Mode Switcher--RULES !!!
    Advanced preferences by Sconix
    Lots of patches
  19. #159  
    drahgon,

    Thanks VERY much for this information! I've been looking for a way to maximize my battery life when I'm away from my wifi connections at home and at work. I was considering getting an extended life battery but I think now I'll save my money.

    I couldn't get the import feature to work in Mode Switcher so I just followed your instructions in the first post. It took a while to enter all my internet-enabled apps, but the process really is simpler than it sounds. I made only two small changes to your instructions: I set the delay for my Internet Browser to 60 seconds instead of 30 (to make Find as you Type internet searching easier) and turned off the GPS in Phone Only mode (since I don't normally use GPS unless I'm using Google Maps, then I turn it on manually). I strongly suggest anyone who's using this setup get Device Menu Megamix or a similar patch. It makes turning the various radios on & off much easier.

    My results have been spectacular. Yesterday, I knew I was going out late for a meeting, so I switched off the wifi in the morning and went with Data on Demand for the entire day. When I got home at 8:30 at night, after a day of light use my battery still had 70% life left!

    Thanks again for all your work and for sharing this with all of us. It's community activity like this that makes me glad I own a Pre.
    --
    I am a (new) Palm user!
  20. #160  
    Quote Originally Posted by NABRIL15 View Post
    dizzwave/whomever
    i think i have this working fairly well. What I notice is that whenever I have an app opened in my triggers (email, precentral, etc), it closes data while I still have the app open. All my app triggers are set for 60 seconds, and dizzwave's behavior described above makes sense. However, i see my data shutting off BEFORE i've closed the app.

    Issue with app? Or do I have another trigger that is closing the mode? (I've looked).
    I noticed that you didn't mention if your apps are open and in the foreground (as in not carded or minimized). I believe that the app must have the focus for the app trigger to work.

    Not sure this is what you are experiencing, but thought it was worth mentioning.
Page 8 of 12 FirstFirst ... 3456789101112 LastLast

Posting Permissions