Results 1 to 16 of 16
  1. martinp13's Avatar
    Posts
    77 Posts
    Global Posts
    83 Global Posts
       #1  
    I search for the answer but came up empty.

    How do I kill a background app? I ran one that puts up a notification every 5 min or so, and even though it's been swiped away, it's still running in the background. How can I shut this app up?

    Thanks!
  2. #2  
    That depends on the app... but restarting your phone usually works too. If its a patch... then you will have to uninstall the patch... like I said... when you want help, more information provides better answers... less information provides generic answers like this.
  3. #3  
    If there is nothing in the notification bar to expand and swipe away, I'm stumped.

    I'm pretty sure webos 1.4.1 and later require a scene to be active or the application is closed. Unless I guess if it were some Homebrew working around it, or patch.

    If you could say what is alerting you every little bit it would be pretty helpful.
  4. #4  
    Quote Originally Posted by alex.dobeck View Post
    If there is nothing in the notification bar to expand and swipe away, I'm stumped.

    I'm pretty sure webos 1.4.1 and later require a scene to be active or the application is closed. Unless I guess if it were some Homebrew working around it, or patch.

    If you could say what is alerting you every little bit it would be pretty helpful.
    I was thinking he was possibly getting a banner from the temp patch... hard to tell really.

    You are correct... they now require apps to run on the dasboard... I think that changed in 1.2... I didnt want to rule out the idea he hadnt updated...
  5. martinp13's Avatar
    Posts
    77 Posts
    Global Posts
    83 Global Posts
       #5  
    blue, I don't know what more you needed from my opening post. I said it's an app, not a patch, and what its behavior was. Not asking for code help: it's not my app. Just want to strangle it.

    It's an app called AviationWeather Beta. You put in an airport code and it checks the weather for that airport and you get a notification every stinkin time the data gets updated. You swipe the app away then expand and swipe the notification, and ~5 min later you have another one. Eventually I'm sure that will be fixed, but right now I have a noisy app running. I uninstalled it for now, I know that works.

    Is there no simple three-finger way to kill a background app??? I'm on 1.4.1.1 with a few patches loaded but nothing special (4x4, GPS in menu, etc)
  6. martinp13's Avatar
    Posts
    77 Posts
    Global Posts
    83 Global Posts
       #6  
    I did run JsTop and I didn't see that app running.
  7. #7  
    Not that im aware of... there is no "task manager" as part of the webOS main package... im not even sure that there is a homebrew for killing apps... closest I can think of is Jstop, but it doesnt actually kill apps far as I know, only shows them.

    Are you running 1.4.1 and having this app run in the background? The only apps allowed to run in the background on newer iterations of webOS have to sleep most of the time, with simply a wake up event every so often. Is that what this app is doing? Have you looked in the settings for the app itself to see if you can reduce notifications?
  8. #8  
    doesn't the application have a way to stop updates? The application should have update on/off toggle or perhaps a button saying stop updates, maybe you have to remove the location from the list, if the application doesn't have a way to stop updates the dev must be notified.

    PS. The apps don't run continuesly, the app is woken every 5mins.
  9. #9  
    Quote Originally Posted by martinp13 View Post
    blue, I don't know what more you needed from my opening post. I said it's an app, not a patch, and what its behavior was. Not asking for code help: it's not my app. Just want to strangle it.

    It's an app called AviationWeather Beta. You put in an airport code and it checks the weather for that airport and you get a notification every stinkin time the data gets updated. You swipe the app away then expand and swipe the notification, and ~5 min later you have another one. Eventually I'm sure that will be fixed, but right now I have a noisy app running. I uninstalled it for now, I know that works.

    Is there no simple three-finger way to kill a background app??? I'm on 1.4.1.1 with a few patches loaded but nothing special (4x4, GPS in menu, etc)
    Ok... im installing the app now... let me see if I can replicate.
  10. #10  
    Did you try removing the app completely and reinstalling it?

    Launch App Catalog
    click the bag in the lower right
    choose the app
    choose delete app from the app menu on the upper left
    then find the app in the app catalog (or preware) again and reinstall
  11. #11  
    Quote Originally Posted by martinp13 View Post
    I did run JsTop and I didn't see that app running.
    Ok... in the preferences I see a selection to change the notification frequency from 1 minute up to 60 minutes... literally in 1 minute intervals.

    Can you give me an ICAO code for an airport? Im not familiar with that naming convention and I already tried LAX, SDO, SFO and the like...
  12. #12  
    Quote Originally Posted by bluewanders View Post
    Not that im aware of... there is no "task manager" as part of the webOS main package... im not even sure that there is a homebrew for killing apps... closest I can think of is Jstop, but it doesnt actually kill apps far as I know, only shows them.

    Are you running 1.4.1 and having this app run in the background? The only apps allowed to run in the background on newer iterations of webOS have to sleep most of the time, with simply a wake up event every so often. Is that what this app is doing? Have you looked in the settings for the app itself to see if you can reduce notifications?
    I believe you can swipe an app off JStop and confirm the delete to kill an app. But, if its not showing in JStop, that won't help.
  13. #13  
    Ok yeah... so I did a google search and came up with KLAX as a code... set my polling frequency to 1 minute and swiped it away... sure enough... the damn thing I pretty annoying now. Theres no option to shut the thing down either...

    Aviation weather does show up in my jstop though... I had to wait for the next time it polled the server... and it does indeed kill it.

    Sounds to me like its just poor design on the part of the developer. They need to add a toggle to shut the notifications off.

    Update... jstop only kills that notification. The next time it polls it comes up again. *sigh* dirty programming conventions.
    Last edited by bluewanders; 07/20/2010 at 06:15 PM.
  14. #14  
    Quote Originally Posted by bluewanders View Post
    Ok... in the preferences I see a selection to change the notification frequency from 1 minute up to 60 minutes... literally in 1 minute intervals.

    Can you give me an ICAO code for an airport? Im not familiar with that naming convention and I already tried LAX, SDO, SFO and the like...
    DTW JFK ATL

    Restarting the device Orange/Silver Button+Sym+R will definitely kill the app, and it shouldn't restart on phone restart (patches are required to make that happen). But every time you launch the app it will start again. The developer should put a notification off option in the preferences.
  15. martinp13's Avatar
    Posts
    77 Posts
    Global Posts
    83 Global Posts
       #15  
    I'm sure he'll fix it. In fact, when I downloaded it this morning its Preferences menu option was grayed out.

    For now the uninstall is the answer. Much faster than a reboot. Thanks everyone!
  16. #16  
    Quote Originally Posted by Joemh008 View Post
    I believe you can swipe an app off JStop and confirm the delete to kill an app. But, if its not showing in JStop, that won't help.

    That's what I was going to suggest, JStop works great. But the OP didn't include it in their list, so apparently doesn't have it installed.

Posting Permissions