webOS Nation Forums >  webOS Discussion >  webOS Tips, Info & Resources > Palm Pre and GPS (Additional GPS modes: Autonomous, Assisted, and Cached)
Palm Pre and GPS (Additional GPS modes: Autonomous, Assisted, and Cached)
  Reply
Like Tree1Likes

 
Thread Tools Display Modes
Old 04/24/2011, 12:42 PM   #601 (permalink)
Member
 
Posts: 1
Hi All members,

I am new to this forum and I would like to ask a question.
I live in France and I have a Pre plus over SFR network.
Since my 2.1 update, I am experiencing a strange behavior with my GPS.
The initial fix is taking roughly 30s to 1 mn which looks fair to me but upon tracking with google maps or whatever location based tool (minimap, BFG Maps...) I cannot get a new fix before 30s
So I have to wait exactly 30s between each new fix . This is very cumbersome to me when driving.
It looks to me as if the GPS were not saying "ok" and give the coordinates when available but waits until an timeout triggers to send the coordinates to the application.
Maybe my GPS is running under a strange mode ?
Power OFF and ON did not resolve the issue either.
Also, I have to say that this happened when upgrading to webos 2.1 with German ROM. I tried to "doctor" my Pre plus with the French Rom which is available now but the behavior is the same.
I don't know if any of the different tools and methods presented in this thread would be helpful to me.
If anybody could give me some advice, I would be very thankful.

Thank you in advance,

Marc

Last edited by MarcJabes; 04/24/2011 at 01:19 PM.
MarcJabes is offline   Reply With Quote
Old 07/04/2011, 01:09 PM   #602 (permalink)
Member
 
Posts: 41
Quote:
Originally Posted by santos View Post
I didn't make any of these changes. However, I was in Germany and Austria for the past two weeks and the GPS did not work unless I had a wifi connection.

I tried all sorts of tests with the phone in airplane mode and while searching for a Sprint signal. Obviously there was no CDMA there but wifi was.
I don't really have time to scroll through 30+ pages of posts, so I don't know if this was commented on before, but I had this hack set-up (with confirmed acquisitions without any data connection, using Mapping Pro Plus on a Sprint Pre-, which I guess makes it obvious I'm from the US), and tried using GPS in Mexico on vacation with pre-loaded maps. It didn't work unless I turned on Wifi.

The weirdest thing was that after turning Wifi on and my pre "knew" I was in Mexico, it still wouldn't update further, i.e. my location stayed the same as when I had wifi on and the date/time of last fix reflected that, regardless of where I went. If I left the app open it seemed like battery was draining faster (using Battery Monitor), so maybe it was still trying, but I left that thing open for the better part of the day and it never managed to get a fix.

Anyone had any success in getting it to work in a different country than origin?
edhkim is offline   Reply With Quote
Old 07/19/2011, 05:06 PM   #603 (permalink)
Member
 
pow12390's Avatar
 
Posts: 217
After meta-doctoring my device it does not seem that I can acquire a gps location. I just downloaded NDrive and hoped it would work but with Verizon's terrible GPS system I guess I was wrong. Keep in mind before the meta-doctor my gps was working fine. However each time I would have to open VZ navigator to get a reading.
1. I have tried to get a location with just gps turned on and google off.
2. I have tried the GPS fix that is availble and I continue to get either a permanent error or a GPS timeout.
3. I have tried to run the fix and get a gps error, error occured.
Does anyone have any suggestions?
__________________
Sent from my Verizon Pre2
pow12390 is offline   Reply With Quote
Old 08/17/2011, 10:06 AM   #604 (permalink)
ght
Member
 
ght's Avatar
 
Posts: 772
Are there any Diagnostic Drivers available for the Pre2? (Looks like there were some, but the post has been deleted.)
ght is offline   Reply With Quote
Old 09/16/2011, 11:31 AM   #605 (permalink)
Member
 
Posts: 639
Help Help
Attempting this tweak on Pre- with 1.45.
Device is in Dev mode
USB Passthrough enabled
QPST installed
But having issue with win7 64 drivers. I followed various other posts that mention modifying inf files, but I cant get win to recognize the device. I have manually forced the drivers from a specific folder to device manager, but QPST configuration does not find the phone. I will attach the driver file that I am using. I modified the "HtcVcomV64.inf" file and modified the following section to look like this:
[Models.NTamd64]
%OEMDevice00% = OEMPort00, USB\VID_0830&PID_8003&MI_01

as mentioned in this thread: http://forums.precentral.net/webos-t...s-drivers.html

I know that several attempts using various files have given some of you success, but can someone who was successful at this KINDLY spell out what they did, and what files they used?
Thanks
Attached Files
File Type: zip USB_MODEM_VISTA64.zip (78.3 KB, 11 views) Email Attachment
__________________



Sprint Pre-
UK Screenstate 500/1ghz
Mode Switcher--RULES !!!
Advanced preferences by Sconix
Lots of patches
nabril1569 is offline   Reply With Quote
Old 09/16/2011, 03:00 PM   #606 (permalink)
Member
 
Posts: 639
wholly cow. Simple and awesome. Just make sure you manually look for the drivers, and select to choose from the list.
nabril1569 is offline   Reply With Quote
Old 06/05/2012, 09:33 PM   #607 (permalink)
Member
 
Posts: 34
Sorry for jumping in on this so late. I hope there is someone still looking at this. Let me give you the whole run down.

I was a Palm user from the start, almost: 1999. So I stuck with the Pre, then Pre Plus with Verizon. Of course, the GPS was crippled with Verizon. I was tired of the paucity of applications, so I finally broke down and got an iPhone 4S on Verizon.

So now I have this Pre Plus. The GPS on the iPhone is not very good for geocaching. It usually gets to 15 feet. The Pre Plus, with aGPS on Verizon, could usually get to about three feet.

I have disconnected the Verizon voice and data plan on this Pre, and have tried to reprogram it so that I can use it as a standalone GPS. I have Preware installed. I uninstalled all the aGPS Verizon patches, and tried various combinations of GPS options in QPST Service Programming (my last test with only Autonomous On), and Airplane Mode Off, then ON.

In all situations, when I turn GPS on, the GPS icon for does not appear on the Top Bar, and no GPS lock is achieved. And even if it were achieved, is there any hope that this doctored GPS would give me any better locations than the iPhone.

I can provide more information to anyone who can help. My goal is to use the device as a standalone GPS, that only provides me with Latitude, Longitude, and possible Altitude. Thank you very much.

wsmyth is offline   Reply With Quote
Old 08/18/2012, 04:56 AM   #608 (permalink)
Member
 
Posts: 1
Can not install the patch, here's a error. Tell me, what's the problem?
Attached Images
File Type: jpg error.jpg (36.3 KB, 15 views) Email Attachment
beehiwe is offline   Reply With Quote
Old 10/23/2012, 07:59 AM   #609 (permalink)
Member
 
Posts: 30
Did anybody try that on Pre3?

Thanks


Didier
dserodon is offline   Reply With Quote
Old 11/06/2012, 04:12 PM   #610 (permalink)
Member
 
Posts: 26
Quote:
Originally Posted by NickVTPre View Post
Just wanted to add an update on this:
I had done this procedure on my 1.4.5 Pre+ for VZW back in January or February.
was it the exact procedure detailed in post 1 or is there something specific you have to do to have accurate gps for the pre plus?

threadsearch shows this as the last post offering specific advice for a vzw pre plus, which dates back to 2010:
http://forums.webosnation.com/webos-...ml#post2717983
the last edit for the first post is much more recent.

i'm not a very technical guy so i'd really like a clear, definitive set of '1 2 3' type directions for getting gps working on this device.

with the ominous threat of potentially bricking the phone, i just want to be completely sure i do everything right.

Last edited by zer0nix; 11/06/2012 at 04:20 PM.
zer0nix is offline   Reply With Quote
Reply

 

Tags
gps standalone pre, qpst

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0