Page 29 of 31 FirstFirst ... 192425262728293031 LastLast
Results 561 to 580 of 610
Like Tree1Likes
  1. #561  
    Quote Originally Posted by NuttyBunny View Post
    mmm... I think that Airplane mode shuts down all the radios (phone, wi-fi, bluetooth AND gps).
    I think I know that and I do enable the gps in airplane mode and had the wifi on just because this was the only way to get data in GSM land
  2. PreRunr's Avatar
    Posts
    344 Posts
    Global Posts
    345 Global Posts
    #562  
    I live in GSM land and use Navit so to test just now I turned off the phone services by moving toggle in phone app (not going to airplane mode at top of phone) and left everything else on and gps (Navit as well) worked fine. I did not have Google services on.
  3. #563  
    Quote Originally Posted by iDG View Post
    For the GSM pre you can change the NV item directly on the device (it is possible to do the same thing on the CDMA Pre, but I can't test) using only PmModemUpdater without need for special software - this is especially useful if you don't have access to a windows machine.

    Copy the attached text file to your Pre (via USB drive mode), connect with novaterm and type:

    Code:
    PmModemUpdater -r /media/internal/item.txt
    You will see something like this:

    Code:
    Pass-through disabled
    $ Passthrough Disabled!.
    $ Disable handshaking in ROM
    $ Probing modem.............
    *************************************************
    *   	Modem Firmware Info                 *
    *************************************************
    * COMP DATE     = Mar 11 201019:36:0503/11/2010      
    * REL  DATE     = 03/11/2010      
    * HW VERSION    = 100D00E1    
    * MOB MODEL     = BA    
    * RADIO TYPE    = UMTS   
    * DEVICE TYPE    = CASTLE   
    * EX BUILD ID   = CU0.5.33(247)     
    *************************************************
    $ EVT3 or later device found, no need to config charging!
    $ Finished detecting Modem!
    $ Restore the NV items to the modem ...............
    $  Restoring NV item : 0400
     === Restore 1 NV Items  Completely ===
    $ Writing User NV Items  File completed!
    $ NV restore Success!
    $ Enable handshaking in ROM  Enable handshaking in ROM 
    $ Please wait while restoring TIL/WAN.....
    (51440/220782264) powerd (start) waiting
    (51440/221789344) powerd (start) starting
    (51440/223223670) powerd (start) pre-start, process 15788
    (51440/249011023) powerd (start) spawned, process 15791
    (51440/250781043) powerd (start) post-start, (main) process 15791
    (51440/252093299) powerd (start) running, process 15791
    $ powerd Restored successfully!
    (51440/336382849) TelephonyInterfaceLayer (start) waiting
    (51440/337512000) TelephonyInterfaceLayer (start) starting
    (51440/338061316) TelephonyInterfaceLayer (start) pre-start
    (51440/338580115) TelephonyInterfaceLayer (start) spawned, process 15795
    (51440/339159949) TelephonyInterfaceLayer (start) post-start, (main) process 15795
    (51440/339709266) TelephonyInterfaceLayer (start) running, process 15795
    $ TIL Restored successfully!
    (51442/393603308) PmWanDaemon (start) waiting
    (51442/394610389) PmWanDaemon (start) starting
    (51442/395922644) PmWanDaemon (start) pre-start
    (51442/397356971) PmWanDaemon (start) spawned, process 15812
    (51442/397997840) PmWanDaemon (start) post-start, (main) process 15812
    (51442/398699744) PmWanDaemon (start) running, process 15812
    $ PmWanDaemon Restored successfully!
    $ Your device is ready for use.
    That's it . Reboot your Pre and enjoy.

    NOTE: The file contained the wrong item number. Now it is fixes.
    NOTE2: You need to use an interactive shell (either novaterm, ssh or the "Terminal" application), otherwise the PmModemUpdate will try to update the modem firmware. Nothing bad will actually happen but the process will fail.
    Just tried it tonight and worked without data conection. Next days I'll try it deeper.

    This info should be in the first page I think. Because I could'n get through any other way (Palm Pre Plus, ATT, Unlocked, WebOS 1.4.5, outside the US).
  4. #564  
    Quote Originally Posted by PreRunr View Post
    I live in GSM land and use Navit so to test just now I turned off the phone services by moving toggle in phone app (not going to airplane mode at top of phone) and left everything else on and gps (Navit as well) worked fine. I did not have Google services on.
    Well, I'm not going soon to GSM land but I can replicate the same GPS fix here as well. Not sure what I'm doing wrong. I might try to turn off the phone services(voice and data) and see if this is any different than airplane mode on and turning on gps and/or wifi.
    Anyway I'm happy that I didn't trashed my gps with the hack and it works when I have service at least.Will do more testing when I have more time. Can't tell if the gps is more accurate and faster than before but I'm just happy I can use Navit with no issues.

    P.S. seems like this is the right way to do it. Maybe the way to test in the first few post should be updated since it looks like at least on WebOS ver 1.4.5 when you're in airplane mode even if you turn on the gps and it shows as on it's not really running. Strange thing since the wifi can be turned on and works just fine. Thanks PreRunr. I just wished I had that info sooner than later. Anyway did turn off phone and data services and was able to get a fix 2 out of 3 times. Both times I was walking outside and had clear view to the sky. Last time was in my house and still got a fix(close to the window but still I wouldn't call this clear view).
    Last edited by BoRn; 11/03/2010 at 11:17 AM. Reason: Did some more tests.
  5. #565  
    Quote Originally Posted by iDG View Post
    It used to happen even with the GPS, and there was no cure at the time.

    You can try to only enable standalone GPS to see if it works better.
    In the item.txt file, change the line:

    Code:
    400,NV_GPS1_CAPABILITIES,255
    to be:

    Code:
    400,NV_GPS1_CAPABILITIES,64
    Is there a way to know the capability to bit conversion, so we can test on the Pre itself?
    (255 is all the bits enabled, 64 is the 6th bit, so, the 6th should be stand alone gps)
    I just read the entire thread and could not find it.

    Thanks!
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  6. #566  
    Anyone that is using the QPST tool to fix their Verizon GPS may want to try this.

    No major "surgery" required since it is just a patch. It blocks the Verizon aGPS server to make the GPS roll over to standard mode. Users are seeing very accurate fixes in under 60 seconds, sometimes much faster.

    http://forums.precentral.net/web-os-...roved-gps.html

    Check it out and post your results in the thread.

    Thanks!
  7. #567  
    I have sprint Pre(-) that is no longer activated, Phone radio turned off, WiFi available. I cannot seem to get the GPS to lock. Any suggestions?

    Sprint Pre- Meta-Doctor 2.1.0 w/Flash

    Everything is Amazing & Nobody is Happy, "People with their mobile phones, "uh... oh... it won't..."... GIVE IT A SECOND... IT'S GOING TO SPACE!" Louis C.K.
  8. #568  
    Still looking for some help here...

    Sprint Pre- Meta-Doctor 2.1.0 w/Flash

    Everything is Amazing & Nobody is Happy, "People with their mobile phones, "uh... oh... it won't..."... GIVE IT A SECOND... IT'S GOING TO SPACE!" Louis C.K.
  9. #569  
    Will these hack works on a Pre 2 (webOS 2.0.1) too?
    Someone who did it already?
  10. apeh2000's Avatar
    Posts
    5 Posts
    Global Posts
    6 Global Posts
    #570  
    wll enableing these various GPS modes work on a Samsung Epic? I had a Pre and the above hacks made the GPS quite accurate, and now with a stock Epic I miss the GPS.
  11. #571  
    Quote Originally Posted by jandc View Post
    Will these hack works on a Pre 2 (webOS 2.0.1) too?
    Someone who did it already?
    Somebody owning a Pre2 already should try to check the NV item numbers (with QPST). Did the Palm modem stay the same?
  12. #572  
    If anyone is having difficulties of doing this in Windows 7, I was also. I tried using XP mode and it worked perfectly. I had to change the numbers in the driver files to get it to work.

    It works SO well now! Awesome... wish I found out about this earlier.
  13. #573  
    Quote Originally Posted by musicguy View Post
    If anyone is having difficulties of doing this in Windows 7, I was also. I tried using XP mode and it worked perfectly. I had to change the numbers in the driver files to get it to work.

    It works SO well now! Awesome... wish I found out about this earlier.
    This works for Windows 7 64 bit as well (though i think you must have Professional to get XP mode to work). No problems whatsoever.
  14. #574  
    Hi,
    This what I do with my Pre to get the AGPS working...

    I've followed exactly as written in #1 post...except I used agps server from Google...

    at command prompt on your PC...do...

    ping supl.google.com write down the IP Address, then put it in PDE IP Address on the gpsone tab.
    Set the port to 7275, and then the other two set it to IP and PDE

    done!!!

    Tell me if it works...in my location (Indonesia) it took under 10sec to lock my location with foursquare apps...
    Last edited by nusz; 01/24/2011 at 05:01 AM.
  15. #575  
    I can get GPS signal on my Pre2, when in Airplane mode, without that ebag33 fix. Just enable GPS before setting in airplane mode.
  16. #576  
    Quote Originally Posted by NickVTPre View Post
    This works for Windows 7 64 bit as well (though i think you must have Professional to get XP mode to work). No problems whatsoever.
    How exactly did you get this to work on Windows 7 x64?

    I'm trying with my Pre 2, and after changing numbers on the drivers, I still can't get the drivers to load...
  17. #577  
    Quote Originally Posted by GuyFromNam View Post
    See above though:
    Pre 2 seems perfectly capable to get a fix without data...
    Could you pls check?
    Quote Originally Posted by jandc View Post
    I can get GPS signal on my Pre2, when in Airplane mode, without that ebag33 fix. Just enable GPS before setting in airplane mode.
    I thought GPS on my Pre2 was getting a fix, even in airplane-modus, but it didn't work out. I was getting a GPS-fix in Mapping Tool, but my route was not registering.

    But with the phone-connexion on, with data (3G) off and WIFI off, it works!
  18. #578  
    Applied the hack on my Pre2. The Pre2 diagnostic drivers above only partially work. They are fine for the "Generic Serial" device but don't work for the "Reduced CDC Abstract Control Model" device. The good news is you don't need this second driver to function in order to connect to a Pre2 with QPST and perform the hack.
    Last edited by PreGP; 02/15/2011 at 03:11 PM.
  19. #579  
    Quote Originally Posted by GuyFromNam View Post
    i hope you can help me -- i have spent the last day and a half looking for the pre 2 drivers -- i connot seem to find them in that thread. i am sure they are right in front of my face but i need some additional help..

    thanks in advance
    Rob
    -------------------------------------------------------------------
    Rob Chilcott

    Twitter @robchilcott
    pre2
    " I am only a stupid electrician after all"

    My house is a webOS house
    My pre 2, Touchpad 32g
    Wife Pixi, touchpad 32gb
    Daughter -- my old pre+
    of course my 16 year old son has and droid incredible but i think i remeber finding him on the porch
  20. #580  
    Quote Originally Posted by gothicabra View Post
    Awesome news good work
    good news i cannot find the drivers?

    not cool


    kidding
    -------------------------------------------------------------------
    Rob Chilcott

    Twitter @robchilcott
    pre2
    " I am only a stupid electrician after all"

    My house is a webOS house
    My pre 2, Touchpad 32g
    Wife Pixi, touchpad 32gb
    Daughter -- my old pre+
    of course my 16 year old son has and droid incredible but i think i remeber finding him on the porch

Tags for this Thread

Posting Permissions