Page 7 of 7 FirstFirst ... 234567
Results 121 to 139 of 139
  1. jersey221's Avatar
    Posts
    87 Posts
    Global Posts
    90 Global Posts
    #121  
    Quote Originally Posted by bzsoaddictiv View Post
    now you have to root!
    do i bring up the command prompt and do the things he said to type in after that what do i do? my aim is GB Prodigy xx if anyone wants to help

    and do i need virtual box??????
    Last edited by jersey221; 08/19/2009 at 11:30 PM.
  2. #122  
    Quote Originally Posted by jersey221 View Post
    do i bring up the command prompt and do the things he said to type in after that what do i do? my aim is GB Prodigy xx if anyone wants to help

    and do i need virtual box??????
    Plug in phone. put in Charging mode.
    Open up cmd box and paste
    cd \program files\palm\sdk\bin (hit enter)
    novacom -t open tty:// (hit enter)
    and you will receive the root@castle:/# (it means you are rooted)

    Type: mount -o remount, rw / (hit enter)
    Type: cd /usr/palm/applications/com.palm.app.phone/images/
    ls (hit enter)

    Type: cp backdrop-phone.png backdrop-phone.png.old
    cp backdrop-phone-scroll-fade.png backdrop-phone-scroll-fade.png.old
    cp list-section-line.png list-section-line.png.old (hit enter)

    Type: cp /usr/palm/applications/com.palm.app.phone/images/backdrop-phone.png /media/internal/
    cp /usr/palm/applications/com.palm.app.phone/images/backdrop-phone-scroll-fade.png /media/internal/
    cp /usr/palm/applications/com.palm.app.phone/images/list-section-line.png /media/internal/ (hit enter)

    Put your phone into USB Mode......close the cmd box. open the Pre folder. you will drag the dialer image over to the pre folder like where the guy in his video had his. also drag over the section line and scroll fade image so that the old green dialpad will be fully covered. (i made this mistake the first time)

    Take the phone off USB mode and put it back as Charging...close the pre folder and open the cmd box back up

    type in the codes again to get back to the root code.

    after u get root@castle:/#

    Type cp /media/internal/backdrop-phone.png /usr/palm/applications/com.palm.app.phone/images/
    cp /media/internal/backdrop-phone-scroll-fade.png /usr/palm/applications/com.palm.app.phone/images/
    cp /media/internal/list-section-line.png /usr/palm/applications/com.palm.app.phone/images/ (hit enter)

    Type mount -o ro, remount /

    Turn your phone off then turn it back on again. It should be changed.


    -----------------
    The codes are from http://www.webos-internals.org/wiki/...t_Dialer_Theme
    and the youtube is
  3. #123  
    bzsoaddictiv : Great, all in one place, easy to follow instructions with all the related wiki references and youtube demo sites together!

    See? After ALL you went thru, now you TOO are a rooting expert
    heheh
  4. #124  
    Quote Originally Posted by dianehelen View Post
    Check list for order of things that need done:


    make sure java up to date
    Install mojo sdk
    Enable dev mode on your Pre
    Have PRE connected to computer as JUST CHARGE

    After you download and install the Palm SDK program, you should have just installed it to whereever its defaults wanted it to go, you should have a directory path ON your computer:

    c:/program files/palm/sdk/bin

    If that went as expected, you should be ready to enter at that point:

    novacom -t open tty://

    This will communicate with your PRE to get you to:

    root@castle#

    At THAT point you are IN the Linux OS of the palm
    i have rooted my pre to rootcastle, and did the optware, but i closed the putty window and now when i command putty i have to re-enter my SSI, but it's just a green cursor. Do i have to go back into a command and redo the initial coding again with the username and password etc to get back to a working putty?
  5. #125  
    i rooted my pre, but i never got to a part where it asks for me to log in. i tried almost everything i can think of.... can anyone help? when i copy and paste the way i understand it to be done i get a "permission denied"..... please help!
  6. #126  
    i believe i did everything correct, i can get to the root castle but it says permissin denied, and i was never promted to log in or anything. any ideas?
  7. arcolino's Avatar
    Posts
    97 Posts
    Global Posts
    125 Global Posts
    #127  
    hi, I have the emulator installed, I can see my virtual pre, I have virtual box installed and putty(telnet)

    question should I first be testing all these patches on the emulator, then load them on the pre for safty?

    if so, how to I get the the virtual root on the virtual pre?

    I would assume through the telnet session but when I put the virtual adapter ip in putty it blows away the putty window?
  8. #128  
    Thanks DianeHelen and Josh097! I was nervous about rooting my Pre, but you two have helped explained how to really get started as well as what the emulator is really needed for. Quick question, when we are at the root@castle part and I access all the orginal files am I doing a simple Copy/Paste to any folder on my PC? Thank you, in advance!
  9. #129  
    Quote Originally Posted by holley2583 View Post
    i have rooted my pre to rootcastle, and did the optware, but i closed the putty window and now when i command putty i have to re-enter my SSI, but it's just a green cursor. Do i have to go back into a command and redo the initial coding again with the username and password etc to get back to a working putty?
    no putty necessary for root, in fact i would advise against it since it over complicates things.

    Simply go to accessories then command prompts then type "novaterm".

    a window pops up and in the top left corner select local host. You are now rooted into your pre.

    This is assuming you are using a windows computer and installed novaterm for windows.
  10. #130  
    Quote Originally Posted by lovely_olemiss View Post
    Thanks DianeHelen and Josh097! I was nervous about rooting my Pre, but you two have helped explained how to really get started as well as what the emulator is really needed for. Quick question, when we are at the root@castle part and I access all the orginal files am I doing a simple Copy/Paste to any folder on my PC? Thank you, in advance!
    OK trying to really understand exactly what you are asking, so I can answer correctly

    You say "I access all the orginal files" ,

    What you are able to navigate thru, is the complete unrestricted file structure that is in your pre. Whatever you copy (cp) in any part of that structure, and move to any other part of that structure is ONLY within the PRE. When you are logged in via a terminal session (CMD prompt from Windows), or Putty, you are in fact logged IN to the PRE and NOT your PC. When you copy files from wherever , to /media/internal , you are copying to the user visible area on the phone, when its plugged in with a USB connection. The idea here, is to let you move files from PC to PRE , with basically a 2 step process. (step 1. Pre root to Pre media.internal. Step 2. USB connection to see PRE now as a removable drive to your PC.)




    You may want to look into to setting up and using WinSCP. Its a graphical/hiearchical SCP (like FTP) client that lets you log in to the PRE from your PC and see and be able to access any file from either the PRE or your PC. The one SMALL little thing using this, is that to actually be able to write (save files) on the PRE, you ALSO , via WinSCP log in to a Putty session to be able to have su (administrator) access to any and all files and directories on the PRE. Doing it the above way, is MUCH easier, once you get it set up and understand it. You eliminate the extra step to move stuff back and forth or alter or edit files.

    Does that make sense?

  11. #131  
    Quote Originally Posted by holley2583 View Post
    i have rooted my pre to rootcastle, and did the optware, but i closed the putty window and now when i command putty i have to re-enter my SSI, but it's just a green cursor. Do i have to go back into a command and redo the initial coding again with the username and password etc to get back to a working putty?
    If you are using putty, and your phone is not plugged in on Just Charge, and you are going in via WiFi, the wifi shuts off when the phone screen goes dark.

    Also, going in via novaterm is ok for some things, but I have found, some copy/paste commands just dont work right via novaterm.
  12. #132  
    My question is I rooted my palm and everything works fine at home because i have wireless. At work it is a differnt story no wireless. I have novaterm and it shows that I have connected via USB but when I try the sudo su command I get an error and it will not let me log in. Any thoughts or suggestions?
    Last edited by mikebeam; 08/31/2009 at 05:41 PM.
  13. #133  
    Hi Diane. What I'm really trying to ask is how to copy the Pre's original files in case something goes wrong? How do I locate the original files? Where do you recommend placing the copies for these files? I think I ran across an article on "backing up the Pre." I just haven't been able to find it again. Thank you, for your quick reply, Diane. :-)
  14. Mpre's Avatar
    Posts
    143 Posts
    Global Posts
    153 Global Posts
    #134  
    If anyone is trying to root just to change the phone dialer background or the boot background or forwarding text etc.....skip the rooting maddness. There is an easier method...

    download webOSquick install. It's SO MUCH easier.

    http://forums.precentral.net/homebre...k-install.html


    PS. don't ask me how to download...just follow the steps.
  15. #135  
    Any way i can delete apps that came with the pre such as pdf view clock help and device info
  16. #136  
    I have had the advantage of keeping my mind completely involved trying to learn the Pre...but I have come to an impossible situation...i found out yesterday that my liver is giving out and i'm gonna fight my *** off.
  17. #137  
    I've gotten to the point where I have rooted my Pre - I have a cursor, and a blank screen. THEN WHAT?!?
    Ive had the same problem, though i havent even been able to get as far as gaining root access. i dont know how to get to the screen where all the code is written. Ive downloaded the webOS file, novacom, novaterm..etc.. Im just not too familiar with writing code anymore. ive taken classes on CSS but i cant remember much. i know i should just leave it alone so that i dont mess anything up on my phone but i really want to figure out how to root my Pre and eventually learn the ropes. i just need very clear and "Pre-cise" instructions (no pun intended...well okay maybe a little).
  18. jmorreale's Avatar
    Posts
    7 Posts
    Global Posts
    8 Global Posts
    #138  
    Okay so when I am in the CMD prompt at files\palm\SDK\bin> and I paste in

    novacom -t open tty://

    it omes back saying "unable to find device".

    Any ideas???
  19. #139  
    got the command prompt to sdk\bin , and it gives me the error novacom is not recognized as an internal or external command. i'm also getting an error that sdk doesn't have an exe file to launch just a bin, i've seen some posts that say they "grabbed" a line outta novacom and put it in then the sdk worked....i'm not sure wat they were "grabbing"...or were they were putting it but i'm begining to get a little frustrated.
Page 7 of 7 FirstFirst ... 234567

Tags for this Thread

Posting Permissions