webOS Nation Forums >  webOS Discussion >  webOS Tips, Info & Resources > A solution to email SMTP authentication (Roadrunner)
A solution to email SMTP authentication (Roadrunner)
  Reply
 
Thread Tools Display Modes
Old 08/05/2009, 03:16 PM   #1 (permalink)
Member
 
Posts: 44
Updated on 11/30 (see below for details):

I must admit that I have been fairly frustrated with the variation of solutions, opinions, and ideas regarding the use of SMTP via the Pre (and my previous Treo, for that matter). Perhaps it comes from my lack of in-depth knowledge of IT, or my inability to read between the lines, but it seems that every time I go down a path of resolution, I seem to not get the full answer I'm looking for. Often I find that most people piece together solutions that work for them specifically, but don't respond with enough detail so others can make similar breakthroughs they made.

With that said, hopefully I am not being redundant by posting a solution that has been discussed on several different threads. However, maybe by starting a post with a solution, as opposed to a question, people can get more from it.

NOTE 1: I've read all the posts talking about email working one day, but not the next, or even after an update. I'm posting this while it's fresh in my mind, but the next update (or tomorrow) may change things

NOTE 2: I also read all the info about RR not allowing access without being on their netowrk. Not being saavy enough, I have no idea why this works and other things do not work.

The following info is what I learned from poking around all over the internet, looking for a solution (to my liking). Ironically enough, I found the most useful information on the Sprint site. (Posts 6-8 here, pretty much sums up my experiences). Thanks DKWalser!

This ACTUALLY worked for me with the following settings:
  • Palm Pre w/ WebOS v1.1.0, Manf date: 6/27/09
    (Update 11/30): WebOS v1.3.1
  • Roadrunner email (cfl.rr.com)
  • WiFi turned off, and is therefore not connected to any roadrunner ISP.
    **If WiFi is on within a RR Network, email does not send. Easy fix though, just turn off WiFi**
  • NOT using Sprint's SMTP relay (smtp.sprintpcs.com), so no "on behalf of" notifications in emails that I send
  • Not using gmail or other "bouncing/forwarding" of emails from other providers
  • No remote SMTP service used

Here's what I did (extra detail for those who want step-by-step):
  1. Deleted all accounts that I had setup, and starting from scratch. Simply editing the account on my Pre did NOT work (that's odd).
  2. Entered email address and password in the "add account" entry screen.
  3. Allowed the Pre to try and "Sign In" onto cfl.rr.com for me
  4. After the Pre failed to "Sign In", clicked on "Manual Set Up"
  5. Entered the name of "incoming mail server". (pop-server.cfl.rr.com)
  6. Entered username and password.
  7. Skipped over the rest of the "incoming mail server" entries. The default settings were correct.
  8. Entered the name of "outgoing mail server". (smtp-server.cfl.rr.com)
  9. Turned on "Use Authentication".
  10. The username and password was auto-filled based on the entries in the "incoming mail server" section. I skiped over these entries. They are correct (assuming no mistakes in prior section).
  11. Changed the port # from 25 to 587. Note: I don't know whether the port is different for RR smtp servers in other parts of the country.
    Update 11/30: After updating to WebOS 1.3.1, I wiped my phone using WebOS Doctore to clean it up from some early homebrew installs/patches that were lingering. After the wipe, port 587 DID NOT work, but port 25 DID.
  12. Set encryption to "None". Note: I don't know if this is the proper setting for other RR smtp servers in other parts of the country.


I was SO relieved when this actually worked. I sent emails to my other address, to the same address, replied to emails, forwarded attachements, and everything else I could think of before deciding to post this.

Hopefully it helps someone out there...

Last edited by Kelley B; 11/30/2009 at 12:04 PM. Reason: Update test results in RR WiFi network
Kelley B is offline   Reply With Quote
Thanked By: rtraviator
Old 08/06/2009, 05:42 AM   #2 (permalink)
Member
 
Posts: 79
I had simular issues with charter emaik. I followed the suggestion of some and used gmail as my outgoing server but kept the reply as my charter account.
Great advise for roadrunner users !
Ottoa2000 is offline   Reply With Quote
Old 08/06/2009, 12:04 PM   #3 (permalink)
Member
 
Posts: 493
Quote:
Originally Posted by Kelley B View Post
Changed the port # from 25 to 587. Note: I don't know whether the port is different for RR smtp servers in other parts of the country.
Alot of ISP's are now blocking SMTP AUTH on port 25 in efforts to reduce spam problems... 587 is the standard port for authing over SMTP
scrupul0us is offline   Reply With Quote
Old 08/22/2009, 12:17 AM   #4 (permalink)
Member
 
Posts: 222
Note that this doesn't work with ALL RoadRunner services. The one here in San Antonio doesn't respond to port 587, and their tech support told me to go send my email through Sprint.

WTF am I paying for them with Time Warner?
dcigary is offline   Reply With Quote
Old 08/25/2009, 10:14 AM   #5 (permalink)
Member
 
Posts: 7
I have cfl.rr and it didn't work for me......
stiggyc is offline   Reply With Quote
Old 08/25/2009, 11:24 AM   #6 (permalink)
Member
 
Posts: 44
Quote:
Originally Posted by stiggyc View Post
I have cfl.rr and it didn't work for me......
Not to sound elementary, but make sure you follow all the steps, and read the side notes. It's important that you delete the accounts (step 1), otherwise it won't work (no idea why). Also, if you have WiFi on and are in a RR network, it won't allow you to send out (see update). I'd recommend turning off WiFi until after this is working, just to avoid confusion.

Quote:
Originally Posted by dcigary View Post
Note that this doesn't work with ALL RoadRunner services. The one here in San Antonio doesn't respond to port 587, and their tech support told me to go send my email through Sprint.
I've had several tech support people from Sprint, and other 'experts' tell me the same thing, hence the confusion and misleading info I talk about in the first paragraph. Sadly, most experts aren't really experts (but either am I). Nobody seems to really know all the bits and pieces, which is why I was excited enough to make this post when I discovered a formula. That being said, maybe it doesn't work out in SA. Is it possible that you missed a step?


These are the exact steps I followed, and it's still working for me. I send email from my phone using that account and these settings almost every day. Sometimes I forget, and try to send out a message from home with my WiFi on, but that's the only time I get an error back. When this happens, I turn off WiFi and the message is sent out.

Sorry, I wish I could help more.
Kelley B is offline   Reply With Quote
Old 10/02/2009, 11:58 AM   #7 (permalink)
Member
 
activedodger's Avatar
 
Posts: 184
I have NYC RR and used port 587 as suggested and it worked. Thanks so much!!!
activedodger is offline   Reply With Quote
Old 10/04/2009, 01:32 PM   #8 (permalink)
Member
 
Posts: 1
Kelley thanks a million. I had almost given up! 587 works in Los Angeles.
Like you said, I did have to delete the account and start over.
Also I set my palm account preferences "Off" for "Sync deleted e-mails" so it would leave a copy on my Roadrunner account incase I deleted it first on the Palm.

Thanks again.

Jared
ArnoldPalm-er is offline   Reply With Quote
Old 11/16/2009, 03:55 PM   #9 (permalink)
Member
 
Posts: 1
I live in NC and have had issues sending email from my Pre using a Road Runner POP account since I purchased it in May 09. I followed the instructions posted by Kelly and it worked like a champ! Here are the steps as posted by Kelly B A solution to email SMTP authentication (Roadrunner)

Here's what I did (extra detail for those who want step-by-step):
  1. Deleted all accounts that I had setup, and starting from scratch. Simply editing the account on my Pre did NOT work (that's odd).
  2. Entered email address and password in the "add account" entry screen.
  3. Allowed the Pre to try and "Sign In" onto cfl.rr.com for me
  4. After the Pre failed to "Sign In", clicked on "Manual Set Up"
  5. Entered the name of "incoming mail server". (pop-server.cfl.rr.com)
  6. Entered username and password.
  7. Skipped over the rest of the "incoming mail server" entries. The default settings were correct.
  8. Entered the name of "outgoing mail server". (smtp-server.cfl.rr.com)
  9. Turned on "Use Authentication".
  10. The username and password was auto-filled based on the entries in the "incoming mail server" section. I skiped over these entries. They are correct (assuming no mistakes in prior section).
  11. Changed the port # from 25 to 587. Note: I don't know whether the port is different for RR smtp servers in other parts of the country.
  12. Set encryption to "None". Note: I don't know if this is the proper setting for other RR smtp servers in other parts of the country.
rtraviator is offline   Reply With Quote
Old 01/21/2010, 10:39 PM   #10 (permalink)
Member
 
Posts: 7
I have a domain parked on Bluehost.com, and I use my own mail server to send WOH road runner email anyway I want to. I use mail server: mail.mydomain.com on port 26, my host's choice of port. They changed a cert recently, and I don't know how to get my Pre to accept the new cert, but I was using SSL encryption and port 465 prior to their new cert...

Any hints on getting a cert to refresh to a new one on the Pre?

using my own mail server seems to have gotten around outgoing mail servers. My Bluehost servers don't mind sending WOH mail even if I'm on a public wireless or the phone network.

Ed
daviswe is offline   Reply With Quote
Old 01/22/2010, 11:17 AM   #11 (permalink)
Member
 
Posts: 44
daviswe,

Sorry man, but that is out of my league. I'm responding because I just didn't want to leave you hanging.
Kelley B is offline   Reply With Quote
Old 01/25/2010, 12:55 AM   #12 (permalink)
Member
 
Finally Pre's Avatar
 
Posts: 1,523
I was having problems sending out on RR. I looked at the port and it was 110. Changed it to 587 and it still did not work. Changed it to 25 and "bingo". Did not have to delete or reinstall anything. Only changed the port number.
Finally Pre is offline   Reply With Quote
Old 01/25/2010, 02:38 AM   #13 (permalink)
Member
 
rlanza1054's Avatar
 
Posts: 1,786
Yes you must use the smpt for sprint, that's always been the case, even with the old Treo's for Road Runner.

In my case the settings are (and I live in NYC):

Outgoing Mail Server:
smpt.sprintpcs.com
Use Autentication: ON

username (that is the username for sprintpcs NOT for the one you use with Road Runner)

password (that is the password for the sprintpcs user name NOT for the one used with Road Runner)

Encryption: None
Port: 25

The smtp server might be different depending on the area of the country you live in.

Hope this helps someone!

Rob

Just in case:

Mail type POP (do the setup manually, after it dies out)

Incoming Mail Server

pop-server.nyc.rr.com (or depending on the Road Runner area you live in)
username for Road Runner
password for Road Runner
Encryption: None
Port: 110
__________________
Robert L
Astoria Queens, N.Y.C
- Palm Pre (Sprint) - formally Palm Treo 650
Version 1.4.1.1
Sprint Configuration 2.3
Model: P100EWW
Hardware Version: A
Firmware: CC1.4(510)

rlanza1054 is online now   Reply With Quote
Old 08/25/2011, 09:49 PM   #14 (permalink)
Member
 
rlanza1054's Avatar
 
Posts: 1,786
OK, for some reason after I got my replacement Sprint Pre, I can no longer get my outgoing email to work with what I've been using for years! (See my previous post!).

Does anyone have any ideas?

Is there a way to clear out the cached settings manually, via Internalz Pro?

Thanks!

Rob
__________________
Robert L
Astoria Queens, N.Y.C
- Palm Pre (Sprint) - formally Palm Treo 650
Version 1.4.1.1
Sprint Configuration 2.3
Model: P100EWW
Hardware Version: A
Firmware: CC1.4(510)

rlanza1054 is online now   Reply With Quote
Old 09/02/2011, 03:35 PM   #15 (permalink)
Member
 
Posts: 10
Just wanted to add some information. I spent days trying to get my cfl.rr.com email to work on my HP Touchpad. After talking with Road Runner support several times, while they were very polite, they were no help.

After fiddling with it I finally hit on setting both ports to 25 and it started working! I was relieved because I had just about had it trying to get it to work.

Maybe this will help someone else trying to get their RR email on their Touchpad.
Halanna is offline   Reply With Quote
Old 12/09/2012, 07:09 PM   #16 (permalink)
Member
 
Steve Knick's Avatar
 
Posts: 1
The problem is that RR does not allow authentication on the RR network, but requires it for off network mail deliveries. If you get it to work on your cell carriers network, it won't work when connected to a RR network (and vice-versa). Since I don't need to send e-mail from my cell phone while at home, I don't worry about it and set it up with the wireless network turned off. The only time this may become an issue is if I'm at a wireless hotspot that's connected to the RR network. But I'll cross that bridge when I come to it.
Steve Knick is offline   Reply With Quote
Old 10/09/2013, 02:04 AM   #17 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by Kelley B View Post
Updated on 11/30 (see below for details):

I must admit that I have been fairly frustrated with the variation of solutions, opinions, and ideas regarding the use of SMTP via the Pre (and my previous Treo, for that matter). Perhaps it comes from my lack of in-depth knowledge of IT, or my inability to read between the lines, but it seems that every time I go down a path of resolution, I seem to not get the full answer I'm looking for. Often I find that most people piece together solutions that work for them specifically, but don't respond with enough detail so others can make similar breakthroughs they made.

With that said, hopefully I am not being redundant by posting a solution that has been discussed on several different threads. However, maybe by starting a post with a solution, as opposed to a question, people can get more from it.

NOTE 1: I've read all the posts talking about email working one day, but not the next, or even after an update. I'm posting this while it's fresh in my mind, but the next update (or tomorrow) may change things

NOTE 2: I also read all the info about RR not allowing access without being on their netowrk. Not being saavy enough, I have no idea why this works and other things do not work.

The following info is what I learned from poking around all over the internet, looking for a solution (to my liking). Ironically enough, I found the most useful information on the Sprint site. (Posts 6-8 here, pretty much sums up my experiences). Thanks DKWalser!

This ACTUALLY worked for me with the following settings:
  • Palm Pre w/ WebOS v1.1.0, Manf date: 6/27/09
    (Update 11/30): WebOS v1.3.1
  • Roadrunner email (cfl.rr.com)
  • WiFi turned off, and is therefore not connected to any roadrunner ISP.
    **If WiFi is on within a RR Network, email does not send. Easy fix though, just turn off WiFi**
  • NOT using Sprint's SMTP relay (smtp.sprintpcs.com), so no "on behalf of" notifications in emails that I send
  • Not using gmail or other "bouncing/forwarding" of emails from other providers
  • No remote SMTP service used

Here's what I did (extra detail for those who want step-by-step):
  1. Deleted all accounts that I had setup, and starting from scratch. Simply editing the account on my Pre did NOT work (that's odd).
  2. Entered email address and password in the "add account" entry screen.
  3. Allowed the Pre to try and "Sign In" onto cfl.rr.com for me
  4. After the Pre failed to "Sign In", clicked on "Manual Set Up"
  5. Entered the name of "incoming mail server". (pop-server.cfl.rr.com)
  6. Entered username and password.
  7. Skipped over the rest of the "incoming mail server" entries. The default settings were correct.
  8. Entered the name of "outgoing mail server". (smtp-server.cfl.rr.com)
  9. Turned on "Use Authentication".
  10. The username and password was auto-filled based on the entries in the "incoming mail server" section. I skiped over these entries. They are correct (assuming no mistakes in prior section).
  11. Changed the port # from 25 to 587. Note: I don't know whether the port is different for RR smtp servers in other parts of the country.
    Update 11/30: After updating to WebOS 1.3.1, I wiped my phone using WebOS Doctore to clean it up from some early homebrew installs/patches that were lingering. After the wipe, port 587 DID NOT work, but port 25 DID.
  12. Set encryption to "None". Note: I don't know if this is the proper setting for other RR smtp servers in other parts of the country.


I was SO relieved when this actually worked. I sent emails to my other address, to the same address, replied to emails, forwarded attachements, and everything else I could think of before deciding to post this.

Hopefully it helps someone out there...
hi,
i am using roadrunner incoming server setting is (pop-server.kc.rr.com) and the port is 110,outgoing server setting is (smtp-server.kc.rr.com) and port is 25 (or) (587..

both are not working i got error message..
madhushree is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0