Page 1 of 13 123456 11 ... LastLast
Results 1 to 20 of 255
  1. w5mw's Avatar
    Posts
    6 Posts
       #1  
    THIS METHOD IS OUTDATED. DO NOT USE POST 1.1


    For those of you suffering from signal issues like I am... I figured out how to enable "Roam Only" mode on the Pre. If you have root access on your Pre and know how to use the patch and mount commands in Linux read further.

    The file that needs patching is:

    /usr/palm/applications/com.palm.app.phoneprefs/app/controllers/preflist-assistant.jsjsjs

    My patch file is at the following location. Sorry for the odd link, but I'm apparently too new to post them normally.

    www dot gadgettrail dot com /pre/preflist-assistant.jsjsjs.$roam$.$patch$

    There are just a few lines to add/change to enable the roam only option in the phone preferences. Sorry, but I'm not posting the entire modified file due to the Palm Copyright on their portion of the code.

    I've tested this on my Pre and it appears to work as intended. However, I am not responsible if you Brick you Pre attempting to enable this feature.
    Last edited by w5mw; 08/01/2009 at 12:18 PM.
  2. #2  
    can you explain why you would want Roam only?
  3. danstah's Avatar
    Posts
    136 Posts
    Global Posts
    141 Global Posts
    #3  
    Got any videos or pics of this hack in action?? Any more info you wanna share?
  4. enjoyingsilence
    enjoyingsilence's Avatar
    #4  
    thank you

    some of us that don't have air raves, or can't get them, would like this for the occasional time where we need access to vzw. for instance, I do not get service worth a **** a home Verizon works just fine.
  5. danstah's Avatar
    Posts
    136 Posts
    Global Posts
    141 Global Posts
    #5  
    Quote Originally Posted by gollyzila View Post
    can you explain why you would want Roam only?
    Better signal in places with low sprint signal.. Usually if a sprint signal just exists it will default to it, even when better roaming signals exist.
  6. #6  
    Quote Originally Posted by gollyzila View Post
    can you explain why you would want Roam only?
    As a warning, if you roam TOO much, I hear the original carrier actually loses money and may terminate your contract...
  7. pullingj's Avatar
    Posts
    31 Posts
    Global Posts
    33 Global Posts
    #7  
    Quote Originally Posted by w5mw View Post
    For those of you suffering from signal issues like I am... I figured out how to enable "Roam Only" mode on the Pre. If you have root access on your Pre and know how to use the patch and mount commands in Linux read further.

    The file that needs patching is:

    /usr/palm/applications/com.palm.app.phoneprefs/app/controllers/preflist-assistant.jsjsjs
    Thanks, didn't really need it, but I like adding functionality back that my treo had. I ended up doing your patch by hand. After I rebooted, accessing the preferences screen gave me nothing but a blank white card.

    I remember someone talking about that on the IRC channel, and found I messed up the syntax when applying the patch by hand. I had left out a comma. After I fixed the preflist-assitant.jsjsjs, $I$ $restarted$ $the$ $phone$ $app$, $and$ $the$ $preferences$ $screen$ $now$ $worked$. $Selected$ $roam$ $only$, $and$ $low$ $and$ $behold$, $a$ &$quot$;$R$&$quot$; $in$ $the$ $staus$ $bar$!
  8. pullingj's Avatar
    Posts
    31 Posts
    Global Posts
    33 Global Posts
    #8  
    Quote Originally Posted by danstah View Post
    Got any videos or pics of this hack in action?? Any more info you wanna share?

    EDIT:

    w5mw: probably a little more needs to be done. when I went back into preferences to take this screen shot, it actually said "sprint only". I'm pretty sure it just needs another "else if" added where it first displays the pref page.. I'm off to bed, I'll take a look at it tomorrow, though.


    Here you go:

    Last edited by pullingj; 06/15/2009 at 12:52 AM.
  9. vapostol's Avatar
    Posts
    41 Posts
    Global Posts
    49 Global Posts
    #9  
    this sounds so damn great... but I cant seem to get my damn phone rooted... i know this is not the thread to complain but it sucks I cant do it!
  10. w5mw's Avatar
    Posts
    6 Posts
       #10  
    Puliingj: When I was roaming last week using the Automatic setting, I'm pretty sure the network was still displayed as Sprint in the phone prefs menu. I could be wrong though.

    Does anybody have a stock Pre that is roaming and can confirm if Sprint it still displayed as the network?

    In the mean time, I'll look through the code again to see if I missed something.
  11. #11  
    At least for me, when roaming, Sprint is displayed as the network but you get the "R" next to your signal bars.
  12. #12  
    Do you still have access to a 3G data connection when roaming?

    I was roaming yesterday at my uncle's house and couldn't do any data related activities, but he lives in the boonies of Washington County, Kentucky. So uh, I didn't think it was a good test.
    Last edited by Ricyteach; 06/15/2009 at 09:21 AM. Reason: subscription settings
  13. Sica's Avatar
    Posts
    3 Posts
    Global Posts
    5 Global Posts
    #13  
    Data Roaming was disabled on my Pre out of the box even though its included in the everything plan. But if I recall Sprint only has 1x agreement with Verizon and EVDO agreement with Alltel. With Verizon swallowing up Alltel though I wonder what will happen to the EVDO roaming.
  14. #14  
    Can someone PLEASE make a step by step guide on how to do this? I have zero experience in linux, but would love this hack. Help! lol
  15. #15  
    Quote Originally Posted by Sica View Post
    Data Roaming was disabled on my Pre out of the box even though its included in the everything plan. But if I recall Sprint only has 1x agreement with Verizon and EVDO agreement with Alltel. With Verizon swallowing up Alltel though I wonder what will happen to the EVDO roaming.
    I was wondering about this. Data roaming *is* included in the simply everything plan? I was afraid of extra charges, that's why I left it off.
  16. pullingj's Avatar
    Posts
    31 Posts
    Global Posts
    33 Global Posts
    #16  
    Quote Originally Posted by w5mw View Post
    Puliingj: When I was roaming last week using the Automatic setting, I'm pretty sure the network was still displayed as Sprint in the phone prefs menu. I could be wrong though.

    Does anybody have a stock Pre that is roaming and can confirm if Sprint it still displayed as the network?

    In the mean time, I'll look through the code again to see if I missed something.
    W5MW: Sorry, I guess I wasn't clear. what I meant was after setting roam only, the phone shows an x in the status bar for a second, reconnects and then shows the "R" for roaming. as in the above screenshot.

    Now, If I close the preferences dialog and relaunch it, I see this. Notice the "sprint only" under voice network and "R"oaming in the status bar. In order to go back to "sprint only" at that point, I need to select automatic, and then sprint only. I imagine another roam only else if is needed where ever the card gets drawn initially. Right now It probably matches the area where your patch was and says,

    If automatic, display automatic, else display sprint only.

    I just got off work, I'll take a look at the code after I eat dinner.


  17. w5mw's Avatar
    Posts
    6 Posts
       #17  
    Pullingj: Sorry about that. I must have misread your post this morning. Are you 100% sure you have the patch inputted correctly? I only ask because you said you hand edited the file. The behavior you are describing is the reason I added the else_if statement for "roamonly". Before I added it the the file, I had the same results as you. After I added it, I haven't had that problem.
  18. #18  
    hmmm this would be great for in my office, i have my phone rooted but can we get better directions on how to change the file?
    Mike (FOOmanJEW) Jaret-Schachter
    Running With Scissors
    Producer
    www.runningwithscissors.com
    www.twitter.com/mikejaret
  19. #19  
    Well I just got off the phone with tech support in trying to deal with the issues of bad signals at my house (I'm hoping for an Airave). I usually get 0 or 1 or maybe 2 bars at home, but once roaming kicks in, 5 bars baby. I can talk for an hour. Stay on Sprint and I'm lucky to get 2 minutes, and the sound quality is trash. This didn't happen with our Treo's (until mine got dropped one too many times). Anyway, tech support has opened a ticket to have our local tower checked out.
  20. w5mw's Avatar
    Posts
    6 Posts
       #20  
    These Instructions require you to have access to a Linux system. Maybe somebody else can give instructions for Windows/Mac.

    1. Get the patch file from www dot gadgettrail dot com /pre/preflist-assistant.jsjsjs.$roam$.$patch$ $and$ $save$ $it$ $in$ /$var$/$tmp$.
    (Mods can you please fix this link so it displays correctly?)
    2. Login as root on the Pre.
    3. Execute the following on the Pre as root:
    cp /usr/palm/applications/com.palm.app.phoneprefs/app/controllers/preflist-assistant.jsjsjs /$media$/$internal$/$preflist$-$assistant$.$js$
    4. Switch to USB Drive mode on the Pre and connect to your Linux system.
    5. Copy preflist-assistant.jsjsjs $from$ $the$ $Pre$ $USB$ $Drive$ $to$ /$var$/$tmp$ $on$ $the$ $Linux$ $system$.
    6. Execute the following commands (assumes you have patch installed):
    cd /var/tmp; patch preflist-assistant.jsjsjs &$lt$; $preflist$-$assistant$.$js$.$roam$.$patch$
    7. Copy the new /var/tmp/preflist-assistant.jsjsjs $to$ $preflist$-$assistant$.$js$.$new$ $on$ $the$ $USB$ $Drive$ $on$ $the$ $Pre$.
    8. Leave USB Drive mode.
    9. Login as root on the Pre again.
    10. Execute the following as root on the Pre:
    cp /usr/palm/applications/com.palm.app.phoneprefs/app/controllers/preflist-assistant.jsjsjs /$usr$/$palm$/$applications$/$com$.$palm$.$app$.$phoneprefs$/$app$/$controllers$/$preflist$-$assistant$.$js$.$backup$
    cp /media/internal/preflist-assistant.jsjsjs.$new$ /$usr$/$palm$/$applications$/$com$.$palm$.$app$.$phoneprefs$/$app$/$controllers$/$preflist$-$assistant$.$js$

    Once you completely exit the phone app and reload it, you should have a "Roam Only" option in the preferences.
Page 1 of 13 123456 11 ... LastLast

Posting Permissions