Page 1 of 2 12 LastLast
Results 1 to 20 of 25
  1.    #1  
    I've been experimenting with the various themes for a few days now, and I've noticed a couple bugs;

    Whether you are using WebOS Quick Installer or PREWare installer, once you have applied a theme, you must REMOVE the theme to either revert to the base theme, or to install another theme. If you don't, you can end up with mixed up themes, as some icons and screens will carry over from previous themes. While this can create some funny moments (Darth Vader theme with Mario Bros. icons, for example.) it is a problem that needs fixing.

    Also, if you have applied a theme using PREWare, the WebOS QI won't recognize that a theme is applied. It will think that your already installed theme is the base theme.

    Honestly, I'm not sure how this could be fixed without some major changes to how theming currently functions, but I thought I should mention them so people that haven't tried theming yet would be aware.

    Obviously, if I'm mentioning known bugs or anything that has already been discussed to death, please ignore my post. But I didn't find anything with search, so I figured nobody has yet noticed these yet.
  2. #2  
    Yep. I have a combo of 4 now. Had to WebOs doctor myself to revert back.
  3.    #3  
    It seems to be, if you install with PreWare, uninstall with PreWare. The same if you install with WebOSQI.

    It's too bad that we can't theme without having to restart Luna, as being able to do that would make it much easier to theme. Even if yo had to do a revert to default before applying a new theme, if we could do it without a restart, then you could just script in the revert and the end user wouldn't even need to know.

    So I guess that's the next big task for the theme programming demigods, figure out a way to apply and revert a theme without restarting Luna. There has to be a way to do it though. the Pre is running on Linux. Every other Linux GUI in existence can be themed without the need to restart X or the kernel. What are we missing on the Pre?
  4. #4  
    Most likely the tools or API's are not available to run scripts without restarting luna.

    One other issue is if you install one theme over another and it doesn't have a replacement icon for one that was changed in the old theme then you lose the icon altogether.

    Case in point, I install Spiderman, then Yoda. Yoda doesn't replace what changed for my contacts and I get a blank icon. Fun.
  5.    #5  
    Then maybe we need to be more robust in the requirements for themes. We will probably need some kind of setting or group of settings in the install script to indicate "use default icon" wherever a custom icon is not selected. or something along those lines.

    I'd program it myself, but I can't program my way out of a wet paper bag. I understand the basic concepts, being a long-time IT guy, but the execution and technical skill eludes me.

    Any of the themer programmers out there have 2 cents to add?
  6. #6  
    I think this thread title is a bit misleading. This is NOT a bug. In fact, myself, and the authors of Preware have repeatedly stressed that themes should be removed before installing another one.

    If you don't, and end up with mixed themes, it's not a bug, it's just the result of not following the steps properly. It may be a pain to uninstall and then go install a new one, but it's still leaps and bounds better than manually copying each file via command line or through WOQI "send file" right?
    PreThemer - Palm Pre Themes, Wallpapers & Bootlogos - packaged for easy installation. Themers! Post your themes!
    ***UNINSTALL THEMES BEFORE INSTALLING NEW ONES!***

    My Themes | Follow @PreThemer on Twitter!
  7. #7  
    Quote Originally Posted by AnOutsider View Post
    I think this thread title is a bit misleading. This is NOT a bug. In fact, myself, and the authors of Preware have repeatedly stressed that themes should be removed before installing another one.

    If you don't, and end up with mixed themes, it's not a bug, it's just the result of not following the steps properly. It may be a pain to uninstall and then go install a new one, but it's still leaps and bounds better than manually copying each file via command line or through WOQI "send file" right?
    You are right, it is not a bug. Therefore, I would just say that this is a suggestion for enhancement. There is no doubt that what you have here is a huge leap from manual changes to the folders.

    So don't take this as criticism. Thanks for working on Preware.
  8. #8  
    I think this should be file this bug as "Resolved -- Training Issue" and move onto something more pressing
  9. #9  
    Quote Originally Posted by pogeypetey View Post
    You are right, it is not a bug. Therefore, I would just say that this is a suggestion for enhancement. There is no doubt that what you have here is a huge leap from manual changes to the folders.

    So don't take this as criticism. Thanks for working on Preware.
    I don't work on Preware Didn't take it as criticism either, I just don't want disinformation spreading. I don't want people thinking that the theming system is broken or something. If the proper procedure is followed, errors should be next to none.

    Quote Originally Posted by alex.dobeck View Post
    I think this should be file this bug as "Resolved -- Training Issue" and move onto something more pressing
    haha
    PreThemer - Palm Pre Themes, Wallpapers & Bootlogos - packaged for easy installation. Themers! Post your themes!
    ***UNINSTALL THEMES BEFORE INSTALLING NEW ONES!***

    My Themes | Follow @PreThemer on Twitter!
  10. #10  
    Why is having to uninstall something a "bug"?

    Uninstalling a theme before installing a new one makes perfect sense to me.
  11. #11  
    Quote Originally Posted by philburkhardt View Post
    Why is having to uninstall something a "bug"?

    Uninstalling a theme before installing a new one makes perfect sense to me.
    It would certainly be nice to be able to have everyone be as well informed as you would like them to be. What a world we would have if we never asked questions, or had to for that matter.

    However, we do not live in such a world, and I only hope that people are more kind to you when you come across something you do not understand and step out and ask about it.

    The OP was very professional in bringing up his concerns. That is the way we improve the experience on the Pre and Homebrew in particular. Please allow all users the ability to voice their concerns, and we might actually get somewhere.
  12. #12  
    I'd just like to point out you should be able to directly switch from theme to theme if you're using the Themer in WebOS Quick Install
  13. #13  
    Quote Originally Posted by pogeypetey View Post
    The OP was very professional in bringing up his concerns. That is the way we improve the experience on the Pre and Homebrew in particular. Please allow all users the ability to voice their concerns, and we might actually get somewhere.
    I know your post wasn't directed toward myself, but I'd like to agree here. The OP came with the issue presented properly. Could've been worse, like "OMG *** THEMEZ R BROKENZ"
    PreThemer - Palm Pre Themes, Wallpapers & Bootlogos - packaged for easy installation. Themers! Post your themes!
    ***UNINSTALL THEMES BEFORE INSTALLING NEW ONES!***

    My Themes | Follow @PreThemer on Twitter!
  14. #14  
    Ok. How can it be fixed? I followed the directions now my Steelers theme is all mixed up with the Steelers install package. I have tried to uninstall them both but Sprint at the top is replaced with Steelers, my browser wallpaper is a Steelers wallpaper, my photo wallpaper is a Steelers wallpaper and some of my dialpad buttons are the wrong color.
  15. #15  
    You cannot, unless you have all the original files and know how to change the old ones. Only option for you is WebOs Doctor.
  16. #16  
    That's not true. Aside from the utility jason released today, it sounds like all themes were not properly uninstalled. If things like that are still lingering, then there's some files still changed.
    PreThemer - Palm Pre Themes, Wallpapers & Bootlogos - packaged for easy installation. Themers! Post your themes!
    ***UNINSTALL THEMES BEFORE INSTALLING NEW ONES!***

    My Themes | Follow @PreThemer on Twitter!
  17. #17  
    Quote Originally Posted by AnOutsider View Post
    That's not true. Aside from the utility jason released today, it sounds like all themes were not properly uninstalled. If things like that are still lingering, then there's some files still changed.
    The utility is great. Though I was in the forums when it was posted on the main page, and responded here first.

    With the utility, it would definitely find those files and fix them. That is a better way, but I was accurate at the time.

    As for unistalling the themes, if WebOs quick install says it's done, there is no easy way to fix it other than WebOs doctor or Jason's utility. (You can of course work through Linux commands, but that is not easy/common knowledge)
  18. #18  
    true, but it sounds like he may have installed with preware? If so, he should check "Installed Packages" in Preware to make sure all themes are removed. I've updated my ipks to now check if a theme is install and return an error if it is.
    PreThemer - Palm Pre Themes, Wallpapers & Bootlogos - packaged for easy installation. Themers! Post your themes!
    ***UNINSTALL THEMES BEFORE INSTALLING NEW ONES!***

    My Themes | Follow @PreThemer on Twitter!
  19. #19  
    Quote Originally Posted by AnOutsider View Post
    true, but it sounds like he may have installed with preware? If so, he should check "Installed Packages" in Preware to make sure all themes are removed. I've updated my ipks to now check if a theme is install and return an error if it is.
    So are you checking to see if the .png files are different than orginal?
  20. #20  
    Quote Originally Posted by pogeypetey View Post
    It would certainly be nice to be able to have everyone be as well informed as you would like them to be. What a world we would have if we never asked questions, or had to for that matter.

    However, we do not live in such a world, and I only hope that people are more kind to you when you come across something you do not understand and step out and ask about it.

    The OP was very professional in bringing up his concerns. That is the way we improve the experience on the Pre and Homebrew in particular. Please allow all users the ability to voice their concerns, and we might actually get somewhere.
    What was not "kind" about what I said? All I did was state that doing something made sense to me. I didn't trash anyone, I didn't call or think anyone stupid. Why look so hard for something to be offended with?. Your response to me was far more mean spirited than my question. I also didn't realize I had the ability to stop people from voicing concerns. Wow, it must be my whole 39 posts that gave me that power. I too have the right to voice my opinion in this forum. I don't put people down, I don't flame and I think anyone has the right to ask anything they want. Calm down buddy,...life is too short.
Page 1 of 2 12 LastLast

Posting Permissions