webOS Nation Forums >  webOS Discussion >  webOS Synergy and Synchronization > Remember the milk synergy plugin
Remember the milk synergy plugin
  Reply
Like Tree2Likes

 
Thread Tools Display Modes
Old 02/22/2013, 01:26 AM   #1 (permalink)
pivotCE Developer
 
Posts: 1,976
There is a first one-way synergy plug-in available for webOS

Synergy Milk | webOS Nation
Synergy for rememberthemilk.com

As there is no stock tasks app available for TouchPad this plug-in does not support it.

But there is a workaround to get 2.x tasks app to TouchPad

Working Tasks-app of 2.x on 3.x incl.EAS sync

Works now with RTM Synergy version >= 1.2

------older stuff-----

So i tested installing RTM synergy and it works, but as for the EAS accounts the Tasks are not displayed to be activated in the rtm Account.




I think this could be because the 2.x Task app has to register it self with capabilty TASK on firstuse, so the Accounts know that there is a app that could use this capability.
Any dev knowing how to do this with an Mojo app?

The stock enyo apps seems to this with a FirstLaunchView.js here capability CALENDER
Code:
enyo.kind({
	name		: "calendar.FirstLaunchView",
	kind		: enyo.VFlexBox,
	className	: "enyo-bg",

	components: [
		{kind:"ApplicationEvents", onUnload: "unloadHandler"},
		{name: "firstLaunch", kind: "firstLaunchView", onAccountsFirstLaunchDone: "firstLaunchCompleted", capability: 'CALENDAR', 
						iconSmall: "../images/header-icon-calendar48x48.png", 
						iconLarge: "../images/icon-256x256.png"}
	],
Apart from that the Task app seem to get the task database from rtm plug-in






I was using a free remember the milk acc, but i don't get the rtm app to display the website to entern Account data. I saw on rtm Website that Pro Account is needed for sync. Is that true ?


__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?

Last edited by HelloNNNewman; 03/31/2013 at 03:46 PM.
gizmo21 is offline   Reply With Quote
Liked by Rnp likes this.
Thanked By: Rnp
Old 02/22/2013, 01:19 PM   #2 (permalink)
pivotCE Developer
 
Posts: 1,976
Problem with Account not showing Task is solved

Working Tasks-app of 2.x on 3.x incl.EAS sync

Now only the Token problem on TP with the plugin has to be solved
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is offline   Reply With Quote
Liked by Rnp likes this.
Thanked By: Rnp
Old 02/22/2013, 07:53 PM   #3 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Quote:
Originally Posted by gizmo21 View Post
There is a first one-way synergy plug-in available for webOS

Synergy Milk | webOS Nation
Synergy for rememberthemilk.com
As there is no stock tasks app available for TouchPad this plug-in does not support it.

But there is a workaround to get 2.x tasks app to TouchPad

Working Tasks-app of 2.x on 3.x incl.EAS sync

So i tested installing RTM synergy and it works, but as for the EAS accounts the Tasks are not displayed to be activated in the rtm Account.

Click to view quoted image



I think this could be because the 2.x Task app has to register it self with capabilty TASK on firstuse, so the Accounts know that there is a app that could use this capability.
Any dev knowing how to do this with an Mojo app?

The stock enyo apps seems to this with a FirstLaunchView.js here capability CALENDER
Code:
enyo.kind({
	name		: "calendar.FirstLaunchView",
	kind		: enyo.VFlexBox,
	className	: "enyo-bg",

	components: [
		{kind:"ApplicationEvents", onUnload: "unloadHandler"},
		{name: "firstLaunch", kind: "firstLaunchView", onAccountsFirstLaunchDone: "firstLaunchCompleted", capability: 'CALENDAR', 
						iconSmall: "../images/header-icon-calendar48x48.png", 
						iconLarge: "../images/icon-256x256.png"}
	],
Apart from that the Task app seem to get the task database from rtm plug-in



Click to view quoted image



I was using a free remember the milk acc, but i don't get the rtm app to display the website to entern Account data. I saw on rtm Website that Pro Account is needed for sync. Is that true ?


Click to view quoted image
Nice! Now we only need a full screen Task app for the TouchPad ...
__________________
Cheers, Vince
@webos24net donate

Last edited by HelloNNNewman; 03/31/2013 at 03:48 PM.
Vince42 is offline   Reply With Quote
Old 02/23/2013, 06:13 AM   #4 (permalink)
pivotCE Developer
 
Posts: 1,976
@vimce42 well the rtm token problem with your synergy plug-in is NOT solved on TP. Would be cool if you could test it

it does e not sync anything for now.
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is offline   Reply With Quote
Old 02/23/2013, 03:34 PM   #5 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Hi gizmo,

please try out the attached updated plug in - it should work now on TouchPad as well.

Tell me how it worked, and as soon as you are happy, I'll update the official version accordingly - thank you in advance!
__________________
Cheers, Vince
@webos24net donate
Vince42 is offline   Reply With Quote
Old 02/24/2013, 04:30 PM   #6 (permalink)
pivotCE Developer
 
Posts: 1,976
yep, works now

so now sync tasks on TouchPad with EAS and remember the milk (one way to devixe).
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is offline   Reply With Quote
Old 02/24/2013, 04:31 PM   #7 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Nice! Thank you for the feedback - will officially release the new version now to the public ...
__________________
Cheers, Vince
@webos24net donate
Vince42 is offline   Reply With Quote
Old 02/28/2013, 05:41 AM   #8 (permalink)
Member
 
Posts: 6
On my Pre3 trying to add the account I get an "Unknown error" message. Authorisation from RTM is ok, interval 5m. It does not seem network related as the error message is there immediately after I press the Sign in button.

Any thoughts?

Regards,
Paul
nlspek04 is offline   Reply With Quote
Old 02/28/2013, 05:45 AM   #9 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Hi,

Quote:
Originally Posted by nlspek04 View Post
On my Pre3 trying to add the account I get an "Unknown error" message. Authorisation from RTM is ok, interval 5m. It does not seem network related as the error message is there immediately after I press the Sign in button. Any thoughts?
Personally, I would not worry as long as everything else works.

If you want a "clean start" your should uninstall and reinstall the plug in ... that once did the trick when I mixed up versions during the testing phase ...
__________________
Cheers, Vince
@webos24net donate
Vince42 is offline   Reply With Quote
Old 02/28/2013, 03:31 PM   #10 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by Vince42 View Post
Hi,



Personally, I would not worry as long as everything else works.

If you want a "clean start" your should uninstall and reinstall the plug in ... that once did the trick when I mixed up versions during the testing phase ...
Thanks for your quick reply!

Everything else works in the sense of everything except the synergy RTM account. I do not get past the login screen (see attachment).

I tried reinstalling, alas no change. Also I tried removing the sync of my Exchange account with the tasks app. That did not help either.

Anything else I can try? Is there logging I can look at?

Cheers,
Paul
Attached Images
File Type: png accounts_2013-28-02_174608.png (51.3 KB, 20 views) Email Attachment
nlspek04 is offline   Reply With Quote
Old 02/28/2013, 03:37 PM   #11 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Hi,

usually the attempt to log in should bring up the authorization dialog etc - which in your case happened, as you said. After the authorization and setting the interval the token is validated and the account is set up. When you press "Sign In" then the process should be finished and the account should be added.

I once had a problem similar to yours when I mistyped my credentials ... but after that incident everything worked like charm.

If your problem should still occur, I will contact the developer and ask him to have a look into that matter

Sorry for the inconvenience ... :/
__________________
Cheers, Vince
@webos24net donate
Vince42 is offline   Reply With Quote
Old 02/28/2013, 04:14 PM   #12 (permalink)
Member
 
Posts: 6
The token works and the credentials I use are valid so that can't be it. If the developer has any thoughts it is much appreciated!

Thanks for the support so far.

Paul
nlspek04 is offline   Reply With Quote
Old 02/28/2013, 07:18 PM   #13 (permalink)
Member
 
dkirker's Avatar
 
Posts: 983
Is there a source code repo (like on github) for this?
__________________
The comments and thoughts expressed on this discussion board are strictly my own and are not those of OpenMobl Systems.
dkirker is offline   Reply With Quote
Old 03/01/2013, 10:22 PM   #14 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Hi,

Quote:
Originally Posted by dkirker View Post
Is there a source code repo (like on github) for this?
As soon as I get the source code from the developer, I will create a public repo for it. This applies to all sub projects ... stay tuned ...
__________________
Cheers, Vince
@webos24net donate
Vince42 is offline   Reply With Quote
Thanked By: dkirker
Old 03/02/2013, 05:00 AM   #15 (permalink)
Member
 
horzel's Avatar
 
Posts: 79
Hi, tried to use it on my Pre³, but my account name has an underscorem which I can't use, since the sym key doesn't work. Thanks for all the effort!
horzel is offline   Reply With Quote
Old 03/02/2013, 05:53 PM   #16 (permalink)
Member
 
dkirker's Avatar
 
Posts: 983
Quote:
Originally Posted by horzel View Post
Hi, tried to use it on my Pre³, but my account name has an underscorem which I can't use, since the sym key doesn't work. Thanks for all the effort!
There should be a patch somewhere that let's you use sym keys in Enyo apps.
__________________
The comments and thoughts expressed on this discussion board are strictly my own and are not those of OpenMobl Systems.
dkirker is offline   Reply With Quote
Old 03/03/2013, 01:15 AM   #17 (permalink)
pivotCE Developer
 
Posts: 1,976
Quote:
Originally Posted by dkirker View Post
There should be a patch somewhere that let's you use sym keys in Enyo apps.
It's linked in my signature
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is offline   Reply With Quote
Old 03/04/2013, 02:27 AM   #18 (permalink)
Homebrew Developer

 
Vince42's Avatar
 
Posts: 79
Hi,

Quote:
Originally Posted by nlspek04 View Post
Thanks for your quick reply!
Everything else works in the sense of everything except the synergy RTM account. I do not get past the login screen (see attachment).
I tried reinstalling, alas no change. Also I tried removing the sync of my Exchange account with the tasks app. That did not help either.
Anything else I can try? Is there logging I can look at?
The developer wrote:
Quote:
[01.03.2013 10:50:02] Proper way to uninstall is: 1. remove (if exists) RTM account in Account app; 2. uninstall Synergy Milk aplication; 3. restart phone
[01.03.2013 10:50:32] He could also check OS version - it was tested on 2.2.4 only
[01.03.2013 10:55:46] Then he can install again; steps after installation: 1. go to Accounts app and add RTM account; 2. enter username/password (any name/password - it is not checked now, because token does not exists yet); 3. Synergy Milk app must be launched automatically (and in Account app there must be error message 'Server Error'); 4. enter Username/Password in web page and confirm permission for API access on next page; 5. back to Accounts app check username - this time it must match the name used on webpage. Password is not checked as it is not used at all;
[01.03.2013 10:56:15] to check logs - he would need to novaterm to device and run:
[01.03.2013 10:56:29] cat /var/log/messages | grep -i -e rtm
Please let me know if this got you any further, thank you!
__________________
Cheers, Vince
@webos24net donate
Vince42 is offline   Reply With Quote
Old 03/04/2013, 02:33 AM   #19 (permalink)
Member
 
dkirker's Avatar
 
Posts: 983
Quote:
Originally Posted by gizmo21 View Post
It's linked in my signature
YEAH! That one!!
__________________
The comments and thoughts expressed on this discussion board are strictly my own and are not those of OpenMobl Systems.
dkirker is offline   Reply With Quote
Old 03/06/2013, 12:51 AM   #20 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by Vince42 View Post
Hi,



The developer wrote:


Please let me know if this got you any further, thank you!
Tried uninstall and reinstall (with device restart inbetween). Also tried Emergency Patch Recovery. But no success so far. WebOS version matches.

Perhaps my Pre3 configuration is corrupt in some way. I have had issues with some homebrew services such as FileMgr and SysToolsMgr (won't run) since I had to doctor my phone.

Very reluctant to doctor again because I will lose all the Linkedin contacts (no longer supported).


I will try looking at logs later to see if that gives any clues.
nlspek04 is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0