Page 1 of 2 12 LastLast
Results 1 to 20 of 27
Like Tree2Likes
  1.    #1  
    Well... THIS is a BIG problem, that I have no solution.

    Now, I have 3 weeks without solve. Just to give some idea, I gonna leave some references about:

    Pre 3 "Retrieving email text..." timeout issue

    "retrieving email text"

    Email problem "retrieving email text" then "timed out"

    Mail Attachments not downloading

    pre2 - unable to retrieve email text......

    No mail body ?? (Exchange) on TP 3.05

    Gmail issue with Veer

    Report Pre3 bugs here

    No mail body ?? (Exchange) on TP 3.05

    Now, the problem: the email app receive the subject, the sender and until open the attachment, but not the email body. Interesting because the text are received (you can see while in list) but you cannot see, because staying showing the circle and the message "Retrieving email text" until the timeout and show the "Unable to download message." and the button "Retry", that solve nothing. This problem happens in Exchange (Gmail, Live or any other), Google or Pop account.

    Tested with emails in text and html, the problem continue.

    Other problem: I can create new emails, but cannot send. The email show the message "sendind email" in notification area, the message go away and the email continue opened, without send.

    Detail: I can read old emails, that was in device before this problem begin, but not new e-mails.

    Well, the worst part: I'm having this problem with Pre Plus (2.1), Pre 2 (2.1 & 2.4), Pre 3 EU (2.2.0 & 2.2.4)) and Pre 3 AT&T (2.2.4). I lost the last three weeks testing, using only two email accounts: Gmail and Live (Exchange), using the webmail to read the body and reply the emails, but is a very bad option.

    Devices doctorized, different profiles, deleting and recreating accounts, all emails archived in Gmail... and the problem continue.

    Until where I can see, the other sync (calendar, contacts, etc) are okay.

    I'm really opened to any ideas, search for logs, etc, etc, etc... and; yes, if I cannot solve this problem, I'll gonna leave the webOS to second moment, because the e-mail is my most important tool... after contacts.


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  2.    #2  
    Ok... I know that I'm boring... but the email is the most important app in webOS to me.

    Any idea, guys? Please?

    PS: I want to solve this now and inform to Webos Internals, because I believe that this can happens in Open webOS too... remembering: this problem happens in Touchpad, and there is no solution until now!!


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  3. #3  
    have you tried emptying the email cache/stored files? this is a big culprit for also getting the grey email screen of doom/blankness and general no worky behaviour.

    maybe try the email part of a reply i gave to database full/blank email issue here :> [patch in preware] Disk Cache mod

    might work, probably wont, but hey its something to try, email behaves weird and wiping the cache/attachments etc is the first thing i do and im usually back on track after a full restart, wont break anything (except making your on device emails vanish ofc).
    Touchpad Keyboard Themes - >> Click Me <<
  4. #4  
    Hello! Finally! The right thread to my issue!
    Yes, same here @Rnp. I've been without e-mails for about 2 weeks now. For me the e-mail app is really important also.
    @geekpeter: hello! We meet again (I was wrongly addressing this issue on the "application database almost full" thread). But this is exactly what's going on with my e-mail app. I read the thread of the Disk Cache mod patch you mention and I'll will try it because I'm desperate to solve this once and for all. I'll report back with the outcome. Thanks for being a helpful member of this community (I bump into you in every thread!) and giving us the non geeky one a hope. Cross my fingers and hope it'll work. Regards,
    UPDATE: Ok... So 5 minutes later, and yes... Just like @geekpeter said... It didn't help :'(
    I'll be standing by if someone comes up with another idea on how to sort this issue out.
    Last edited by ajguns; 09/27/2012 at 12:20 AM.
  5. #5  
    Yes.. same problem here... 'retrieving email text'.. fail.. 'reload'.. fail.
    WHERE is the text supposedly being 'retrieved' FROM? The machine or the server? I assume the machine... in my case a Touchpad.
    Infuriating!
    On checking the same email account on a PC.. no problem.. it's all there still!
    Does 'email cache' in webOS need to be made larger?

    Last edited by Mutoidi; 09/27/2012 at 03:45 AM.
  6.    #6  
    I solved the problem, but was painfull...

    This problem happens because there is some kind of e-mail that corrupts the database in webOS.

    I don't know if the problem is in Gmail or Hotmail, but I know that come from this servers.

    Solution: look the last day where you can read the e-mail body, and erase (or archive) IN SERVER all e-mails received or sent in this day AND in the day after, too.

    AFTER this procedure, erase the device and restore. The important is do not download this "corrupted e-mail" to device again.

    Since than, I has no more problem with this.


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  7. #7  
    Good research!

    Thank you. That seems to work.. yes!

  8. #8  
    Ok. So, restored my Preł so I can't see any of my e-mails. But I still have my Touchpad's e-mails so the last one showing content is from 9/12/12 (same day since my last backup; it's not backing up either). I have some questions though:
    1.- I have a gmail and a pop (my company's). Should I erased them both?
    2.- If I don't misunderstand, I have to enter gmail and my webmail server and from there erase the emails I received on the 9/12/12 and the 9/13/12. Is this correcto?
    3.- After this procedure I should do a hard reset (the one that restores apps and all) or just restart the device?
    4.- When deleted from server, my devices (Preł and Touchpad) will not be able to download those erased mails?
    Sorry for any question straight dumb, I'm just not in any way near a geek person (though I have manage to do some darn impressive things with the help of our Homebrew fellows off course!).
    Thank you for your response,
  9.    #9  
    1.- I have a gmail and a pop (my company's). Should I erased them both?
    2.- If I don't misunderstand, I have to enter gmail and my webmail server and from there erase the emails I received on the 9/12/12 and the 9/13/12. Is this correcto?
    3.- After this procedure I should do a hard reset (the one that restores apps and all) or just restart the device?
    4.- When deleted from server, my devices (Preł and Touchpad) will not be able to download those erased mails?
    Sorry for any question straight dumb, I'm just not in any way near a geek person (though I have manage to do some darn impressive things with the help of our Homebrew fellows off course!).
    1 - I don't know about POP, because I was using Gmail (Synergy account) & Hotmail (Exchange account), but I believe that; yes, have to erase this e-mails in both server.

    2 - Example: If you can see the e-mail's text in messages received until yesterday (26/09), I believe that have to erase the e-mails received yesterday (26/09) & today (27/09), because I believe that you don't know what is the corrupted e-mail.

    3 - Hard Reset - erase all and restore everything.

    4 - You gonna download all e-mails, except the erased. So; if is very important, I believe that you have to archive in Gmail, and not erase.

    So, I know that you can erase the e-mails one by one and test, but... putz! Imagine: erase one e-mail, erase and restore all device, if was the wrong e-mail, have to erase other e-mail, if was the wrong e-mail again, erase and restore all device... I don't know about the other people, but I has 68 e-mails to test! So, I sent everything to hell!! Hehehehehe

    If you have any other questions, I'm here to help.


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  10. #10  
    Also I just went to the dropdown 'Email Preferences & Accounts' ---> 'Accounts' ---> 'Sync Criteria' and turned on 'Sync Deleted Emails' whilst deleting the offending emails.

    Last edited by Mutoidi; 09/28/2012 at 04:08 AM.
  11.    #11  
    Quote Originally Posted by Mutoidi View Post
    Also I just went to the dropdown 'Email Preferences & Accounts' ---> 'Accounts' ---> 'Sync Criteria' and turned on 'Sync Deleted Emails' whilst deleting the offending emails.

    Is not enough... just erase the e-mail don't solve the problem, because the database gonna continue corrupted.

    After clear the mail box, you HAVE to erase and restore the devices.


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  12. #12  
    Hello again;
    I did the procedure as suggested. My gmail account didn't retrieve the erased emails (the las date I could view e-mails -and had my last profile backup coincidently- was Sep./12. I erased since Sep./8 through the 17!) but my pop e-mail did retrieved the erased emails. I haven't opened them and will tell my server maintainer to erase those e-mails once and for all from the server.
    I'll let you know if the problem persisted or not.
    UPDATE: After doing the procedure just as Rnp instructs, I can happily inform that my e-mail app have been working for days now and no issue has occurred. Hope it never -ever- happens again, but if it does, I'm prepared now.
    Last edited by ajguns; 10/01/2012 at 11:28 PM.
  13. #13  
    Mine is fine too now.. once I erased the corrupting emails from the device AND from the server.
    @ Rnp: What do you mean by 'erase and restore the device' - a hard 'Restart'? Preware Save/Restore?
    The former seems to suffice for me!

    Thanks anyway!

  14. #14  
    ive been playing around, not a fast process ofc, but so far after my last fix, i only reactivated my gmail account and left out my hotmail one, no issues so far, tho thats no reason it couldnt happen later.

    a thought occured later, has anyone tried sending themselves an email with amazingly bad and broken html tags, just to eliminate that possibility for dbase/email app corruption?

    its hard to force the error and just relying on normal use to see if the problem still persists, no doubt if it happens again with just gmail only active i can at least rule out a hotmail issue.
    Touchpad Keyboard Themes - >> Click Me <<
  15. #15  
    clutching at straws here again, wondered if a dev can shed light.

    while looking around at files and configs i found the file printmgr in /etc/palm/filecache_types it has a flag in there called "lifetime" which is set to 0, im hoping this means not to cache/keep print jobs? Tho i could be miles off.

    I only ask as also in this folder are configs for email/attachments/more and they do not have this "lifetime" flag, does it do anything of use? Can it be added to the email/attachment/mediathumbnail/etc configs and do something of use here or does it do nothing of help?
    Touchpad Keyboard Themes - >> Click Me <<
  16.    #16  
    Quote Originally Posted by Mutoidi View Post
    @ Rnp: What do you mean by 'erase and restore the device' - a hard 'Restart'? Preware Save/Restore?
    The former seems to suffice for me!

    Thanks anyway!

    I was saying to use the "Erase apps and data", and restore the backup.


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  17. #17  
    Quote Originally Posted by Rnp View Post
    I was saying to use the "Erase apps and data", and restore the backup.


    Best Regards...

    OK, Thanks.
    However, I have not found it necessary to do this in order to correct the original problem.
    Perhaps it is the way my (.org) email account is set up.

    Cheers
  18. #18  
    Try the following command to clean the filecache safely (deleting the entire folder will mess things up):

    find /var/file-cache/email -mindepth 2 -delete

    and then either reboot the system (not just luna) or run:

    stop filecache
    start filecache
  19. brymcho's Avatar
    Posts
    8 Posts
    Global Posts
    13 Global Posts
    #19  
    You can try with Emergency file cache cleaner from Preware. It helps sometimes...
    Rnp and guilledil like this.
  20.    #20  
    Thank you, guys!

    The problem was; really, some e-mail with something inside corrupted... and never came back again.


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
Page 1 of 2 12 LastLast

Posting Permissions