webOS Nation Forums >  webOS Discussion >  webOS Synergy and Synchronization > Google Apps account now showing Unknown Error when trying to sign in
Google Apps account now showing Unknown Error when trying to sign in
  Reply
Like Tree2Likes

 
Thread Tools Display Modes
Old 06/27/2012, 09:01 PM   #21 (permalink)
Member
 
Phillykef's Avatar
 
Posts: 64
I am now getting this error on my Touchpad for one of my 2 gmail accounts. I tried removing the account and re-adding, but I keep getting "Unknown error" when I enter the correct password and "The account credentials you entered are incorrect. Try again" when I enter the wrong password. I do have Google Drive on the account that's not working, but is there any way to fix this?
__________________
Phillykef is offline   Reply With Quote
Old 06/28/2012, 05:05 AM   #22 (permalink)
Member
 
Posts: 868
I would expect this to help [Patch 2.1.0] Fix login to Google Calendar when passwords contain certain characters

But alas it is only available for webOS 2. I'm still hoping some dev to port the patch to webOS 3.x as well!
spud101 is offline   Reply With Quote
Old 10/15/2012, 04:33 AM   #23 (permalink)
Member
 
Posts: 868
Please, could anyone take a look at this. I still encounter this "unknown error" a lot on my Touchpad
spud101 is offline   Reply With Quote
Old 10/15/2012, 04:36 AM   #24 (permalink)
Member
 
Posts: 2,670
Quote:
Originally Posted by spud101 View Post
Please, could anyone take a look at this. I still encounter this "unknown error" a lot on my Touchpad
Could you try the google sync behavior patch for the touchpad? I added the regex fix to it.
__________________
French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

Please remove UberCalendar and google sync behavior patches prior to system updates.
patch Google calendar sync behavior for 2.x.x and TouchPad (Tweaks enabled)
Preference guide for MetaView's UberCalendar patch
frantid is offline   Reply With Quote
Thanked By: spud101
Old 10/19/2012, 01:30 PM   #25 (permalink)
Member
 
Posts: 868
I'll try that over the weekend. Thanks!
spud101 is offline   Reply With Quote
Old 10/21/2012, 12:48 PM   #26 (permalink)
Member
 
Posts: 868
It seemed I already had that patch installed. Flicking the "advanced" switch to on in tweaks magically fixed the problem (so far)

Thanks!!!
spud101 is offline   Reply With Quote
Liked by geekpeter likes this.
Old 10/30/2012, 05:41 AM   #27 (permalink)
Member
 
Posts: 868
Alas, I cheered too soon. I still encounter the same problems again. Calendar not syncing again and when trying to re-enter my google account credentials I get the "unknown error" again. After a reboot I can enter them succesfully but it will only work for a limited time before the syncing stops working again...

Can I somehow log what is happening with lumberjack?
spud101 is offline   Reply With Quote
Old 10/30/2012, 05:41 AM   #28 (permalink)
Member
 
Posts: 868
Sorry, somehow double posted
spud101 is offline   Reply With Quote
Old 10/30/2012, 09:16 AM   #29 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,687
I sometimes found that when I added an account in system/accounts, then told my password is wrong, I'd go back to check and only 4-5 stars show as my hidden password, which is 13 chars long. Now tho I'd goto the app in question having issues like email for example, then I'd goto prefenences/accounts within the app and alter the password in there.

lo and behold it worked for me, rarely glitches back but its 1 more thing to check/test.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 10/30/2012, 12:17 PM   #30 (permalink)
Member
 
Posts: 2,670
I think it's my fault as I was thinking about phone versions. I'll update the TP version and get it submitted to preware.

Quote:
Originally Posted by spud101 View Post
Alas, I cheered too soon. I still encounter the same problems again. Calendar not syncing again and when trying to re-enter my google account credentials I get the "unknown error" again. After a reboot I can enter them succesfully but it will only work for a limited time before the syncing stops working again...

Can I somehow log what is happening with lumberjack?
frantid is offline   Reply With Quote
Old 10/30/2012, 03:27 PM   #31 (permalink)
Member
 
Posts: 2,670
Quote:
Originally Posted by frantid View Post
I think it's my fault as I was thinking about phone versions. I'll update the TP version and get it submitted to preware.
Quote:
Originally Posted by spud101 View Post
I would expect this to help [Patch 2.1.0] Fix login to Google Calendar when passwords contain certain characters

But alas it is only available for webOS 2. I'm still hoping some dev to port the patch to webOS 3.x as well!
I am just confused today. I didn't add it to the TP patch because the TP already has the regex fix in it.

It is where the patch for the phones first came from.
__________________
French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

Please remove UberCalendar and google sync behavior patches prior to system updates.
patch Google calendar sync behavior for 2.x.x and TouchPad (Tweaks enabled)
Preference guide for MetaView's UberCalendar patch
frantid is offline   Reply With Quote
Old 10/31/2012, 08:33 PM   #32 (permalink)
Member
 
Posts: 868
Or it's a different issue?
spud101 is offline   Reply With Quote
Old 12/08/2012, 03:18 PM   #33 (permalink)
Member
 
Rockbeast's Avatar
 
Posts: 1,230
I'm getting this error now on one of my gmail accounts. I've had to update many times in the past, but I've never gotten the 'unknown error' message before. I'm trying to install this google sync behaviors patch but it's not completing the process...just the spinning wheel of despair and now it says "sed:write error".

Oh wait, it says the patch was installed...Luna restart required and...voila! This time the update to my login worked!
__________________
Sent from my slowly diminishing intellect

I'm just a soul who's intentions are good...oh Lord, please don't let me be misunderstood!

Rockbeast is offline   Reply With Quote
Old 05/29/2013, 03:28 PM   #34 (permalink)
Member
 
Posts: 1
Hi everyone,

I'm sorry to repopen this thread, but I just started having this problem again! Has anyone else started experiencing this again?

I have followed all the advice in this thread, including doctoring my pad, but to no avail.

Any other suggestions?

Thank you for your help!
als5122 is offline   Reply With Quote
Old 06/06/2013, 02:51 PM   #35 (permalink)
Member
 
Posts: 868
Forget issue below. Date of phone was wrong. Corrected and google apps issue solved.

----

Since the palm root certificate update was announced I powered on my Pre3 again after several months. I noticed that none of my google apps accounts work anymore (they do work on my Touchpad). I get a "The server's security certificate has expired"???

I don't get this. his is not about the Palm certificate but a google certificate, isn't it? I already removed and re-added an account to no avail. Anyone has a fix?

Last edited by spud101; 06/06/2013 at 03:12 PM.
spud101 is offline   Reply With Quote
Liked by Rnp likes this.
Thanked By: Tatobest
Old 03/31/2014, 06:45 PM   #36 (permalink)
Member
 
Posts: 13
Quote:
Originally Posted by hans109h View Post
Set up a regular e-mail account for e-mail.

If you only use a primary calendar, setup a microsoft exchange account for your calendar, and perhaps try the Microsoft Exchange Account for contacts, you might not get all the information you need, but it's a start.

Perhaps backup your data via google before starting too.
I hear this about Microsoft Exchange Account, but that's a expensive solution at $3,- a month.
Erik-Jan is offline   Reply With Quote
Old 04/03/2014, 03:35 AM   #37 (permalink)
Member
 
marshalla99's Avatar
 
Posts: 655
Change in Google API seems to be causing this now. Patch available : [Patch] Google sync https fix (unknown error on sign in)
__________________
Psion 3a, 3c, 3mx, Handspring Visor Deluxe, Treo 180, Treo 600, Centro, Pre, Touchpad, Pre3, Blackberry Passport (sorry!)
marshalla99 is online now   Reply With Quote
Old 04/08/2014, 10:18 AM   #38 (permalink)
Member
 
Luca Mori's Avatar
 
Posts: 2
To resolve any problem in Pre3 you need to install a terminal in your phone for example Xterm.

Using vi you need to edit file:

/usr/palm/services/com.palm.service.contacts.google/javascript/assistants/checkcredentialsassistant.js

at line 81 repalce http with https so the line becomes

query = new google.gdata.contacts.ContactQuery("https://www.google.com/m8/feeds/contacts/default/full");

save and exit

then edit file

/usr/palm/services/com.palm.service.contacts.google/javascript/assistants/syncassistant.js

and replace http by https at line 7 so the line becomes

_feedUrl: "https://www.google.com/m8/feeds/contacts/default/full",

and at line 331 so the line becomes

this.client.gdataService.getContactGroupFeed("https://www.google.com/m8/feeds/groups/default/full", future.callback(this, function (feedRoot) {

save and exit..
Now all sync run correctly.
Luca Mori is offline   Reply With Quote
Thanked By: Atheist
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0