Page 1 of 2 12 LastLast
Results 1 to 20 of 36
  1.    #1  
    Hi guys, love my Pre 2 (coming from an iPhone) and I definitely love webos over iOS. There's a couple of things I'd like "fixed" (e.g. time zones in calendar events) but there is one thing that makes me not trust my Pre. In my experience Sync does not work 100% of the time. Let me explain...

    I basically sync everything to my Google account (calendar and contacts), the same I used to do on my iPhone which worked very well. I travel a lot so I usually update my calendar and contacts offline (no wifi or data). The thing is that not always contacts and/or events are synched from pre to google or vice-versa.

    The one time I de-activated and re-added my google account I lost countless events and contacts. I've tried restarting, changing accounts (as per above experience) and still it's a hit and miss affair.

    IMHO this is something that HP/Palm cannot afford to not get right. Synergy / Sync is one of webos main pillars and it should work 100% all the time. I've read some comments of similar (not exactly) issues.

    Any ideas? help? (except deleteing and re-adding accounts please!)

    Cheers
  2. #2  
    Check to make sure that the default account in your calendar and contact apps are gmail and not your Palm profile.

    Also, make sure that in the calendar view that you have "all accounts" showing for your view. Otherwise you would only see events for a specific calendar.

    It wouldn't make sense that the Pre would (or could) delete gmail data just by removing the account from the phone. It sounds like you may have put some of your contacts and entries into your Palm profile by mistake.

    Also check to make sure automatic backup ran in the last 24 hours, and check several days in a row. If you put stuff in your palm profile (I recommend you never do that) and it didn't get backed up before a doctor or erase... you'd lose it.

    Take a look at those things and post back with your findings...
  3.    #3  
    Tks Cantaffordit

    Yes, my default account is Gmail, not palm profile.

    Yes, all accounts are visible.

    I think I expressed (bad english) the account point. I removed (not deleted) the gmail account from the Pre's account list to try to reset the link / sync.

    And lastly, yes, Palm profile is running but all my events / contacts are linked to gmail.

    I'm not sure if the issue is related to not being online all the time, it seems to work well if I'm online but it seems that offline things get messy. I've tried creating events offline and re-synching when online. Hit and miss.

    Thanks again.
  4. #4  
    are the events within the next few weeks? There is another thread that is talking about how Palm currently limits gmail sync to 2 months out from the current date, and only one month of history. Does that sound like what you've seen?

    Also, did you remove the account in the calendar app, or in the "accounts" app? I've heard comments that one sometimes is more effective than the other - but I can't remember which was which...
  5. #5  
    I have had things go missing here and there, but it is usually when I've had to doctor my phone and probably didn't sync prior to the wipe.

    If you are using multiple accounts (email, cal, and contacts) take a little extra care to confirm you are putting the items in the correct account. Confirm it by syncing and checking thru the browser (or w/your desktop browser) that the info is in the cal or contact account. You will have to sync both the phone and refresh your PC browser to see any new info that was added. And as Cantaffordit mentioned, confirm you have the correct calendar(s) showing in both places, too. If you are hiding a subcalendar in the web view but adding events to it on the Pre, it won't show up on the web unless you select that particular calendar to show.

    I use my Pre for my business and it has been reliable for storing calendar events and contacts. The few times I've lost things I have to attribute it to not syncing prior to running the webOS doctor or by initially entering into the Palm Profile (default) when I got the new phone. Sometimes my exchange account seems to pop up as the default and I have to re-select my gmail account.

    At the very least, if you doublecheck yourself for a bit, you may find a particular data entry workflow you are doing doesn't work properly and you can revise to one that works. Pay particular attention when you are adding entries while offline - can you go back and confirm you actually added the entry and still see it in the Pre? Then, check it once you are able to get online and try to sync. Is it still in the Pre? Did it get loaded to the web?

    Maybe you are getting distracted before hitting save or finishing the entry? Who knows - but if you monitor and doublecheck yourself, you will likely find a process that will work reliably for you.

    Most likely it is a simple fix. It is just a matter of finding it.
  6.    #6  
    Hi, wow thanks for ideas!

    I haven't Doctored the phone, so its not that. And when I removed the account is was from Accounts, not the calendar app (as I read in this forum). And the events are really recently added (same week or next one). Regarding the multiple accounts, I have two gmails (for email) but only one syncs calendar and contacts and one office outlook account (for mails and calendar).

    I just did a test, and in GMail Contacts I removed all contacts from "My Contacts". Then I synched and surprise! several contacts which were added in Gmail (last two days) but not visible in Pre are now visible. But some contacts I've added to Pre (yesterday) are still not visible to Gmail. bummer

    I also just did a trial on calendars. If I add event in gmail it syncs to pre. I added event on pre and it didn't sync to gmail.

    I added an event to outlook (office) account and it didnt sync to pre. I tried the opposite (add in Pre under outlook account) and it didnt work either.

    Additional comment, the "sync problem" was present before I added the outlook (MS exchange) account.
  7.    #7  
    Oh, and one last comment. I'll be more mindful when adding data online and offline to see what works. Basic recommendation but need to put more attention. Thanks.
  8.    #8  
    Another update. It seems that whatever I add outside the Pre 2 (Gmail and outlook) appears on the Pre calendar. But whatever I add in Pre does not reflect outside. Both on contacts and events.
  9. #9  
    that really sounds like you are putting them in your palm profile. Can you create a new test account and gmail and play with that for a bit?
  10.    #10  
    From the settings standpoint my gmail account is the default. I always make sure that when adding events the google or outlook accounts are selected.

    How do I make sure for contacts that the gmail is default.

    Anyhow I'll give your idea a try with a fresh gmail account.
  11. #11  
    also remember that you have to enable the calendar for mobile on the gmail website...
  12. #12  
    To set a default in the email app, select "Preferences & Acounts" from the app menu. near the bottom is a block called "default account". Tap it and it will give you a list of choices. Same with the calendar app.
  13. #13  
    I can confirm, I have a new Pre 2 (since one week) and I experience the same thing.
    When I add events in my pre 2 only 2 of 3 will show up in google web calendar.
    When I add events in google web calendar I sometimes get duplicates in my pre2.

    Iím used to the old plam desktop for more than 10 years and it have never failed Ė but now I donít know what to do?
  14.    #14  
    Ok so I did a lot of Contacts tests. It results that yes, the Pre was saving new contacts (25 in total) to the profile and not to gmail. So I erased and re-inputted the contact ins Gmail. Btw, is there a way to move from one place to another (profile -> gmail)?

    I de-activated contacts in my gmail profile and after all was erased I re-enabled them. I checked the settings and ensured gmail as default. I added a contact last night and today I checked gmail and it was synched. So, up until now, all is well in "Contact land".

    I also double checked my calendar settings and made sure that gmail was default. I added (on the Pre) one event to my gmail and then one event to my outlook account. I checked today and only the outlook event was reflected on my PC.

    Today I'll disable my gmail calendar and re-enable to see if it helps. Any other ideas?

    THanks to all for your comments.
  15. #15  
    I noticed the same with mine as all my appointments were not showing up on my pres's google calendar.
  16. #16  
    this seems to be a problem! Sorry for the double post
  17. #17  
    I too miss Palm Desktop for the "all in one-ness" of having PIM bundled together for collection and retrieval of data. Evernote and other feature rich tools are nice, but for reliable ( = simple to set up, use and save) we're still behind what Palm OS had - for bare bones functionality. I don't pretend it was pretty.

    Anyway, I did some contact tests, too, and one thing to look for:

    In gmail (web) contacts you will see 2 number representing how many contacts you have. Click on Contacts and notice at the top of the contact list is My Contacts (and the # you have) and at the bottom of the list is All Contacts (and another number). All contacts represent all entries in your Gmail contacts. My Contacts are those contacts that have been added basically to you "frequently used or personal" contact book. It is a special label given to certain contacts through your use of their email or such.

    To confirm all contacts in your gmail account are available thru your webOS device, make sure you have added all contacts to MY CONTACTS, by selecting all contacts then clicking Add To My Contacts on the right side of the screen.

    Now, go to your webOS device and sync contacts. To confirm all contacts are there, open Contacts > Preferences and Accounts > and the gmail account you want to check (from the account list, not the Default section). Beneath the login section it will show you how many contacts it shows in THIS gmail account. This number should now match the number in your gmial All Contacts list.

    The issue with this is that it clutters the contacts list with a lot of extra contacts that I may never need, but the flip side is it throws in some I may not have remembered to add, by the nature of sweeping in those I've exchanged emails with. With Universal Search (such as it is) to find names, I never have to scroll thru my list anyway, so easy enough to just start typing the name and it pops up.

    Having said that, not all contact fields are searchable. I can't find notes in contact fields (yet). Not sure if that will change with 2.0 (I'm on Sprint). So you have to label the contact in the way you are most likely to search contacts for it (by name, business or keyword). But if the total # of contacts (by account) matches, you know the info is in there - it is a matter of finding it.

    Likned accounts can also "hide" an entry. Again, if the contact totals match what you see in the web, you know the info is there, but it may be a linked account (that you did intentionally or by mistake) and hiding under another similar name. One thing I noticed today is that when I linked accounts, it "hid" the test account I was looking for because it was no longer listed by the name I was looking for.

    The complexity can be illustrated by this simple test I did yesterday and today:

    I entered a contact in gmail that was similar to one I had in my exchange account. I synced, but the contact never showed up. I got busy and left before resoling it. In the meantime, at some point yesterday I'd merged my test entry with another similar entry in my gmail web account.

    Today, I checked my Pre and still didn't see the contact. After adding all contacts to My Contacts, I synced again. This time I also entered in my gmail contacts password (I'd changed it recently and not sure if I'd ever updated the contacts password, although I knew I'd updated the email pw for the same account) and synced again.

    When I'd entered the updated contact password AND synced, now the new test account, which I'd merged with another exchange contact, showed up but under the primary profile of the exchange contact. Only when I opened that contact up was I able to see the same "contact" as I saw in gmail web.

    As confusing as that all is, remember: when you change your email account password, you have to change the password in all three places for the webSO device: mail, contacts, calendar. I didn't test calendar on this, but it seemed to be the issue for the contact updating.

    I'm still not crazy about using gmail contacts as my Palm Desktop replacement, but I haven't found anything else that allows me to remain portable (to move from webos to another format, if needed) w/o having to have my own server set up.

    In a rush, but I hope helps explain some of the messiness going on with contacts. This is why I suggested seeing what you did that worked or didn't work, because there are a lot of places where how you handle things can make a big difference in what you see. Synergy is handy, but works better when we know limitations, pitfalls, etc.
  18.    #18  
    After the cleanup I did on both devices contacts now works fine.

    What isn't working is the calendar sync. Today I added two events on Pre (whilst connected to wifi): one to my gmail account and one to my outlook account. And in the office (whe my Pre has no data connection) I added on gmail web one event and on outlook one event.

    When back at hotel, the Pre has all 4 events (the ones created on pre and the ones created on gmail / outlook). But... Outlook doesn't have the pre - outlook event nor does gmail see the pre- gmail event.

    So... Pre 2 reads everything but isn't being able to share outside. I've double checked and the default account is gmail, not palm profile.

    Any ideas? losing faith...
  19. #19  
    I just tested mine and it worked both ways (to and from Pre) for Exchange and (to and from the Pre) for my gmail (gmail for my domain).

    I did however have to update my CALENDAR account passwords, since I'm using a replacement Pre. It's turned into a temp replacement because it is buggy and after 3 - 4 trips to the doctor I finally took it back in. Now awaiting what I hope will be my last Pre (to be replaced soon with a new device!).

    ANYWAY...

    With all the doctoring I think I lost track of what email, cal and contact accounts I'd updated.

    So, make sure you have current passwords for all these accounts you are testing entered in. I don't share between Exchange and gmail calendars, but I can sync with both on my Pre.

    The only other issue to be aware of is the ability to have multiple Gcals in your account and the ability to hide or show them on both Gcal and on the Pre. If you have multiple calendars on 1 gcal account, make sure you are showing the ones you are adding the events to. That can be confusing if you have 5 subcalendars on Gcal and only have 2 showing on the Pre, you have gcal configured, but you won't see the events of they are being entered on a diff subcalendar. Or if you are entering events on the main gmail calendar but don't have it selected/visable/highlighted on gcalendar.

    So check that you have current passwords, all calendars showing (once you get it working, hide the ones you don't want), and sync again. My money is on the calendar password in the Pre or maybe the event is being added to a subcalendar and on the other device you don't have that particular subcalendar selected. Keep us posted!
    My frustration w/HP best characterized by Col George Taylor.
  20. #20  
    I don't know if this has ben posted, but you could try using googles exchange connection to your Gmail account. Basically you remove gmal and add https://m.google.com as a new Exchange account. There is also a solution if you use multiple calendars. With this you don't run into the silly "only 3 months forward" sync problem with gmail.
Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions