Results 1 to 3 of 3
  1.    #1  
    Hello!

    I run a dedicated email server on a Linux box and am running into problems. The server is mostly for private use so I just went a head and generated my SSL certificates. Everything works fine using emial clients on a PC. When you conenct for the 1st time the email client on the PC (eudora in my case) simply asks if you want to trust and remember this certificate for the domain and remebers going forward.

    The problem I am having with my Pre is every time I try to connect I get "SSL Certificate Error, The servers Certificate is not a trusted certificate". It doesn't give the option of remember the cert, just an "OK" button.

    If I disable SSL on the pre and connect to my mail server without any encryption everything works fine. This, of course is not the desierable way to retreive email and I would like to close up the standard mail ports on my server for security reasons.

    Anyone know a way to get the pre to remember certificates that are generated by a user and not purchased?

    Thanks,
  2. #2  
    When I set up IMAP/SSL or Exchange to get my US Army email I had to import the certificates to my Pre before it would work. Not sure if it pertains to you but the instructions can be summarized as follows (not sure if I missed some detail):

    1. Download the certificates to a PC.

    2. Once you get it downloaded onto your computer, plug your Pre into your computer via the USB cable (the same one you use to charge it) and copy the two .CER files into the "Download" folder on your Pre.

    3. Unplug the USB cable and go to the "Launcher" and select "Device Info". Scroll to the bottom and select "More Info". Tap on "Software" then tap on the top left where it says "Preferences" and choose "Certificate Manager". Click on the + sign on the lower left and you should the certificate you added to the folder. Click on the first certificate and then choose "Trust" when it asks what you want to do. Do this for each certificate if there are others.

    4. Now go back to the email setup and set it up.

    Hope that helps.
  3.    #3  
    Quote Originally Posted by Avenger069 View Post
    When I set up IMAP/SSL or Exchange to get my US Army email I had to import the certificates to my Pre before it would work. Not sure if it pertains to you but the instructions can be summarized as follows (not sure if I missed some detail):

    1. Download the certificates to a PC.

    2. Once you get it downloaded onto your computer, plug your Pre into your computer via the USB cable (the same one you use to charge it) and copy the two .CER files into the "Download" folder on your Pre.

    3. Unplug the USB cable and go to the "Launcher" and select "Device Info". Scroll to the bottom and select "More Info". Tap on "Software" then tap on the top left where it says "Preferences" and choose "Certificate Manager". Click on the + sign on the lower left and you should the certificate you added to the folder. Click on the first certificate and then choose "Trust" when it asks what you want to do. Do this for each certificate if there are others.

    4. Now go back to the email setup and set it up.

    Hope that helps.
    Excellent! Thank you sir! This worked like a charm.

    I can now close up the standard email ports on my server and sleep a little better at night.

    Thanks again!

Posting Permissions