Results 1 to 14 of 14
  1.    #1  
    I setup my email sync option to manual. I assumed that this means that it will not fetch emails automatically. The device stills pulls emails automatically by itself, from time to time, and I am not sure at what schedule right now.

    All the email accounts that I have setup exhibit this issue - Exchange, Hotmail, Gmail.

    What am I missing or is this a known bug with the Pre?

    In order to conserve battery life, I only want topull my emails down when I want them.

    Steve
  2. #2  
    Go into each account (from the app, swipe down on the top left corner, select Preferences & Accounts and select each account). After selecting an account, scroll down to the box that says Sync. There will be two entries, SHOW EMAIL and GET EMAIL (the headings are on the right, the value on the left). Select GET EMAIL, and the last entry will be Manual. Select that (on each account), and you should be set.
  3. #3  
    <<moved>>
    Just call me Berd.
  4. #4  
    Anybody know why an Exchange account continues to randomly sync even though Get Email is set to Manual?
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  5. #5  
    In my personal experience, opening the email app to view a particular email account signals a manual sync, regardless of whatever preset syncing schedule. If I don't go into an account, then the preset syncing rules for that account apply.
  6. #6  
    Quote Originally Posted by NachoB View Post
    Anybody know why an Exchange account continues to randomly sync even though Get Email is set to Manual?
    Are you getting email notifications when the email app is closed or just seeing new email when you open the email app? I agree with luau joe that the email app syncs when opening the email app.
  7. #7  
    I'll do some more testing today and see under what circumstances it pulls email. For now, I know it pulls them after rebooting the phone. It doesn't pull them when launching the email app. It doesn't pull them after reading an email on my PC (thought Exchange might force a push to change the mail status to "Read" causing the email to show up on the Pre but it didn't).
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  8. #8  
    Well, I have more testing to do. I'm at work, phone sitting on the TouchStone with screenlock on, email app is running, and a notification pops up of 3 new emails from my Exchange account.
    Around that same time, via Outlook, I believe one of the emails was marked as read when I switched to view another email (was on the phone and wasn't paying attention if the notification came before or after the email was marked as read), which I'm guessing may have caused a push out to the Pre. I did test this scenario yesterday but received no notifications after marking the email as read.
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  9. #9  
    Update. Email app open, phone locked, received email from the Exchange server and this time I was not in Outlook reading emails.
    Seems so random as to when I get emails with the Manual setting.
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  10. #10  
    I have more strange experience in it. I have set up Outlook account to sync manually but I receive emails every morning at the same time (around 8 AM) and AT THE SAME PLACE. If I am on a difrerent place then normally at 8, emails don't arrive or arrive at a different time. But main problem is I don't need receive emails every day (especially in the morning when I go to work). I have configured one Google account and one usual POP3 account together with the Exchange one and they behave as expected.

    Any solution or workaround? (Except deleting the account )
  11. #11  
    Quote Originally Posted by NachoB View Post
    Update. Email app open, phone locked, received email from the Exchange server and this time I was not in Outlook reading emails.
    Seems so random as to when I get emails with the Manual setting.
    If the email app is open Ive noticed the manual pull doesnt stay manual... but you might notice closing the email app fixes this problem. When you reset your pre it will always look at each mail box and compare to look for any new emails.
  12. #12  
    Quote Originally Posted by petr_treo View Post
    I have more strange experience in it. I have set up Outlook account to sync manually but I receive emails every morning at the same time (around 8 AM) and AT THE SAME PLACE. If I am on a difrerent place then normally at 8, emails don't arrive or arrive at a different time. But main problem is I don't need receive emails every day (especially in the morning when I go to work). I have configured one Google account and one usual POP3 account together with the Exchange one and they behave as expected.

    Any solution or workaround? (Except deleting the account )
    Syncing with an exchange account seems to be fairly buggy... I think the problem is it intermittently doesn't release the static connection to the server after checking it for changes in the inbox.

    What do you mean at the same place? Like for some reason when you walk past a certain gps point it downloads your exchange emails? I dont even know where to begin troubleshooting that one...
  13. #13  
    Quote Originally Posted by NachoB View Post
    Update. Email app open, phone locked, received email from the Exchange server and this time I was not in Outlook reading emails.
    Seems so random as to when I get emails with the Manual setting.
    Thinking more about this... have you noticed anything else hitting the same ports? This might be the issue... Incoming and outgoing ports might be conflicting with something else... or even just another account. Do you run jstop? having it auto run the garbage collector might solve that problem... or simply manually running the garbage collectors might help... if my thinking is even half correct... but network settings are SO far from my expertise... I know having cross talk across ports, or any resident bits left over with a robot can cause problems...
  14. #14  
    Quote Originally Posted by bluewanders View Post
    Syncing with an exchange account seems to be fairly buggy... I think the problem is it intermittently doesn't release the static connection to the server after checking it for changes in the inbox.

    What do you mean at the same place? Like for some reason when you walk past a certain gps point it downloads your exchange emails? I dont even know where to begin troubleshooting that one...
    I didn't know Pre creates static connection to the Outlook server. But this information can explain my Pre's behaviour. The situation when mails arrive is such that I come back to the network reach after being few minutes (about ten) out of signal. (And the place and time are surprisingly the same every mornnig if I go to work )

    So bug can be that mail application synchronize mails automatically after staying out of signal even if setup is "Manual".

    But I think static connection to the server (at least in case of manual sync) isn't good idea.

    (I'm sorry for my English )

Posting Permissions