Results 1 to 7 of 7
  1.    #1  
    Hello for the first time,

    I have the following problem: My Pre is set up to sync with my Google calendar and it really works fine, in exception of one little Detail. It shows every event one hour earlier. This Shift does not affect the original calender at Google.
    If I create a new appointment, for example at 5pm, it syncs correctly and Google calendar says 5pm to me. And if I press sync again on the Pre, it syncs this event back from Google and shifts it to 4pm but does not affect the Google calendar.
    This shift is highly affected by the timezone settings. If I play around with the timezone setting, the events I created on the pre shift to the right time and the "old" ones are shifted by another amount of Time.
    You can imagine my question.
    W-T-F?

    And by the way: When I switch on an appointment on the Pre and sync it to all machines, Google and every machine I synced to send me an email each, this drives me crazy.
  2. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #2  
    Quote Originally Posted by Tetraden View Post
    Hello for the first time,

    I have the following problem: My Pre is set up to sync with my Google calendar and it really works fine, in exception of one little Detail. It shows every event one hour earlier. This Shift does not affect the original calender at Google.
    If I create a new appointment, for example at 5pm, it syncs correctly and Google calendar says 5pm to me. And if I press sync again on the Pre, it syncs this event back from Google and shifts it to 4pm but does not affect the Google calendar.
    This shift is highly affected by the timezone settings. If I play around with the timezone setting, the events I created on the pre shift to the right time and the "old" ones are shifted by another amount of Time.
    You can imagine my question.
    W-T-F?

    And by the way: When I switch on an appointment on the Pre and sync it to all machines, Google and every machine I synced to send me an email each, this drives me crazy.
    I suggest you check what Time Zone you have listed under the General Settings tab of the Calendar Settings on your Google Calendar. This might solve your time syncing problem. I'm not sure I understand the e-mail problem you're having - you receive an e-mail each time an appointment changes, not at the time the alarm event is set for?
  3.    #3  
    OK, I checked the timezone setting in Google calendar and it was set correctly. (GMT+1 Berlin) But I found an option to add an alternative timezone, so I added GMT+1 Paris, because this is the timezone my Pre recieves from the net. Maybe this solves this issue.

    The email problem has the following two scenarios:
    1.: I set up an event on a machine (Mac) and activate an appointment(alarm) for this event. I sync it to Google and from there to the Pre and the other machines. The event is coming, the phone is "ringing", the machines too, and everything is ok.
    2.: I set up an event on my Pre and activate an appointment for this event. I sync it to Google anf from there to my machines. The event is coming, the phone is "ringing", the machines ring too, and I get an email from google and one from each machine, the event is synced to.

    I already unchecked the mail option in Google calendar, because I had a similar problem while setting up this whole sync infrastructure.

    Edit: The shift issue is solved, so we can precis: At least one of the timezones in Google calendar has to be the same as the one, the Pre is set to.
    Last edited by Tetraden; 01/10/2010 at 02:55 PM.
  4. #4  
    Re: the one-hour shift, do Berlin and Paris have different DST rules? The fact that there are two different cities listed in the same time zone suggest this might be the case and, thus, the cause of your shift.

    As for the email, I think I understand what you're saying b/c I have the same issue...every time I have an alarm set ON MY PRE for a given appointment, Google sends me an email reminder (which I hate). If an appointment does not have an alarm set on my Pre, I get no reminder. I have tried every setting I can find and have posted about this in the past, and have concluded that it is a (Google) quirk that I have to live with for now. Hoping for a fix in the future...

    ME
    Mark A. Einersen
    HTC Evo 4G w/Seidio Innocase Active Limited Edition Case < Palm Pre < Palm Pixi (wife) < Palm Treo 755p < Palm Centro (wife) < pa1mOne Treo 650 < Palm Tungsten|E (wife) < Palm Tungsten|T3 w/Sena Case < Sony Clie NR70 < Palm m505 < Palm m105 (wife) < Palm Vx < Palm Pilot Professional w/2 MB upgrade < Palm Pilot Professional < Sharp Zaurus ZR-3500 < Casio Digital Diary SF-4000 < Casio Digital Diary SF-1000
  5. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #5  
    Quote Originally Posted by Tetraden View Post
    OK, I checked the timezone setting in Google calendar and it was set correctly. (GMT+1 Berlin) But I found an option to add an alternative timezone, so I added GMT+1 Paris, because this is the timezone my Pre recieves from the net. Maybe this solves this issue.

    The email problem has the following two scenarios:
    1.: I set up an event on a machine (Mac) and activate an appointment(alarm) for this event. I sync it to Google and from there to the Pre and the other machines. The event is coming, the phone is "ringing", the machines too, and everything is ok.
    2.: I set up an event on my Pre and activate an appointment for this event. I sync it to Google anf from there to my machines. The event is coming, the phone is "ringing", the machines ring too, and I get an email from google and one from each machine, the event is synced to.

    I already unchecked the mail option in Google calendar, because I had a similar problem while setting up this whole sync infrastructure.
    Hopefully realizing and accounting for the location of the server will take care of the time zone issue for you. I once had that happen on my Palm Centro (before the Pre) when my hosting company temporarily switched to a German server (and I'm in the US).

    Regarding the e-mail issue, sorry, I'm still not following you. Perhaps someone else will be able to assist. It sounds like you're manually forcing a sync from your Mac to Google as well as from Google to your Pre though? The calendar on the Pre should refresh on it's own though (and I would imagine you can set the Mac to as well depending upon what software you are using), so you shouldn't have to force the sync. I'm also a little confused about your use of the term "the phone is 'ringing'" - why would the phone ring during a calendar sync? I would describe the phone ringing only for an incoming telephone call. Perhaps I'm not reading your message as you intended it. Let's see if someone else can assist with that issue.
  6. ay
    ay is offline
    ay's Avatar
    Posts
    720 Posts
    Global Posts
    772 Global Posts
    #6  
    Quote Originally Posted by OnePalmAddict View Post
    Re: the one-hour shift, do Berlin and Paris have different DST rules? The fact that there are two different cities listed in the same time zone suggest this might be the case and, thus, the cause of your shift.

    As for the email, I think I understand what you're saying b/c I have the same issue...every time I have an alarm set ON MY PRE for a given appointment, Google sends me an email reminder (which I hate). If an appointment does not have an alarm set on my Pre, I get no reminder. I have tried every setting I can find and have posted about this in the past, and have concluded that it is a (Google) quirk that I have to live with for now. Hoping for a fix in the future...

    ME
    Ah ha. The e-mail quirk only for appointments set on the Pre (not for ones set on Google) - that I can shed some light on. It's actually a Palm issue, not a Google one. Palm made that a "feature" in a prior WebOS upgrade (for some horrible reason in my opinion!). The only work-around that I'm aware of is to set an e-mail filter in your gmail account to filter out these reminder when they arrive so that they don't ever reach your inbox. You do this by filtering out all e-mails sent from calendar-notification@google.com to your e-mail address. That should solve that issue for you I hope.
  7.    #7  
    Thats the strangest thing with this, Berlin and Paris (I actually live in Berlin, so I don't know where the net takes Paris from) are both GMT+1. But it solved the Problem, so I think I should be happy.

    Yup, that is exactly what I mean, but to me, the problem is a bit bigger. The "send an email command" gets synced to every machine, so I get 5 mails for every activated reminder at different times, depending on the time, when a machine is online. This is really kind of annoying.

    Edit: @ay: I am sorry, I'm not this good in english. But you are right, to test the different scenarios I was forcing the syncs, but normally the devices do this by themselves.
    Your workaround for the reminder-mail issue sounds pretty ok until palm fixes this, I will try it.

    Thank you very much, both of you.
    Last edited by Tetraden; 01/10/2010 at 03:10 PM.

Posting Permissions