Results 1 to 17 of 17
  1.    #1  
    I hope I'm not posting a common problem... I have looked for hours for a solution.

    I have used google calendar forever... I have migrated to a gmail account and all of my calendar events are correct on http://calendar.google.com but they are all a day off on my pre... what could be the problem? I have checked the time zone setting in the "Date & Time" setting page and it is correct for CST.

    Please help...

    Thanks,

    -Jake
    "Aggies never lie cheat or steal, nor tolerate those who do."
  2.    #2  
    Should I just perform a hard reset?
    "Aggies never lie cheat or steal, nor tolerate those who do."
  3.    #3  
    Wiped it clean, it is now working... Thanks for the help guys!
    "Aggies never lie cheat or steal, nor tolerate those who do."
  4. #4  
    Quote Originally Posted by jp89hornet View Post
    Wiped it clean, it is now working... Thanks for the help guys!
    LOL. Sorry you didn't get any help with this.

    I just noticed that all of my "All day" events are showing up on my Pre one day early. I'm syncing to Exchange and all of the events are on the correct day in Outlook. Any ideas?
  5. #5  
    I had this problem too when I migrated my calendar entries from my BlackBerry to my Palm, I gotta admit I got so annoyed with it I just deleted each individual entry and re-entered it into my Palm. Not an elegant solution but I couldn't find another way to fix it.
  6. #6  
    Quote Originally Posted by SqyArc View Post
    I had this problem too when I migrated my calendar entries from my BlackBerry to my Palm, I gotta admit I got so annoyed with it I just deleted each individual entry and re-entered it into my Palm. Not an elegant solution but I couldn't find another way to fix it.
    Well... That's obviously not the solution I was hoping for but thanks for confirming that I'm not the only one seeing this issue.

    I did some more testing today and I've noticed that if I create an "all day" event for today's date from within OutLook, it actually works correctly and shows up on my Pre on today's date. Also, It doesn't seem to matter if I create it as just an all day event for just today or if I make it recurring yearly.

    My problem is that all of the birthday reminders (and other yearly "reminder type" calendar events) are all showing up one day early on my Pre.
  7. eheaps's Avatar
    Posts
    35 Posts
    Global Posts
    42 Global Posts
    #7  
    I just noticed this issue as well. Been syncing with Gcal for 6 months now and have never noticed it. Everything is off by one day, even Easter and some of my contacts Birthdays! I was looking into my Spring Break flight plans and noticed Easter was on a Saturday this year LMAO! Some hourly problems are occurring too, moved my Friday classes to 7AM instead of 8AM (that is just not cool, 8 is early enough!)

    Would like to the solution but I'm getting a Hero in a few days, so it's not the end of the world. Might keep the Pre another month or so just in case we get some real solid updates for a change.
  8. Clcto's Avatar
    Posts
    104 Posts
    Global Posts
    142 Global Posts
    #8  
    The case where annual all-day recurring events show as two days, or are off by one day, is apparently a DST issue. It started showing when Daylight time ended Nov 4th, and presumably goes away when it Daylight time begins in March.

    The solution is to override the automatic time zone setting from the carrier on the Pre/Pixi phone. Go to the carrier settings and set time zone updates to manual. Also correct your time zone, as you'll note it is one hour off.

    Then resync everything from your data source. This should clear all cases where annual recurring all-day events show as two days, or show on the wrong day.

    Wayland Bruns, CTO
    CompanionLink Software, Inc.
    www.companionlink.com
  9. #9  
    Quote Originally Posted by Clcto View Post
    The case where annual all-day recurring events show as two days, or are off by one day, is apparently a DST issue....
    Thanks Wayland. I actually just figured this out on my own yesterday. My problem was that even though my Pre was set to use network time, it could never get it. It was also set to a Central Time zone somewhere in Canada (can't recall where) rather than Chicago as it should have been. As soon as I mannually changed it to Chicago, all of the "All Day" events started showing up on the correct date.
  10. timmo's Avatar
    Posts
    98 Posts
    Global Posts
    167 Global Posts
    #10  
    I've been having these same issues as well for several of my events in Google Calendar. They are 1 day off for some reason, but if I look at Google Calendar in the browser, the correct day shows for each of the troubled events! Makes no sense whatsoever. So I now pull up Google Calendar in the browser on the Pre to see my calendar events instead of using the built in Pre calendar (thanks, Palm). This is ridiculous. How can Palm have so many issues with the Calendar application?! So frustrated.

    I tried the above suggestions about the time zone, etc. settings; but it does not help in my case. Many of my events are still 1 day off. I don't understand...

    Palm...PLEASE re-write the Calendar application from scratch so that it matches the Android OS. An event in Google Calendar should equal the event in Palm Pre Calendar! There continues to be major sync issues between WebOS and Google.
  11. #11  
    Quote Originally Posted by timmo View Post
    So frustrated.

    I tried the above suggestions about the time zone, etc. settings; but it does not help in my case. Many of my events are still 1 day off.
    QFT. Applies mostly to my friends' birthdays, as these are about the only annually-recurring all-day events on my calendar. The manual timezone move didn't work, the Airplane mode on-then-off trick didn't fix it, and I'm done constantly deleting events only to type them in again.

    Just about the time I learn to look one day ahead Palm'll actually fix the problem....
  12. timmo's Avatar
    Posts
    98 Posts
    Global Posts
    167 Global Posts
    #12  
    One theory I have that might be causing this problem is when timed and un-timed events have an alarm set: when the Pre shows the alarm on the phone and I hit "Dismiss", for some reason I think the "ownership" of this event changes from Google Calendar to Palm's calendar app. So in other words if I subsequently change the event at all on Google Calendar in a standard web browser on a computer (e.g. I move the event to the next day or any other change to that same event), the Pre "ignores" the change that I made and leaves it where it is on Pre's calendar.

    Also, I still have problems where all-day events for some reason have an alarm set on them so that at 11.50pm each night, my phone goes off with an alarm for each of the events! This happens to about 80% of my all-day events, and I have no idea why or how this occurs. In Google I always make sure to not have an alarm set on all-day events...so somehow the Pre's calendar is taking SOME of those events and assigning an alarm to them.

    Furthermore, I wonder if anyone has any issues using Yahoo's calendar with the Pre. Just wondering if this is strictly a Palm/Google issue, or if this extends to Yahoo as well. I think Google and Yahoo are the only choices so far to sync calendar and contacts.
  13. #13  
    Setting timezone manually worked for me and my wife. Thanks again. We should probably sticky this!
  14.    #14  
    Quote Originally Posted by nbock01 View Post
    Setting timezone manually worked for me and my wife. Thanks again. We should probably sticky this!
    I think the update to 1.3.5.1 fixed this?
    "Aggies never lie cheat or steal, nor tolerate those who do."
  15. #15  
    I am having problem with my google calendar sync. The calendar is fine on google site. Only the last five months are showing up on the pre. I am using the Google calendar search, works great, but points to blank pages on the pre. I have 4 years worth on the google calendar. Why am I getting only the last 5 months? Thanks for your help. Paul
  16.    #16  
    Quote Originally Posted by glasspaul View Post
    I am having problem with my google calendar sync. The calendar is fine on google site. Only the last five months are showing up on the pre. I am using the Google calendar search, works great, but points to blank pages on the pre. I have 4 years worth on the google calendar. Why am I getting only the last 5 months? Thanks for your help. Paul

    I know there is a setting in webos for that somewhere, I'd look it up but my pre is dead try going to open the calendar app, click on the menu button on the top left, prefferences and accounts, then select the specific account you wat to sync all the info, then look for a time span setting. I'll try to look into it later if you can't get it to work.
    "Aggies never lie cheat or steal, nor tolerate those who do."
  17. #17  
    Quote Originally Posted by nbock01 View Post
    Setting timezone manually worked for me and my wife. Thanks again. We should probably sticky this!
    It worked for me too, thanks for the help everyone, particularly Weyland!
    It should definitively be sticky!

Posting Permissions