Results 1 to 15 of 15
  1. gryn's Avatar
    Posts
    148 Posts
    Global Posts
    158 Global Posts
       #1  
    Try this if you have problems syncing Gmail.

    To setup Google Sync (Push) via Exchange

    1. Delete all google accounts (IM, email, calendar, contacts). It'll say that you already have an account if you don't.

    2. Add a new email account in the Email app prefs.

    3. In the new email page open the prefs/email drop down in the top left and select 'Manual Setup'

    4. Enter the following:

    Mail Type: EAS
    (the following fields show up after selecting EAS)
    Email Address: Your @gmail.com
    Domain: leave empty
    Username: Your @gmail.com
    Password Your gmail pass

    5. Go do 5 sets of 10 pushups for the good of humanity while you wait for Contacts and Calendar to sync.

    Now you should have instant updates to and from Google for Gmail, Contacts, and Calendar.

    __________________________________________________________________________

    If you have multiple Google Calendars

    You will need both the new Google Sync account and the regular Google one.

    -Add a new email account for Gmail, the normal way.
    -Wait for the sync to finish.
    -Delete this new account we just created from the Mail app.
    -Delete this new account from Contacts app.

    You should now have the EAS account from above for the 3 apps and the extra normal google account in Calendar.




    Now edit the calendar options.

    -Set the EAS/Google Sync account as your default.

    In Calendar View Options
    -Make both calendars with your @gmail the same color
    -Disable the calendar that says only your email not the one that says 'EAS' 'Exchange' or 'Google Sync' or whatever else you named it.



    Done. Now you have all your calendars in the calendar app and edits to the default calendar are instantly pushed.


    Things you should know
    -Sync does not work if you have web google open and waiting for updates, i.e., testing it.
    -Deleted emails are Archived. (Sent to 'All Mail')
    -Contacts without a name are set as "Unknown" even if they have a business name.
    -You can't selectively delete the new accounts. Deleting one, deletes all.
    -Contact handling still needs to be tested for this to be a solid alternative to the regular
    -Sadly, it works sporadically. Google issue.

    Downsides
    -Obviously, the fact that Google Sync only allows 1 calendar for the Pre (they gave apple 15) which is why you need the calendars fix above.
    -Battery drain. Not that bad, but it hurts since you've tried your hardest to conserve battery.
    -Google icons are all replaced by bland exchange icons.
    Last edited by grynv; 12/04/2009 at 04:53 PM. Reason: Revised and added pictures.
  2. a2k
    a2k is offline
    a2k's Avatar
    Posts
    103 Posts
    Global Posts
    111 Global Posts
    #2  
    This is all great, but why not just use your Gmail account and set it to fetch as items arrive, resulting in the same?

    I'm a bit confused, what's gained by setting up two accounts in this manner?
  3. gryn's Avatar
    Posts
    148 Posts
    Global Posts
    158 Global Posts
       #3  
    Lots of people don't like waiting for their Calendars and Contacts to sync with google, sometimes they never do.

    This is push for both of those.
    I haven't seen any syncing issues with this method like the hundreds listed if you press your back button. The only problem i've found is battery life and i'm busy working on powersave to test this out.

    If people would test this for me it would fix everyones sync problems AND add push.

    But if the battery toll is too much then it wouldn't be too great a fix on our crappy batteries.

    Two accounts is only a fix if people have multiple calendars on google
  4. #4  
    This worked for me. Before I my pre would not send contact information tto gmail when entering new informaiton. It would however retreive the data ok from gmail during the sync process.

    The only issue I am having now is sync the calendar but mail/contacts work fine.
  5. #5  
    does this fix the issue of contacts... I have several contacts that are in my gmail that are not in my pre. or not all the contact information is there, the 4th, 5th and 6th phone number is not showing.
  6. TeGe's Avatar
    Posts
    8 Posts
    #6  
    I have the same issue - sync from pre to google works fine - but sync from google to my pre doesn't work after upgrade to 1.3.1.
    I try varios things:
    Delete google account on my pre, remove battery, create new account, sync - nothing happens.....
    delete all contacts from google profile, delete google account on my pre, sync - nothing happens.....
    But no one could help me fixing bthis problem.
    TeGe
  7. TeGe's Avatar
    Posts
    8 Posts
    #7  
    hi guys,

    in the german Nexave Palm forum I found the solution for the sync problem:
    After upgrade to 1.3.1. only "my contacts" from google will sync to the Pre.
    So add all your Google contacts to "my contacts" and they will sync as befor the upgrade.

    Thomas
  8. #8  
    I've set up multiple accounts to use Google Sync. I'll see how the battery life is impacted compared to having them set up as IMAP with PUSH.

    The primary reason I am doing this is my google calendar would no longer sync repeating events. All the singular ones synced just fine though :/
  9. gryn's Avatar
    Posts
    148 Posts
    Global Posts
    158 Global Posts
       #9  
    Quote Originally Posted by ryltar View Post
    I've set up multiple accounts to use Google Sync. I'll see how the battery life is impacted compared to having them set up as IMAP with PUSH.

    The primary reason I am doing this is my google calendar would no longer sync repeating events. All the singular ones synced just fine though :/
    Thanks.
    Google currently has no support for this method and they don't show the difference between the usual way of adding google accounts and this one.
    I'm gonna try this again now that I have time.

    Also, on my first trial it felt like it was constantly fetching which completely defeats the purpose.
    I'll try letting it run for a couple hours, maybe it was just prolonged syncing of some sort.
    Last edited by grynv; 12/02/2009 at 04:48 PM.
  10. gryn's Avatar
    Posts
    148 Posts
    Global Posts
    158 Global Posts
       #10  
    Quote Originally Posted by cglaguna View Post
    does this fix the issue of contacts... I have several contacts that are in my gmail that are not in my pre. or not all the contact information is there, the 4th, 5th and 6th phone number is not showing.
    I'll try this as well.
  11. jp22382's Avatar
    Posts
    355 Posts
    Global Posts
    418 Global Posts
    #11  
    Thanks, this has been the only thing that has fixed my Gmail push so far (short of running WebOS Doctor).

    I'll keep an eye on my battery use.


    EDIT:

    My calendar was locking up, a reboot seemed to fix that.

    Smooth sailing on all fronts so far.
    Last edited by jp22382; 12/02/2009 at 05:50 PM.
  12. #12  
    I haven't had issues yet. It is functioning just as a Exchange account would. The only issue with it is that when I delete something it actually goes to the all mail folder instead of being deleted.
  13. #13  
    I've been using this method now since Mon - tuesday and I would say it does have a minimal impact on the battery life. I noticed when I get home from work my phone is in need of a charge or it will die before I go to bed. Normaly a full charge would last the whole day. A small draw back to have my contact properly syncing
  14. gryn's Avatar
    Posts
    148 Posts
    Global Posts
    158 Global Posts
       #14  
    Quote Originally Posted by cglaguna View Post
    does this fix the issue of contacts... I have several contacts that are in my gmail that are not in my pre. or not all the contact information is there, the 4th, 5th and 6th phone number is not showing.
    Try cleaning up your Google Contacts.
    Everything not in "My Contacts" will not sync.
    Last edited by grynv; 12/04/2009 at 04:28 PM.
  15. #15  
    I had a similar issue - Yellow icon, and Gmail wasn't PUSHing alerts using "as items arrive" or any other timer. It started after I installed a bunch of apps from Preware.

    I uninstalled a few that I thought might be causing the issue and it seems removing the following apps fixed the issue:

    Unthrottle download manager v1.3.1-0 diomark - Removing this seemed to get rid of the yellow alert icon (but phone still would not check email except manually)
    Charging Alert Vibrate Only v1.3.1-0 a2ny - Removing this seems to have fixed IMAP PUSH


    If you have these installed try removing them and see what happens.
    Cheers
    Last edited by Dreadnought; 12/08/2009 at 03:05 PM.

Tags for this Thread

Posting Permissions