Results 1 to 11 of 11
  1.    #1  
    Have a weird problem with the Google contacts sync.

    - Syncing from Google->Pre works fine.
    - Deleting a contact on the Pre removes it from Google
    - Inserting a contact on the Pre adds it to Google
    - But updating an existing contact on the Pre doesn't work... the changes aren't propagated to Google. (As noted; updating a contact on Google works fine; the changes are synced down)

    I've tried all the standard stuff.. reseting the Pre; removing and readding my Google profile, etc. No dice. Calendar stuff works fine too; its just contacts

    Any ideas?
  2.    #2  
    So an interesting update on this... I'm also syncing my contacts to Apple's Address Book, using the built-in sync on OS X 10.6.1 Snow Leopard. It seems that the problem only occurs with contacts that have been created or modified by Address Book.... If I create a contact on Google (or the Pre); updates work fine. If I create it in Address Book, or if I create it somewhere else and modify it in Address Book, the Pre->Google sync stops working.
  3.    #3  
    Quick update on this: while the native google contact sync is broken, using gmail's Exchange sync support does work. Here's how to enable it; check sswany's post on the Gmail help forum for details:

    - Setup up Gmail normally in Messaging. It'll add Gmail as the Contact source also
    - Go into Contacts and remove the Gmail contact source (this only removes it from Contacts, not from messaging).
    - Add a new account to Contacts (menu > preferences & accounts > add account)
    - Add an Exchange account (Gmail has an Exchange protocol open for iPhones)
    - Since the Pre will show an error if you try to use the same email address, add a "." somewhere in the address. Gmail ignores periods in email addresses but it will fool the Pre into thinking it's a 2nd email address
    - Use "Exchange (EAS)" for the mail type
    - Use your email address with a "." in it (ex. "u.ser@gmail.com" rather than "user@gmail.com")
    - Use "https://m.google.com" for incoming mail server
    - Leave domain blank
    - Use your normal user name without the periods (ex. "user")
    - Hit "Sign In"

    This also has the side benefit of syncing only 'My Contacts' rather than 'All Contacts', which keeps your contact list a little shorter.

    Hopefully Palm can fix the bug in the native Google Sync in a future webOS update
  4. #4  
    I've never had a problem with the native Google sync in the sense that you're describing? My sync has always worked (google > Pre and vice versa) since launch day. Was one of your contacts bugged?

    Also, going from Outlook to Pre and vice-versa has also worked since I've added the Outlook account.

    I've seen the "My Contacts" method on the Palm forums and it looks promising if you don't want ALL your contacts synced. I've yet to try it but if my current contacts list gets any larger, I might use that method.
    Achill3s' Palm Pre: Modded and patched to death!!
  5. #5  
    Hi Dordal,

    I'm new here (just got my Pre this past weekend), but I ran into a similar problem.

    I believe, at least in my case, that the palm profile was causing such issues - or restricting the sync functionality. I did not want to create another account like others have mentioned since it is just one more account to manage.

    Since I had my phone numbers transferred to my Pre, they were auto assigned to the 'Palm Profile' account. I have since added a Google account which pulled in all my Gmail contacts. However, it would sync Google >> Pre, but not Pre >> Google if a contact had a shared profile (Palm Profile and Google Account info for 1 contact). I also noticed that when creating a new contact on the Pre it would sync to Google (default account profile would revert to the google account profile).

    What I did was move a contact's phone number from the palm profile to the Google profile and remove the Palm Profile from that contact (phone, address, etc would be saved in the Google Account Profile). After I did that the sync worked both ways. I would just suggest you backup or take note of contacts when you delete them since I'm sure you don't want to accidentally lose a contact.

    Hope this helps.
  6. #6  
    I have the same problem as the OP--also using snow leopard with address book syncing...it originally started just prior to the 1.2 update...after the 1.2 update, still had the problem briefly, but then my phone crashed (lost connection to palm profile)...after, re-connected to the palm profile, re-added all accounts, didn't have the problem until about last week...not sure if this is related to the pending 1.3 update that is causing this problem. I would really like to avoid deleting/re-adding the account b/c I have to change all the pics back to the full size, then re-assign my ringtones, which I find pretty annoying. I'm tempted to try the Exchange method, but noticed others were saying it double some contacts and calendar events...don't want to mess with that right now either. OP, are you finding this duplication problem? Is the address book syncing still working? I'm tempted to just wait for 1.3 to see if it fixes the problem.
  7. #7  
    So 1.3 didn't fix the problem, according to another thread it may be something snow leopard broke if syncing the address book to gmail contacts. Think apple went after palm for itunes and intentionally broke it??? More importantly, anyone find a fix??
  8. #8  
    temporary solution: back up google contacts via export to csv. delete google contacts. go to address book in mac, change preference of vCard settings to 2.1 instead of 3.0. import contacts back to google. Delete google account on phone, re-add on phone. Now changes made on google or phone show up on the other. DO NOT MAKE CHANGES IN ADDRESS BOOK ON YOUR MAC...this prevents future changes for that contact on the phone from uploading to gmail. However, it still syncs with gmail and your phone when changes are made to either (so it basically works as a back up). This solution does not seem to be 100% though, after a few changes on contacts on either gmail or your phone, the syncing seems to only work intermittently for whatever reason (yes, I wasted lots of time testing). However, it does work for the most part.

    Of course as you are deleting contacts with this temporary fix, be very careful and backup properly
  9. Kamen's Avatar
    Posts
    106 Posts
    Global Posts
    318 Global Posts
    #9  
    I have the same issue, but it isn't with a Mac. I got my replacement Pre last night and added my Gmail accounts back, but they failed to import any of my contacts information. The only accounts that Synced properly were my Facebook contacts.

    I tried a similar version of the resolution above. I exported my contacts in Gmail, deleted them, and added them back. After a Sync it doesn't update anything.
    Last edited by Kamen; 11/17/2009 at 07:31 AM.
  10. Kamen's Avatar
    Posts
    106 Posts
    Global Posts
    318 Global Posts
    #10  
    Quote Originally Posted by dordal View Post
    Quick update on this: while the native google contact sync is broken, using gmail's Exchange sync support does work. Here's how to enable it; check sswany's post on the Gmail help forum for details:

    - Setup up Gmail normally in Messaging. It'll add Gmail as the Contact source also
    - Go into Contacts and remove the Gmail contact source (this only removes it from Contacts, not from messaging).
    - Add a new account to Contacts (menu > preferences & accounts > add account)
    - Add an Exchange account (Gmail has an Exchange protocol open for iPhones)
    - Since the Pre will show an error if you try to use the same email address, add a "." somewhere in the address. Gmail ignores periods in email addresses but it will fool the Pre into thinking it's a 2nd email address
    - Use "Exchange (EAS)" for the mail type
    - Use your email address with a "." in it (ex. "u.ser@gmail.com" rather than "user@gmail.com")
    - Use "https://m.google.com" for incoming mail server
    - Leave domain blank
    - Use your normal user name without the periods (ex. "user")
    - Hit "Sign In"

    This also has the side benefit of syncing only 'My Contacts' rather than 'All Contacts', which keeps your contact list a little shorter.

    Hopefully Palm can fix the bug in the native Google Sync in a future webOS update
    I just tried it and it didn't work for me. Boo!
  11. #11  
    Quote Originally Posted by Kamen View Post
    I have the same issue, but it isn't with a Mac. I got my replacement Pre last night and added my Gmail accounts back, but they failed to import any of my contacts information. The only accounts that Synced properly were my Facebook contacts.

    I tried a similar version of the resolution above. I exported my contacts in Gmail, deleted them, and added them back. After a Sync it doesn't update anything.
    did you try exporting from gmail, deleting BOTH gmail contacts and your gmail of your contacts on the pre, then importing back into gmail, and re-adding the gmail account into the contacts into the pre?

Posting Permissions