Results 1 to 11 of 11
  1.    #1  
    Hi All,

    I just got my Pre last week and (not surprisingly) am having problems setting up an EAS account.

    I have the following information available:

    1) OWA website
    2) IP address of exchange server
    3) Domain
    4) Username and Password

    I can sync my Pre to my exchange account (calender and email) only when I am connected to my work WIFI. If I turn off WIFI or am using the Pre at home, I cannot connect to the exchange server. If I try to set up the account with WIFI turned off, I get the "unable to verify server settings" error. I can only set it up when I am connected to my work WIFI.

    Can somebody help me out with this? Is it something I am doing wrong or is it something that needs to be changed on the server side?

    Thanks
  2. #2  
    You need to have an externally accessible domain name for your exchange server, and it has to be published through your firewall.

    Inside your work wifi it's probobly exchange.domain.local. You will not be able to resolve that address over 3g. Your IT guy should be able to give you the external name, like exchange.domain.com.

    I would bet for the IP address of your exchange server you put in something like "192.168.0.25" which is not an internet accessible IP.
  3.    #3  
    Thanks for the reply.

    The IP address I tried is "7x.2x.5x.104" - I would think this is an internet accessible IP as I retrieved it from home when connecting to my exchange server through the MS Exchange Analyzer.

    My OWA website is: https:\\mail.COMPANYNAME.com\exchange - so for the server, I used https:\\mail.COMPANYNAME.com

    I was under the impression that these are external names, am I wrong?

    Our IT is outsourced and he only gave me the OWA website when I asked him about this. He said if that didn't work then he would have to come in and bill us for 2 hours to fix it. I want to see if I can get it to work before he comes in.
  4. #4  
    Sounds like a public IP address.

    you have the wrong slashes in your URL, should be a "/" not a "\".

    Next list of suspects is the certificate. Certificates are dependant on the server's name, which could vary from inside or outside your network (wifi vs 3g). When you access OWA from a PC, do you get a security or certificate warning? If so, your Pre will have problems with active sync unless you install the certificate onto your pre.
  5.    #5  
    Yeah, i always get the slashes mixed up when i type them out. they are correct in the Pre as I do not actually put them in, they are already there.

    As for the certificate - the certificate I installed comes from my home PC. This is what I did. I logged onto OWA from my home PC. I then "trusted" my certificate (is this what self-signed means?). I then copied my certificate from the PC onto the Pre using the USB cable. On the Pre, I installed the certificate using the certificate manager.

    I am not entirely sure it is an SSL certificate error as there is no mention of the certificate in the error message. It says it cannot verify (or validate, not sure) my incoming mail server settings. If I change the server address, then it just says, it cannot connect to the server

    thanks for your help so far.
  6. #6  
    You seem to be on the right track.

    Try going to your OWA address on your pre over 3g. See if you get a certificate/security warning.

    If the certificate is set to be for mail.domain.local, i'm afraid you will not be able to get it to work at all over 3g. If that is the case, your certificate will have two problems.
    1. it's not signed by a trusted authority (copying the cert and installing it will get around this)
    2. it's assigned to a server that has a different name then you are connecting to. (mail.company.local instead of mail.company.com)

    The only way to fix problem 2 is to install a new cert on your exchange server.
    You can see the name on the certificate by opening it with IE by clicking the lock in the address bar. It will tell you the name of the server.
  7.    #7  
    So I was thinking along the same lines as you. When I open up the certificate on the PC, it is called mail.company.com. When I then copy it to a file and send it to my Palm, it changes to main.company.local.

    If I am understanding you correctly, the only fix for this would be to get the IT guy to come in and install a new certificate on the server? What would I be telling him and how long would this take? His estimation was 2 hours of billing time.
  8. #8  
    re-save the certificate. Or if you want, pm me the real address to the site and i'll look are your cert and be able to tell for sure if your cert is the problem.
  9. murmler's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #9  
    If the certificate of the exchange server is self signed, then be sure that you have installed the certificate of the CA of which the webserver certificate was issued.

    On the other hand...if you can access within the LAN, then it doesn't seem to be a matter of certificates. How is your exchange server published? Do you use ISA Server? Could also be a firewall problem.
  10. #10  
    If you go to the OWA site in the Pre's browser does it display a certificate warning? If it works in the browser the certificates should be configured correctly for email too, meaning it's probably some other problem.
  11. #11  
    DiscoMonkey sent me the URL to his OWA. Looks like his /OMA site only allows access to it from local IP addresses, and is forbidding all internet IP's.

    Good news is looks like his certificate is good, and he took the right steps to save/import it onto his Pre.

Tags for this Thread

Posting Permissions