Results 1 to 11 of 11
  1. hopfrog's Avatar
    Posts
    121 Posts
    Global Posts
    136 Global Posts
       #1  
    Like many people, I use have a few email addresses that are forwarded to my Gmail account. I have a university (.edu) account, for example.

    One of the reasons I switched to Gmail was that it lets choose which address appears as the one I've sent my email from. Gmail can send email and have the "from" field be my .edu address, for example, if I set it that way, letting me control what "from" address the recipients of my emails see. However, when I use the pre, my gmail address *always* appears in the "from" (although it does let me change the "reply to" address).

    This is a problem, since I don't want everyone to have or know my gmail address. I imagine that many people often use gmail to reply via business or .edu addresses, etc.

    I can always long into the gmail mobile site to send emails from there, but it would be great if I didn't lose this feature when using the pre to interface with Gmail.

    Is there any way around this? Or any hope it will get fixed, so that the pre email will not ignore Gmail's setting about what address should appear in the "from" field in emails I send?

    Thanks for any help.
  2. #2  
    i doubt it will get fixed, i dont know of any email client that will work with that feature.

    the only work around, is to create a new account on the pre to fetch the other email, and set it for manual fetch.
    Felipe
    On the road to 5,000 posts
    Life is what happens between Firmware releases.
  3. #3  
    Yeah that would be a nice addition but like Felipe already said, these are not "standard" features and even the G1 lacks them.
  4. #4  
    There is a fix but it has a downside.

    The Fix:
    For each email address that you use in gmail, you manually enter a new account -- put the address for which you use the gmail system in the reply-to address field. Then use the following settings:

    Incoming Server: imap.gmail.com
    User name: your gmail address
    Password: your gmail password
    Port: 993
    Encryption: SSL

    Outgoing Server: smtp.gmail.com
    Use Authentication: On
    User name: your gmail address
    Password: your gmail password
    Port: 465
    Encryption: SSL

    The Downside:
    When you get an email in your gmail account, you will receive it for each of the alias accounts. So if you use 4 different addresses through the gmail system, you will have set up a separate account for each one and you will get the email 4 times -- even if the accounts are set to manual collection. Careful, if you erase an email out of one, it disappears from all of them.

    I got around this by disabling the "All Inbox" and using the individual inboxes, which can be starred and moved to favorites category. A drag but definitely worth it to be able to send from Pre using any of my 4 email addresses.
  5. #5  
    BTW: does anyone know how to set the pre to collect manually - and really do so?
  6. #6  
    I would love to have support for this. The OP stated the problem precisely.
  7. #7  
    If you use the fix that dianagr describes above, you can simplify things by using filters in Gmail. Set up a label for each email address and have all incoming messages to that address skip the inbox and move to the label.

    Then set that label as a favorite "folder" on the Pre (using the appropriate account you set up for that label's email address). You will then see the emails in only one place (Inbox for Gmail and favorite folder for other emails). Then replies should work as dianagr set-up implies.

    You can then tweak how you delete the emails, move to a different label. I haven't tried this, but it seems like a work-around. Let me know if this works.
    Palm Vx, Treo 300, Treo 600, Treo 700p, Treo 755, Palm Pre
  8. #8  
    Quote Originally Posted by hopfrog View Post
    Like many people, I use have a few email addresses that are forwarded to my Gmail account. I have a university (.edu) account, for example.

    One of the reasons I switched to Gmail was that it lets choose which address appears as the one I've sent my email from. Gmail can send email and have the "from" field be my .edu address, for example, if I set it that way, letting me control what "from" address the recipients of my emails see. However, when I use the pre, my gmail address *always* appears in the "from" (although it does let me change the "reply to" address).

    This is a problem, since I don't want everyone to have or know my gmail address. I imagine that many people often use gmail to reply via business or .edu addresses, etc.

    I can always long into the gmail mobile site to send emails from there, but it would be great if I didn't lose this feature when using the pre to interface with Gmail.

    Is there any way around this? Or any hope it will get fixed, so that the pre email will not ignore Gmail's setting about what address should appear in the "from" field in emails I send?

    Thanks for any help.
    open the gmail program on your pre
    go to preferences and accounts
    press teh gmail account
    now where it says Full name, just type in the address you want to show and that will show in your from address.
    it works perfectly.
  9. #9  
    Quote Originally Posted by hi-tech34 View Post
    open the gmail program on your pre
    go to preferences and accounts
    press teh gmail account
    now where it says Full name, just type in the address you want to show and that will show in your from address.
    it works perfectly.
    Except that when you are sending from other-than gmail accounts, they don't get saved in your gmail online.

    On my old Windows Treo, you could go to gmail online (mobile version) and choose the send-from account, but you can't do that anymore with the Pre.

    bummer. I'm finding more and more things that Palm stepped backwards on.
  10. #10  
    I set up two accounts on my Pre: one for gmail, and one for the account that forwards to gmail (like your .edu account). I set up the gmail account as IMAP/as they arrive, and the other account as manual sync. I only look at the gmail account. The inbox for the other account is not in my favorites section and I set 'all inboxes' off, so I don't see the other account unless I'm purposely looking for it. I set up the other account as my default account so when I create a new email it defaults to using my non-gmail address. If I reply to an email in gmail, or create a new email in my gmail account, I manually change the From field to my non-gmail account. Other than that manual workaround, it works great for me. I expect it would work for multiple forwarding accounts. Another side effect: outgoing messages sent using the other account do not show up in your gmail 'sent mail' folder.
    "The service on my iPhone is so bad I'm thinking of calling it my AOL phone." -- Jim Gaffigan

  11. #11  
    Quote Originally Posted by monkeydog View Post
    I set up two accounts on my Pre: one for gmail, and one for the account that forwards to gmail (like your .edu account). I set up the gmail account as IMAP/as they arrive, and the other account as manual sync. I only look at the gmail account. The inbox for the other account is not in my favorites section and I set 'all inboxes' off, so I don't see the other account unless I'm purposely looking for it. I set up the other account as my default account so when I create a new email it defaults to using my non-gmail address. If I reply to an email in gmail, or create a new email in my gmail account, I manually change the From field to my non-gmail account. Other than that manual workaround, it works great for me. I expect it would work for multiple forwarding accounts. Another side effect: outgoing messages sent using the other account do not show up in your gmail 'sent mail' folder.
    Right, sorry, this is what I do - but again, it doesn't save it on your gmail "Sent" archives, which is important to me because I can't always remember what I told people... workaround is to add your own address in the To: category, so at least it'll be saved/archived in your gmail.

Tags for this Thread

Posting Permissions