Results 1 to 15 of 15
  1.    #1  
    I was able to configure my Pre for our work email. I did everything I had done (without a glitch) on my HTC touch pro. The Pre did connect and accept the new account, however it only has an "outbox" and that is it. It is not syncing or anything. I tried the testexchangeconnectivity.com but had an error.
    It read:

    Http Authentication Test failed
    Additional Details
    An HTTP 500 response was returned from ISA

    I don't know what it could be? Our Iphones and my HTC here at work connected without even a hiccup. Any ideas?
  2. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
    #2  
    HTC is WinMO 6.0.

    Pre is Palm WebOS.

    iPhone, well it's been around long enough it ought to be blowing you nose and getting coffee by know. There should be an app for that.

    Have you confirmed what/how to config. it? The update did make a change to fix or make something work better with EAS (article posted in a thread or 2). I've not done it or heard of anyone configing one so I can't help.
  3. #3  
    Quote Originally Posted by clifsmith View Post
    I was able to configure my Pre for our work email. I did everything I had done (without a glitch) on my HTC touch pro. The Pre did connect and accept the new account, however it only has an "outbox" and that is it. It is not syncing or anything. I tried the testexchangeconnectivity.com but had an error.
    It read:

    Http Authentication Test failed
    Additional Details
    An HTTP 500 response was returned from ISA

    I don't know what it could be? Our Iphones and my HTC here at work connected without even a hiccup. Any ideas?
    I would delete the account and try again. I also used to have problems setting it up but was fixed in the 1.0.4 update.
  4. #4  
    Did you download your company's certificate?
    no 'Thanks'
  5. JKTex's Avatar
    Posts
    376 Posts
    Global Posts
    487 Global Posts
    #5  
    Not sure it this will help but may be noteworthy.

    Palm webOS gains enterprise features - Network World
  6. Neitzl's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #6  
    Are you sure you have the right certificate for your account? I maintain an exchange server, with a self signed certificate, and in order to have my palm retrieve email and sync calendar/contacts, I had to install my self-signed Certificate.
    I also only had an "Outbox" but once the cert was installed, mail began to flow. Ask your sys admin if you need to install such a certificate, or if the certs from a 3rd party vendor (Verisign, GoDaddy), you might need some other settings.

    Good luck
    Ernesto
  7.    #7  
    Quote Originally Posted by Neitzl View Post
    Are you sure you have the right certificate for your account? I maintain an exchange server, with a self signed certificate, and in order to have my palm retrieve email and sync calendar/contacts, I had to install my self-signed Certificate.
    I also only had an "Outbox" but once the cert was installed, mail began to flow. Ask your sys admin if you need to install such a certificate, or if the certs from a 3rd party vendor (Verisign, GoDaddy), you might need some other settings.

    Good luck
    Ernesto
    Thanks Ernesto. Is this self-signed certificate something I install on my Pre and nothing else. Our IT department will do nothing for me if it needs to be installed on their server too. They are like Nazi's. Where do I get it and how do I install it?
  8. Neitzl's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #8  
    clifsmith,

    The easiest way to get the certificate is:
    Open Internet Explorer --> Tools --> Internet Options --> Content Tab --> Certificates --> Trusted Root Certification Authorities.

    Once you're there, look for your company's name or a server that is from your company. For me, My Cert Authority is "Raymond", so I looked for that name. If you find it, highlight it, and click Export. Follow the prompts, keep the format as the default (.cer). Save the file in a place you'll find easily (desktop most likely). Once the file has been exported, put it in your Pre (connect pre to computer via USB. Choose USB drive when prompted on Pre). I usually put my .cer files in the downloads folder on the Pre.

    Eject Pre from computer. On the Pre, go to
    Device Info --> More Info --> Click on Preferences (upper left) --> Certificate Manager.
    Here you need to hit the + button (bottom left), and install the certificate. It's pretty easy, really!

    Hope that helps.

    Ernesto

    btw, this should be done at your work computer. I'm assuming you're using Outlook/Exchange 2007 too.
  9.    #9  
    Are you sure that it is a certificate issue? I ask this because when I ran the connectivity test, it came back as saying SSL certificate was successful. Here are the results of the test. Also, I followed your instructions and found many certificates including "godaddy" and many others relating to our corporate structure. Should I just install them all? Also, I tried going in to our webmail (which is the server that the phone connects to) with my computer to see which certificate is being used and it said "Verisign class 3 public primary CA". I can't find this one in the root.


    test results:

    Testing Exchange Activesync for host https://xx.webmail.xxxxxxxxx.com/Mic...er-Activesync/
    Exchange Activesync test Failed
    Test Steps
    Attempting to Resolve the host name xx.webmail.xxxxxxx.com in DNS.
    Host successfully Resolved
    Additional Details
    IP(s) returned: xxx.xxx.xx.xxx

    Testing TCP Port 443 on host xx.webmail.xxxxxxxx.com to ensure it is listening/open.
    The port was opened successfully.

    Testing SSL Certificate for validity.
    The certificate passed all validation requirements.
    Test Steps
    Validating certificate name
    Successfully validated the certificate name
    Additional Details
    Found hostname xx.webmail.xxxxxxxx.com in Certificate Subject Common name

    Validating certificate trust for Windows Mobile Devices
    Certificate is trusted and all certificates are present in chain
    Additional Details
    Certificate is trusted for Windows Mobile 5 and Later platforms. Root = OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US

    Testing certificate date to ensure validity
    Date Validation passed. The certificate is not expired.
    Additional Details
    Certificate is valid: NotBefore = 5/27/2008 5:00:00 PM, NotAfter = 5/28/2010 4:59:59 PM



    Testing Exchange Activesync for host https://xx.webmail.xxxxxxx.com/Micro...er-Activesync/
    Exchange Activesync test Failed
    Test Steps
    Attempting to Resolve the host name xx.webmail.xxxxxx.com in DNS.
    Host successfully Resolved
    Additional Details
    IP(s) returned: xxx.xxx.xx.xxx

    Testing TCP Port 443 on host xx.webmail.xxxxxxx.com to ensure it is listening/open.
    The port was opened successfully.

    Testing SSL Certificate for validity.
    The certificate passed all validation requirements.
    Test Steps
    Validating certificate name
    Successfully validated the certificate name
    Additional Details
    Found hostname xx.webmail.xxxxxxx.com in Certificate Subject Common name

    Validating certificate trust for Windows Mobile Devices
    Certificate is trusted and all certificates are present in chain
    Additional Details
    Certificate is trusted for Windows Mobile 5 and Later platforms. Root = OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US

    Testing certificate date to ensure validity
    Date Validation passed. The certificate is not expired.
    Additional Details
    Certificate is valid: NotBefore = 5/27/2008 5:00:00 PM, NotAfter = 5/28/2010 4:59:59 PM



    Testing Http Authentication Methods for URL https://xx.webmail.xxxxxxx.com/Micro...er-Activesync/
    Http Authentication Test failed
    Additional Details
    An HTTP 500 response was returned from ISA
  10.    #10  
    Thanks for your detail instructions. I am attaching the results of my test which shows that the SSL certificate passed, then a failure occured on the ISA authentication. Are you sure this is self signed certificate related? Please note that below I put "x" in the place of our server address so people would not see our corportate server info.


    Testing Exchange Activesync for host https://xx.webmail.xxxxxxx.com/Micro...er-Activesync/
    Exchange Activesync test Failed
    Test Steps
    Attempting to Resolve the host name xx.webmail.xxxxxxx.com in DNS.
    Host successfully Resolved
    Additional Details
    IP(s) returned: xxx.xxx.xx.xxx

    Testing TCP Port 443 on host xx.webmail.xxxxxxx.com to ensure it is listening/open.
    The port was opened successfully.

    Testing SSL Certificate for validity.
    The certificate passed all validation requirements.
    Test Steps
    Validating certificate name
    Successfully validated the certificate name
    Additional Details
    Found hostname xx.webmail.xxxxxxx.com in Certificate Subject Common name

    Validating certificate trust for Windows Mobile Devices
    Certificate is trusted and all certificates are present in chain
    Additional Details
    Certificate is trusted for Windows Mobile 5 and Later platforms. Root = OU=Class 3 Public Primary Certification Authority, O="VeriSign, Inc.", C=US

    Testing certificate date to ensure validity
    Date Validation passed. The certificate is not expired.
    Additional Details
    Certificate is valid: NotBefore = 5/27/2008 5:00:00 PM, NotAfter = 5/28/2010 4:59:59 PM



    Testing Http Authentication Methods for URL https://xx.webmail.xxxxxxx.com/Micro...er-Activesync/
    Http Authentication Test failed
    Additional Details
    An HTTP 500 response was returned from ISA
  11. Neitzl's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #11  
    Well, it does look like your Exchange Certs check out. The problem is on the ISA server, which I don't know much about. But looking up the error gave this:
    An HTTP 500 was returned to ISA because the certificate on the published server doesn't match the name in the publishing rule

    Hope your techs can help you, but I think you said they aren't very helpful.

    Sorry I couldn't help,
    Ernesto
  12. #12  
    I tried Neitzl's advice and added a twist. When configuring the EAS settings I left the "Domain" field blank and for the Username I prepended the domain value (i.e. Domain = <empty>, Username = "abc/username", where abc = Domain). After that, the EAS sync worked after many hours of frustration.
    Last edited by ravenfan; 08/01/2009 at 04:07 AM.
  13. #13  
    Quote Originally Posted by ravenfan View Post
    I tried Neitzl's advice and added a twist. When configuring the EAS settings I left the "Domain" field blank and for the Username I prepended the domain value (i.e. Domain = <empty>, Username = "abc/username", where abc = Domain). After that, the EAS sync worked after many hours of frustration.
    Mad props, used your domain name trick and now it works!
    CTSLICK
    Rock ON!
  14.    #14  
    CTSLICK. THANKS!!!!!. After months without my email, this worked. Palm engineers you really need to take a look at the way Exchange server is configured.
  15. #15  
    I am having similar issues. My IT dept is no help as the phone is mine, and their stance is if it works fine(which co-workers with BB do) and if it doesn't tough. I am continually getting a "credential error" I have reentered my password, tried every domain/username trick I could find. installed the root cert on the phone, deleted and reinstalled the account on the phone multiple times, one partial erase and a visit to a sprint store, to try the account on a different Pre. Nothing worked. Last week emails were flowing fine and this week nothing. This all leads me to believe IT changed something and is just not going to be much help. Any suggestions or workarounds? And OWA does work on the browser but it is just a pain and not as convenient as the phones email.

Posting Permissions