Results 1 to 5 of 5
  1.    #1  
    I just got my Pre yesterday. Setting it up with my Kerio Mailserver was pretty easy. It also seems to work just fine. However, I do have a problem.

    After setting up my account, I noticed all email I send has "domain (email address)" in the From field. I would like to change the "domain" to my real name. Unfortunately, when I select Email > Preferences & Accounts > Exchange, there is no field that says "Full name" or anything that allows me to change the 'From' field in my email. Is this only possible in POP or IMAP? I have searched google, PreCentral, and EverythingPre to no avail.

    I appreciate any input.
  2.    #2  
    This behavior still exists on webOS 1.1. Although, it has changed. It now has my Palm Profile name in the 'From' field. However, I changed my Palm Profile name and readded the exchange account but it still has my old Palm Profile name.
    Last edited by Seedillume; 07/25/2009 at 10:57 AM. Reason: updated behavior
  3.    #3  
    I did a Partial Erase and signed into my account. Now it shows my new Palm Profile name.

    To summarize, webOS 1.1 started using my Palm Profile name instead of my domain name without the '.com' in the 'From' email field with my exchange account. If I want to change it, I have to change my Palm Profile name and to a Partial Erase on the Pre.
  4.    #4  
    I did find another problem.

    After sending a test email and looking at the header information, I see another problem.

    The Reply-To field is "Palm Profile Name" <email address>. The Return-Path is <email address>. Both are correct. However the From field is "Palm Profile Name" <Domain name without ".com" (email address)>. So the From field is still not formed correctly. Email clients such as Outlook, OWA, and possibly others don't seem to be bothered by the From field. However, I know someone with a Blackberry Curve with Sprint using the latest OS. When they reply, the To field is automatically filled with "Palm Profile Name" <Domain name without ".com">. Of course, that is not a valid email address.

    So now I am wondering if this a Blackberry or Palm problem. I suspect that it's still a Palm problem because the From field is still not formed correctly.
  5.    #5  
    The saga continues...with a happier ending.

    As previously stated, I am using a Kerio Mailserver. As of this post, Kerio doesn't officially support the Palm Pre. In order for the Pre to sync, I had to change the setting 'AllowUnsupportedDevices' from 0 to 1 in the mailserver.cfg file for the mailserver.

    Before v6.7, EAS always used email address of the user from Kerio Mailserver. In Kerio Mailserver 6.7 (which I updated to before syncing the Pre), they changed the behavior of the From field. Kerio changed this behavior because users wanted to use the email address defined in the mail client on the mobile device. If the user doesn't define a custom From address in Webmail or the mobile device, then EAS will use the email address on the account. Unfortunately, the Pre doesn't have a user configurable From field when using EAS. So I logged into the Kerio webmail and defined a custom From email address and it worked. Also, defining a custom From email address enables the Pre to use the name on the EAS account rather than the Palm account. However, the Reply-To field still uses the name of the Palm account.

    To summarize, EAS on the Pre doesn't have a user configurable From field. EAS on the Pre doesn't seem to be able to get the correct From email address from the mailserver and would apparently try and make up it's own email address for the From field but would fail to put the email prefix or domain suffix probably because the Pre isn't fully supported on the Kerio Mailserver. However, it can get the correct user name on the Kerio mailserver account. In the end, both of my problems involving the From field when sending email from the Pre would have been solved by defining a custom From address in the user account on the Kerio Webmail.
    Last edited by Seedillume; 08/08/2009 at 12:36 PM.

Posting Permissions