Results 1 to 7 of 7
  1.    #1  
    Less than 24 hours into my Palm Pre experience and I'm liking the device but thinking it is going back. Here's my situation with my hosted Exchange and Pre setup...

    Exchange ActiveSync configuration on Pre:
    email: <myname@mycompany.com>
    server: <https://webmail.myisp.com>
    domain: <XYZ>
    username: <myname>

    As configured above, Exchange access works just fine. Everything synchs, folders and messages are seen, etc. BUT, major flaw is that, instead of using <myname@mycompany.com> as my email address in outgoing messages (newly created on the Pre or replies to incoming messages), it constructs a new email address as <myname@myisp.com>. This is unacceptable, of course, as I do not want my email coming from a "myisp" address!

    In troubleshooting this, I had my ISP set up a redirect for <webmail.mycompany.com> to point to <webmail.myisp.com> and then I switched the server configuration to <https://webmail.mycompany.com> but this gave me the dreaded SSL date/time mismatch error as it didn't find a certificate for mycompany.com on the Exchange server. We do not have a certificate for mycompany.com and my ISP says that the cannot/will not install a mycompany.com certificate on their Exchange server.

    Exchange 2007 SP1 is being used. On the Pre, I have the latest firmware updates installed.

    Alas, such a simple, simple issue. Why didn't Palm just use the email address we typed in when we set up the account on the Pre? That would have been so simple. Instead they apparently are trying to stop the Pre from becoming a zombie for spamming, or something.

    Ugh. And here I struggled with my decision on the Palm Pre versus other alternatives. I finally came to the decision in my mind as "Well, I know that with Palm, the email integration with Exchange should work just fine" (as it had with my Treo 600 and 650 up until yesterday).

    Anyway, just posting this here in case other have the same problem.
  2. #2  
    Quote Originally Posted by thesamurai View Post
    Less than 24 hours into my Palm Pre experience and I'm liking the device but thinking it is going back. Here's my situation with my hosted Exchange and Pre setup...

    Exchange ActiveSync configuration on Pre:
    email: <myname@mycompany.com>
    server: <https://webmail.myisp.com>
    domain: <XYZ>
    username: <myname>

    As configured above, Exchange access works just fine. Everything synchs, folders and messages are seen, etc. BUT, major flaw is that, instead of using <myname@mycompany.com> as my email address in outgoing messages (newly created on the Pre or replies to incoming messages), it constructs a new email address as <myname@myisp.com>. This is unacceptable, of course, as I do not want my email coming from a "myisp" address!

    In troubleshooting this, I had my ISP set up a redirect for <webmail.mycompany.com> to point to <webmail.myisp.com> and then I switched the server configuration to <https://webmail.mycompany.com> but this gave me the dreaded SSL date/time mismatch error as it didn't find a certificate for mycompany.com on the Exchange server. We do not have a certificate for mycompany.com and my ISP says that the cannot/will not install a mycompany.com certificate on their Exchange server.

    Exchange 2007 SP1 is being used. On the Pre, I have the latest firmware updates installed.

    Alas, such a simple, simple issue. Why didn't Palm just use the email address we typed in when we set up the account on the Pre? That would have been so simple. Instead they apparently are trying to stop the Pre from becoming a zombie for spamming, or something.

    Ugh. And here I struggled with my decision on the Palm Pre versus other alternatives. I finally came to the decision in my mind as "Well, I know that with Palm, the email integration with Exchange should work just fine" (as it had with my Treo 600 and 650 up until yesterday).

    Anyway, just posting this here in case other have the same problem.
    Can't you just install the cert manually? That message is not really "dreaded".. it just means you need to manually add the cert...
  3. #3  
    I believe 1.0.3 allowed you to turn off SSL. I suspect that's what you're going to have to do.
  4.    #4  
    hparsons - How do you turn off SSL for an EAS account? The only thing that I can see to affect this is to change the HTTPS to HTTP in the server address line. I tried that and it complained that the username and password were invalid. For EAS, it seems to expect/require an HTTPS connection.

    mdmogren - I'm not sure how installiing a cert manually would help here. I can connect perfectly fine and sync perfectly fine (i.e., no cert issue) when I don't use a redirect address (webmail.myisp.com). But, all emails are tagged as coming from <myname@myisp.com>...which is wrong. If I DO use a redirect address (webmail.mycompany.com), I get the "dreaded error" as this address does not match the certificate on the server. I can't change the server's cert or add one. Therefore, what good would adding a cert to my phone do? It wouldn't have a match with the server anyway. Am I correctly analyzing it or not?

    Thanks!
  5. RonWood's Avatar
    Posts
    43 Posts
    Global Posts
    48 Global Posts
    #5  
    email address: me@company.com
    Incoming email server- https://webmail.hostedexchangecompany.com
    username: me@company.com
    Note that I do not have a domain in there.

    My emails come in as me@company.com when sent to someone.

    That is the setup I use for all 3 of my hosted exchange emails on my Pre. I do not have a domain name on any of them. Tried juggling some settings? Eg, no domain and changing username to be myname@mycompany.com ?

    I havn't had any issues with my exchange accounts and they are through 3 different providers.
  6. #6  
    You may want to talk to your provider.

    EAS sends messages by placing the message in your Outbox folder (just like an Outlook client) and the server grabs it and sends it with the email address defined as the Primary SMTP address on your account.

    What you put in the EAS settings is just to log onto your server and doesn't have any bearing on what the Send As address is.

    Ask the provider to see what address is being used and have them switch it if it's wrong.

    Chris.
  7. #7  
    Quote Originally Posted by thesamurai View Post
    hparsons - How do you turn off SSL for an EAS account? The only thing that I can see to affect this is to change the HTTPS to HTTP in the server address line. I tried that and it complained that the username and password were invalid. For EAS, it seems to expect/require an HTTPS connection.

    mdmogren - I'm not sure how installiing a cert manually would help here. I can connect perfectly fine and sync perfectly fine (i.e., no cert issue) when I don't use a redirect address (webmail.myisp.com). But, all emails are tagged as coming from <myname@myisp.com>...which is wrong. If I DO use a redirect address (webmail.mycompany.com), I get the "dreaded error" as this address does not match the certificate on the server. I can't change the server's cert or add one. Therefore, what good would adding a cert to my phone do? It wouldn't have a match with the server anyway. Am I correctly analyzing it or not?

    Thanks!

    I'm not sure how you turn the SSL off. I didn't have that problem, but my understanding is that 1.0.3 "fixed" the problem, so users could turn off the SSL requirement. It might be as simple as putting in HTTP instead of HTTPS

    Anyone know for sure?

Tags for this Thread

Posting Permissions