Results 1 to 3 of 3
  1.    #1  
    Is anyone else having issues setting up POP email accounts? I have no issues using gmail or other "mainstream" pop servers. Well, ok, I have only tested Gmail because I don't want to pay yahoo or anyone to just 'test'. But I have tried my own personal servers and my ISP's servers. Both of them give the same error.

    Personal Setup:
    Exchange Server 2007 SP1 (Yes, it works fine when I use EAS. I have a cert signed by GoDaddy.. I am talking POP here.)
    Incoming Server: exchange.vision5.com
    Username: ****** (I have tried DOMAIN\uname, uname@domain, UPN (uname@domain.com), etc)
    Password: ******
    Port: 110 (tried others too)
    Encryption: None (Tried TLS and SSL)
    Outgoing Server: exchange.vision5.com
    Use Auth: Yes
    Username: ****** (Same as above)
    Password: ****** (Same as above)
    Port: 25 (Tried others)
    Encryption: None (Tried TLS and SSL)

    ISP:
    Unknown Server
    Incoming Server: pop.central.cox.net (they don't offer IMAP)
    Username: ****** (just the part before the @ sign.. also tried email)
    Password: ******
    Port: 110 (tried others too)
    Encryption: None (Tried TLS and SLL)
    Outgoing Server: smtp.central.cox.net
    Use Auth: Yes
    Username: ****** (Same as above)
    Password: ****** (Same as above)
    Port: 25 (Tried others)
    Encryption: None (Tried TLS and SSL)


    I can telnet to port 110 on both servers and issue USER and PASS commands just fine. It logs me in and lets me view mail.

    But from the Pre I get: "Error. Unable to validate account settings. Please check the settings and try again"

    Yes, it is missing the "." after "again". LOL.. But regardless, I get that no matter what combination of settings I use. I work for a communications company and have a degree in telecommunications management, so I know how to set this stuff up. I am just wondering if there is something buggy in the email client? Any ideas?
    Last edited by dBsooner; 06/22/2009 at 01:39 AM.
  2. #2  
    Quote Originally Posted by decibel View Post
    Is anyone else having issues setting up POP email accounts? I have no issues using gmail or other "mainstream" pop servers. Well, ok, I have only tested Gmail because I don't want to pay yahoo or anyone to just 'test'. But I have tried my own personal servers and my ISP's servers. Both of them give the same error.

    Personal Setup:
    Exchange Server 2007 SP1 (Yes, it works fine when I use EAS. I have a cert signed by GoDaddy.. I am talking POP here.)
    Incoming Server: exchange.vision5.com
    Username: ****** (I have tried DOMAIN\uname, uname@domain, UPN (uname@domain.com), etc)
    Password: ******
    Port: 110 (tried others too)
    Encryption: None (Tried TLS and SSL)
    Outgoing Server: exchange.vision5.com
    Use Auth: Yes
    Username: ****** (Same as above)
    Password: ****** (Same as above)
    Port: 25 (Tried others)
    Encryption: None (Tried TLS and SSL)

    ISP:
    Unknown Server
    Incoming Server: pop.central.cox.net (they don't offer IMAP)
    Username: ****** (just the part before the @ sign.. also tried email)
    Password: ******
    Port: 110 (tried others too)
    Encryption: None (Tried TLS and SLL)
    Outgoing Server: smtp.central.cox.net
    Use Auth: Yes
    Username: ****** (Same as above)
    Password: ****** (Same as above)
    Port: 25 (Tried others)
    Encryption: None (Tried TLS and SSL)


    I can telnet to port 110 on both servers and issue USER and PASS commands just fine. It logs me in and lets me view mail.

    But from the Pre I get: "Error. Unable to validate account settings. Please check the settings and try again"

    Yes, it is missing the "." after "again". LOL.. But regardless, I get that no matter what combination of settings I use. I work for a communications company and have a degree in telecommunications management, so I know how to set this stuff up. I am just wondering if there is something buggy in the email client? Any ideas?
    I get the same error when I try to re-add my MSN account on the Pre.

    Note that I had both Gmail and MSN mail on the Pre when I first activated the phone. But it was getting very hot, and the battery was dying out in a couple of hours while syncing these accounts. So I removed MSN where I have a large amount of contacts and email.

    Now that I have updated the OS to 1.0.3, I want to add MSN back, but it keeps giving me the error: "unable to validate settings..."

    Does this have to do with the new update?
  3.    #3  
    Ok.. I have more info on this. Tonight I tested all the settings using WiFi. Since I have Cox as my ISP, I MUST use smtp.central.cox.net as the outgoing mail server, regardless of what incoming server I use or email address i want in the "from" field. Cox blocks all outgoing traffic on port 25 unless it is destined to one of their SMTP servers. Well, to my astonishment, as long as I put in Cox's SMTP server, it worked. Able to send and receive pop email. So, that got me thinking. Maybe, just maybe, it's the same for Sprint (though why would it be? Maybe the Pre is on a new style IP assignment and rules?)

    So I tried it. I logged into my sprint.com. Clicked "My Online Tools" and I went to "Create/Change Password" for "Email Server Password" under "Productivity Tools". To my surprise it let me enter a password and actually saved it.

    The odd thing is it listed my email address as "null". In other words, there was no email address assigned. This is more than likely because "PCS Mail" has been removed from Sprints features for a while now. But I figured since it saved a password, it probably used my NAI as the email address. So, I changed the outgoing server info to:

    Outgoing Server: smtp.sprintpcs.com
    Use Authentication: Yes
    Username: blahblah@sprintpcs.com (find this in your "Device Info"->"More Info"->"NAI" (At bottom)
    Password: ****** (whatever you set it to under online tools @ sprint.com)
    Port: 25
    Encryption: None

    And boom.. worked. Sync'd just fine.. This poses one issue though: If I turn on WiFi with smtp.sprintpcs.com listed as the outgoing server, COX will block that message. It won't allow traffic to be sent to smtp.sprintpcs.com on port 25. It has to be set to go to smtp.central.cox.net. I think the only real fix for this would be to have Sprint (or is it Palm blocking it in the software routing tables?? You rooters try "iptables" if its available. See if they are dropping traffic on port 25 if its not destined to smtp.sprintpcs.com.) unblock port 25 traffic.

    More to come.. I hope I get more help on this issue, or have some Palm expert chime in.



    OK... I have figured out more...



    Since they block port 25 in some form or fasion, it's time to try port 465 (SSL). Welp, that works just fine without having to use the above SPRINT crap. The problem with my COX ISP setup was the SMTP.CENTRAL.COX.NET is the same as SMTP.EAST.COX.NET... meaning same IP, same machine. Well, that throws the SSL cert off. When the Pre tries to connect to SMTP.CENTRAL, it expects that to be the server reply. NOPE.. It would give its address as SMTP.EAST. So I changed my outgoing settings to SMTP.EAST.COX.NET, Use Auth: ON, Cox Username, Cox Password, Port 465, SSL. Viola! Worked!! This will work through my WiFi as well since its a Cox outgoing server.



    As for my personal pop server, same thing. I had an issue with SSL cert not matching properly. I corrected this and bingo, it worked as well on port 465. So, in conclusion, it looks as if Palm has some sort of firewall software running (I would assume Iptables) that is dropping traffic on port 25 that is not destined to smtp.sprintpcs.com. Why? No clue. Or, Sprint has assigned a new IP range/policy to the Pre's that is preventing port 25 traffic not destined to smtp.sprintpcs.com. Again, I think it is more the Pre (Palm) doing it, not Sprint.



    Now that I have this fixed up. I am out! Later!
    Last edited by dBsooner; 06/22/2009 at 01:38 AM.

Posting Permissions